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1 INTRODUCTION

1

GiD is an interactive graphical user interface used for the definition, preparation and visualization of all 

the data related to a numerical simulation. This data includes the definition of the geometry, materials, 

conditions, solution information and other parameters. The program can generate a mesh for finite 

element, finite volume or finite difference analysis and write the information for a numerical simulation 

program in its desired format. It is also possible to run these numerical simulations from within GiD and 

then visualize the results of the analysis.

GiD can be customized and configured by users so that the data required for their own solver modules 

may be generated. These solver modules may then be included within the GiD software system.

The program works, when defining the geometry, in a similar way to a CAD (Computer Aided Design) 

system but with some differences. The most important of these is that the geometry is constructed in a 

hierarchical mode. This means that an entity of higher level (dimension) is constructed over entities of 

lower level; two adjacent entities will then share the same lower level entity.

All materials, conditions and solution parameters can be defined on the geometry itself, separately from 

the mesh as the meshing is only done once the problem has been fully defined. The advantages of this 

are that, using associative data structures, modifications to the geometry can be made and all other 

information will automatically be updated and ready for the analysis run.

Full graphic visualization of the geometry, mesh and conditions is available for comprehensive checking 

of the model before the analysis run is started. More comprehensive graphic visualization features are 

provided to evaluate the solution results after the analysis run. This postprocessing user interface can 

also be customized depending on the analysis type and the results provided.

1.1 Using this manual

This manual has been split into five clearly differentiated parts.

The first part, General aspects, provides information on the basic aspects of the program. In this way, 

you can gain confidence and become more familiar with the system in order to take advantage of all the 

available facilities.

The second part, Preprocessing, describes the preprocessing functionality. You will learn how to 

configure a project and define all its components - geometry, data and mesh.

The third part, Analysis, concerns to the calculation process. Although it will be performed by an 

independent solver, it forms part of the integrated GiD system in that the analysis can be run from inside 

GiD.

The fourth part, Postprocessing, emphasizes aspects relating to the visualization of results.

The fifth part, Customization, explains how to customize your files so that you can introduce and run 

different solver modules according to your own requirements.

Different kinds of fonts are used to help you follow all the possibilities offered by the code:
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1 font is used for the options found in the menus and windows and for literal code.

2 font is used for special references in some parts.
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GiD is a geometrical system in the sense that, having defined the geometry, all the attributes and 

conditions (i.e. material assignments, loading, conditions, etc.) are applied to the geometry without any 

reference to a mesh. Only when everything has been defined is the meshing of the geometrical domain 

carried out. This methodology facilitates alterations to the geometry while maintaining the definitions of 

the attributes and conditions. Alterations to the attributes or conditions can be made simultaneously 

without needing to reassign the geometry. New meshes can also be generated if necessary and all the 

information will automatically be assigned correctly.

GiD also provides the option of defining attributes and conditions directly to the mesh once it has been 

generated. However, if the mesh is regenerated, it is not possible to maintain these definitions and 

therefore all attributes and conditions must then be redefined.

In general, the complete solution process can be defined as:

1 define geometry - points, lines, surfaces, volumes;

2 use other facilities;

3 import geometry from CAD;

4 define attributes and conditions;

5 generate mesh;

6 carry out simulation;

7 view results.

Depending upon the results in step (5) it may be necessary to return to one of the previous steps to 

make alterations and re-run the simulations.

Building a geometrical domain  in GiD is based on four levels of geometrical entity: points, lines, 

surfaces and volumes. Entities of higher level are constructed over entities of lower level; two adjacent 

entities can therefore share the same level entity. Here are a few examples:

Example 1: One line has two lower level entities (points), each of them at an extreme of the line. If 

two lines are sharing one extreme, they are really sharing the same point, which is a unique entity.

Example 2: When creating a new line, what is really being created is a line plus two points or a line 

with existing points created previously.

Example 3: When creating a volume, it is created over a set of existing surfaces, which are joined to 

each other by common lines. The lines are, in turn, joined to each other by common points.

All domains are considered in 3-dimensional space but if there is no variation in the third coordinate (into 

the screen) the geometry is assumed to be 2-dimensional for the purposes of analysis and the 

visualization of results. Thus, to build a geometry with GiD, the user must first define the points, join 

these together to form lines, create closed surfaces from the lines and define closed volumes for the 

surfaces. Many other facilities are provided for creating the geometrical domain; these include: copying, 

moving points, automatic surface creation, etc.

The geometrical domain can be created in a series of layers where each one is a separate part of the 
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geometry. Any geometrical entity (points, lines, surfaces or volumes) can belong to a particular layer. It 

is then possible to view and manipulate some layers and not others. The main purpose of these layers is 

to offer a visualization and selection tool as they are not used in the analysis. An example of the use of 

layers might be a chair where the four legs, seat, backrest and side arms are the different layers.

With GiD you can import a geometry or mesh created with an external CAD program. The formats 

supported at present are: DXF, IGES, Parasolid, ACIS, VDA, Rhino, Shapefile, STL, VRML, 3DStudio 

and NASTRAN.

Attributes and conditions are applied to the geometrical entities (points, lines, surfaces and volumes) 

using data input dialog boxes. These menus are specific to the particular solver that will be employed for 

the simulation and, therefore, the solver needs to be defined before attributes are defined. The form of 

these menus can also be configured for the user's own solver module, as is explained below and later in 

this manual.

Once the geometry and attributes have been defined, a mesh can be generated using the mesh 

generation tools supplied within the system. Structured and unstructured meshes containing triangular 

and quadrilateral surface meshes or tetrahedral and hexahedral volume meshes may be generated. The 

automatic mesh generation facility uses a background mesh concept for which the user is required to 

supply a minimum number of parameters.

Simulations  are carried out from within GiD by using the calculate  menu. Indeed, specific solvers 

require specific data that must have been prepared previously. A number of solvers may be 

incorporated together with the correct preprocessing interfaces.

The final stage of graphic visualization is flexible in order to allow the user to critically evaluate the 

results quickly and easily. The menu items are generally determined by the results supplied by the 

solver module. This not only reduces the amount of information stored but also allows a certain degree 

of user customization.

One of the major strengths of GiD is that the user can define and configure his own graphic user 

interface within GiD. The first step is to create some configuration files which define new windows, 

where the final user will enter data, such as materials or conditions. The format that GiD uses to write a 

file containing the necessary data in order to run the numerical simulation program must also be defined 

in a similar way. This preprocessor or data input interface will thus be tailored specifically to the user's 

simulation program, but employing the facilities and functionality of the GiD system. The second step is 

to include the user's simulation program within GiD so that it may be run utilizing the calculate menu 

option. The third step consists of writing an interface program, or using the 'gidpost' library, which 

provides the results information in the format required by the GiD graphic visualizer, thereby configuring 

the postprocessing menus. This post-analysis interface may be included fully in the GiD system so that 

it runs automatically once the simulation run has terminated.

Details on this configuration can be found in later chapters.
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When installing GiD on Windows, the useful way is to start GiD from desktop icon:

There is also added a direct access from the programs list of the start menu.

An special option is to start 'GiD safe mode', then a window will be open to ask the user to select how to 

handle OpenGL graphics: by software or by hardware (some graphic cards and drivers have problems 

with the hardware option, the screen can show corrupted images or even GiD can crash)

It's possible to change this options by clicking on  /  in the bottom right corner of GiD window 

When starting the GiD program from a shell or script it is possible to supply several options in the same 

command line.

With

gid -help

the program will list the possible command line options.

Command line syntax:

gid [-b[{+/-}g][{+/-}i][{+/-}w] batchfile] [-t tcl_command] [-h] [-p problem] [-e cmd] [-n] [-n2] 

[-c][-c2] [filename]

All options and filename are optional. filename is the name of a problem to be opened (the .gid 

extension is optional).

Options are:
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-b batchfile  executes batch_file as a script file (see Batch file -pag. 34- ). 

+/- g  Enable/Disable Graphics (if -g, GiD does not redraw until the batch file has finished). 

+/- i  Enable/Disable GraphInput (enable or disable peripherals while the batch file is being executed: 

mouse, keyboard, etc.). 

+/- w   Enable/Disable Windows (GiD displays - or does not display - windows which require 

interaction with the user). 

-h  shows GiD's command line arguments. 

-t tcl_command  to evaluate tcl code just after read the filename if it has been specified 

example:

gid -t "WarnWinText [GiD_Info Project]" C:\temp\myexample

-p problem  loads problem as the type of the problem to be used for a new project. 

-e cmd  can continue until the end of the line. It executes anything as if it were a group of commands 

entered into GiD. 

-n  runs the program without any window. It is most useful when used with the option batchfile. Tcl is 

loaded but not Tk and most GiD scripts. 

-n2  runs the program with minimized window, the Tk  library and GiD scripts are loaded. This option 

is useful if you use Tcl and maybe Tk commands in a batch file. 

-c conffile  takes the window configuration from conffile. (See Save window configuration -pag. 100-

  for information about window configuration). 

-c2 inifile  to use an alternative user configuration file, instead the default 'gid.ini' (to not share this file 

between problemtypes or versions) 

-openglconfig (Only for Windows ): this allows you to choose between the accelerated OpenGL, if 

present, or the generic implementation, if you experience troubles using the accelerated libraries of 

the graphics card. 

Note: by default, when running a batch file from the command line or importing a Batch file -pag. 34-

 from the 'Files->Import' menu, graphics are disabled, and then for example is not possible to save an 

snapshot in a file. To enable graphic features use gid -b+g batchfile 

On the other hand when reading a file with the Read batch window -pag. 101-  graphics are enabled. 

Other useful options are:

gid -compress [ -123456789ad] file_name_in file_name_out

in order to compress (gzip) a file, e.g. to compress '.dat' files or new postprocess formatted data files.

And:

gid [ -PostBinaryFormat { 1.0 / 1.1}] -PostResultsToBinary file_in file_out

in order to transform ASCII results files into compressed binary ones. You can select whether to use the 

binary format 1.0 or 1.1. The default format (recommended) is 1.1.

3.1 Settings

GENERIC SETTINGS

\plugins folder
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It is possible to extend GiD with new features implemented in Tcl scripting language, by adding this .tcl 

files to the folder \plugins of GiD

All Tcl files inside this folder will be automatically sourced when starting GiD.

It is hightly unrecommended to modify or add any script to the \scripts GiD folder, because this changes 

will be lost when installing new versions.

\templates folder

All .bas files of this folder will be showed in the Files->Export->Using template .bas (only mesh) menu

This .bas templates are text files with a syntax explained in the Template File  section, used to export 

GiD data of mesh (and maybe other attached data). 

dump.bas is an example template that write in a simple way most of the GiD mesh and attached data 

information.

\problemtypes folder

This folder must contain customizations of GiD to handle external third part solvers (see 

CUSTOMIZATION)

USER SETTINGS

Each user has its own copy of some GiD settings (like preferences variables, or window sizes). 

This information is saved in a file named 'gid.ini' that is stored in a different place depending on the 

platform

e.g. 

Windows XP: C:\Documents and Settings\<current user>\Application Data\GiD\gid.ini

Windows Vista: C:\Users\<current user>\AppData\Roaming\GiD\gid.ini

Linux/Mac OS X: $(HOME)/.gidDefaults

And by default some folders like "Application Data" are hidden.

This settings are automatically saved when exiting GiD, and loaded when starting.
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The user interface allows you to interact with the program. It is composed of buttons, windows, icons, 

menus, text entries and the graphical output of certain information. You can configure the interface to 

display things in a certain way, and may use as many menus and windows as required.

The initial layout of GiD is consists of a large graphical area with pull-down menus at the top, a 

command line at the bottom, a message window above it and an icon bar. The project that is being run 

is displayed in the window title bar. The pull-down and 'click on' menus are used to access GiD 

commands quickly. Some of them offer a shortcut for easier access - these are activated by holding the 

Ctrl  key and pressing the appropriate letter key(s). 

Right-clicking the mouse while the cursor is over the graphical area opens an on-screen menu with 

some visualization options. To select one of them, right- or left-click on the option; to quit, left-click 

anywhere outside the menu.

The first option in this menu is called Contextual . It will give different options depending on the function 

currently being used. 

The pair of icon bars contain some facilities that also appear in the graphical area of the window or in 

the menu bar. When left-clicking on the icon, the corresponding command is performed or an icon menu 
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with several options will be shown. When right-clicking (or using the center button if there is one), a 

menu with the options help and configure toolbars will appear allowing you to get a description of the 

icon or to configure the position of the toolbars. The description also appears when the cursor remains 

over the icon for a couple of seconds.

To configure the position and view of the toolbars, the Toolbars position   window can be called from 

Utilities -> Tools -> Toolbars, or by right-clicking over a toolbar. 

Using the Toolbars position  window it is possible to enable the Right buttons  menu. Only advanced 

users should use these buttons. 

Toolbars window

The Standard bar  has common options for both pre- and postprocessing components, including: open, 

take a snapshot, print, preferences, help, exit and others. 

Standard toolbar in preprocess

Standard toolbar in postprocess

The different icons represent, from left to right:

New: PRE: the existing project is closed and a new one is created. POST: the model is closed.

Open: PRE: closes the current project and opens an existant one. POST: closes the current model 

and reads an existant mesh with its results.

Save: PRE: saves de project. POST: saves de postprocess information in a new binary file.

Previous view, Next view: no navigate through the used views

List of views: shows a list of some predefined and user-saved views
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Take a snapshot: takes a picture of the current visualization, using the Page/Image setup -pag. 39-

  options 

Print: print using the the Page/Image setup -pag. 39-  options 

Toggle between preprocess and postprocess

Copy: PRE: shows the copy window, POST: shows the transformation window.

Layers/Meshes/Sets: PRE: pops-up the 'Layer' window, POST: pops-up the 'View Style' window (not 

implemented)

(only in preprocess): Combobox to select layer in use 

Preferences: pops-up the preferences window to select general, meshing, graphical, fonts options, 

among others

Help: shows GiD's help

Exit: quits the program.

(only in postprocess) Labels indicating: numbers of nodes, number of elements, render type, 

transparency and units.

GiD icon that show also our current passwort type: green=profesional, red=evaluation, 

orange=conection fault short time period of profesional version before change to evaluation.

The Geometry & view bar  has some of the view options common to pre- and postprocessing, such as 

zooming, panning, rotating, etc. But certain icons are specific to preprocessing and others to 

postprocessing. 

Geometry & View bar in preprocess

The different icons represent, from left to right:

Zoom in: zooms the project in

Zoom out: zooms the project out

Zoom frame: adjust the visualization to comprise the whole model

Redraw: redraws the model, useful if the graphical window gets 'dirty'

Rotate trackball: rotates de model dynamically using the mouse as 'spaceball'

Pan dynamic: translates the model dinamycally

Create line: as is

Create arc: as is

Create NURBS line: as is

Create polyline: as is

Create NURBS surface: as is

Create volume: as is

Create object (rectangle, polygon, circle, sphere, cylinder, cone, prism, torus): as is

Delete: specific types of entities o all types of entities

List entities: shows information of the selected entities

Toggle between geometry view and mesh view

Note:  The position of the icons depends on how the window is positioned. 
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If you left-click on Delete, GiD opens another window with the different entities to be deleted: Point, 

Line, Surface, Volume or All types.

If you left-click on List entities, GiD opens another window with the different entities able to be listed: 

Points, Lines, Surfaces or Volumes.

Geomety & View bar in postprocess

On the postprocess toolbar, the first six commands are the same as on the preprocess toolbar, i.e. from 

Zoom in to Pan.

The remaining icons represent, from left to right:

Change Light Vector: allows you to change the light direction (see Render -pag. 47- ). 

Display style: when you click here, a menu appears with each icon corresponding to a display option: 

Boundaries, Hidden Boundaries, All Lines, Hidden Lines, Body, Body Boundaries, Body Lines, points 

or BoundaryPoints

Culling: allows you to switch on or switch off the front faces and/or the back faces.

Mesh selection: select the volumes to switch them on or off

Set selection: select the surface sets to switch them on or off

Cut selection: select the cuts to switche them on or off

Cut meshes/sets: cut the volume or surface meshes

Set maximum value: set a maximum value for contour fills

Set minimum value: set a minimum value for contour fills

Reset maximum and minimum values: reset the above fixed values

List nodes and elements information: list information (conectiviti, set number, results, etc.) about 

selected nodes or elements

Notes:

If windows are used to enter the data, it is generally necessary to accept  this data before closing the 

window. If this is not done, the data will not be changed. 

Usually, commands and operations are invoked by using the menus or mouse, but all the information 

can be typed into the command line.

When an option is selected and a secondary window is opened, it generally appears over the main 

window and cannot be hidden by it. This behaviour can be changed by deselecting the Always on top 

flag in the Window system menu (right-click on the window title bar to do this).

The Macros bar  allows the creation and execution of macros defined by the user or predefined by GiD: 

Macros icon bar

Record macro / stop recording macro: stars a new macro and registers each operation in GiD until 
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stop is pressed.

Edit macros...: a windo will pop-up allowing the user to edit the macro, rename it or change its icon 

and accelerator keys.

The View results bar allow the user a quick view of the results:

View result bar

it's fully explained at View Results Bar -pag. 174-

4.1 Mouse operations

As well as selecting the functions to be used, the left mouse button is used to select entities, either 

individually or picking several within a given area (see Entity selection -pag. 21-), and to enter points in 

the plane z=0 (see Point definition -pag. 17-).

The middle mouse button is equivalent to escape (see Escape -pag. 23-).

The right mouse button opens an on-screen menu with some visualization options. To select one of 

them, use the left or right mouse button; to quit, left-click anywhere outside the menu.

The first option in this menu is called Contextual. You can select from different options relevant to the 

function currently being used.

When the mouse is moved to different windows, depending on the situations, different cursor shapes 

and colors will appear on the screen.

In some windows a help option will appear when you click the middle or right mouse buttons over an 

icon.

4.2 Command line

All commands may be entered via the command line (found at the bottom of the GiD window) by typing 

the full name or only part of it (long enough to avoid confusion with other commands); commands are 

not case-sensitive. Any function from the Right buttons menu can be used by typing all or part of its 

name in the command line. Special commands are also available for viewing (zoom, rotation and so on) 

and these can be typed or used at any time when working from within another function. A list of these 

special commands is given in View (see VIEW -pag. 43-).

Commands entered by typing are word oriented. This means that the same operation is achieved if one 

writes the entire command and then presses enter or if one writes a part of it, presses enter and then 

writes the rest.

All these typed commands can be retrieved using of the up arrow (to recover past commands) and down 

arrow (to return to more recent commands).
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The following features are essential to the effective use of the GiD system. They are, therefore, 

described apart from the preprocessing facilities section.

5.1 Point definition

Many functions inside GiD need points to be defined by the user. Points are the lowest level of 

geometrical entity and therefore the most commonly used. Consequently, it is important that you have a 

thorough understanding of how to do this. Sometimes an existing point is required and sometimes a new 

point must be defined.

Window for entering coordinates

All the options explained in this section are available through the window shown above (see Coordinates 

window -pag. 100-). This window is accessed via the pull-down menu Utilities -> Tools. Here you can 

choose not only the kind of reference system - cartesian, cylindrical or spherical - but also whether to 

use a global or local coordinate system and whether the origin of coordinates is fixed or relative (where 

new coordinates are relative to the last origin point entered).

In general you can enter points in the following ways:

1 Picking in the graphical window.

2 Entering points by coordinates.

3 Selecting an existing point.

4 Using the Base button.

5.1.1 Picking in the graphical window

Points are picked in the graphical window in the plane z=0 according to the coordinates viewed in the 

window. Depending on the activated preferences (see Preferences -pag. 81-), if you select a region 
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located in the vicinity of an existing point, GiD asks whether it should create a new point or use the 

existing one.

5.1.2 Entering points by coordinates

GiD offers a window for entering points in order to create geometries easily, defining fixed or relative 

coordinates as well as different reference systems - cartesian, cylindrical or spherical.

The coordinates of a point can be entered either in the enter points window or in the command line by 

following one of two possible formats:

1 The format: x,y,z

2 The format: x y z

Coordinate z can be omitted in both cases.

The following are valid examples of point definitions:

5.2,1.0 5.2,1

8 9 2 8 9,2

All of a point's coordinates can be entered as local or global and through different reference systems in 

addition to the cartesian one.

1 Local/global coordinates

2 Cylindrical coordinates

3 Spherical coordinates

5.1.2.1 Local/global coordinates

Local coordinates are always considered relative to the last point that was used, created or selected. 

The Utilities -> Id command allows you to make a reference to one point (see Id -pag. 115- ). Then, to 

define points using local coordinates referring to the same point, use Options and Fixed Relative when 

entering each point. The last point selected or created before using this will be the origin of the local 

coordinate system. It is also possible to enter this central point by its coordinates. 

The following are valid examples of defining points using local coordinates:

Example (1):

                           1,0,0

                                 @2,1,0 (actual coordinates 3,1,0)

                                 @0,3,0 (actual coordinates 3,4,0)

                                 2,2,2

                                 @1,0,3 (actual coordinates 3,2,5)

Example (2): 

                           1,0,0
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                                 Fixed Relative (when creating the point) 

                                @2,1,0 (actual coordinates 3,1,0)

                                 @0,3,0 (actual coordinates 1,3,0)

                                 2,2,2

                                 @1,0,3 (actual coordinates 2,0,3)

Example (3):

                           'local_axes_name'2.3,-4.5,0.0

The last example shows how to enter a point from a local coordinate system called 'local_axes_name' 

(any name inside the quotation marks will work), previously defined via the option define local axes (see 

Local axes -pag. 126- ). 

All the examples have been presented using a cartesian notation. However, cylindrical or spherical 

coordinates can also be used.

5.1.2.2 Cylindrical coordinates

Cylindrical coordinates can be entered as: r<angle,z

The z_coordinate may be omitted and angles are defined in degrees. Cylindrical coordinates can be 

applied to global and local coordinate systems.

The following are valid examples of the same point definitions:

example (1):

                                 1,0,0

                                 1.931852<15

example (2):

                                 1,0,0

                                 @1.0<30

5.1.2.3 Spherical coordinates

Spherical coordinates can be entered as r<anglexy<anglez

Anglez may be omitted and angles are defined in degrees. Spherical coordinates can be applied to 

global and local coordinate systems.

The following are valid examples of the same point definitions:

Example (1):

                                 1,0,0

                                 1.73205<18.43495<24.09484
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Example (2):

                                 1,0,0

                                 @1.0<45<45

5.1.3 Base

Mouse menu: Contextual->Base

If the Base button is selected (it is set by default to No Base), a point can be retrieved from any of the 

other modes. Then, the coordinates of this point, instead of being used immediately, are written in the 

command line and can be edited before they are confirmed.

It is possible to change the way that GiD works with points by default via preferences (see Preferences 

-pag. 81-).

5.1.4 Selecting an existing point

Menu: Contextual->Join Ctrl-a

When using a function that asks for a point, e.g. line creation, GiD will expect you either to enter a new 

point (the cursor is a cross) or select an existing one (the cursor is a box). To change from the first mode 

to the second, click the Join button in the Right buttons menu or the Contextual mouse menu, or use 

the shortcut (Ctrl-a); the option will then change to No Join. Simply select an existing point to pick it. 

(Ctrl-a) switches from Join to No Join and vice versa.

The special options FJoin and FNoJoin force GiD to change either to Join mode or No Join mode 

independently of the previous mode.

5.1.5 Point in line

Mouse menu: Contextual->Point in line

With this option selected, when creating a new point or line, etc., you can only select points that lie on 

existing lines. To switch it off, simply select No Point in line.

5.1.6 Point in surface

Mouse menu: Contextual->Point in surface

With this option selected, when creating a new point or line, etc., you can only select points that lie on 

existing surfaces. To switch it off, simply select No Point in surface.

5.1.7 Tangent in line

Mouse menu: Contextual->Tangent in line

Using this option, you can pick over a line in the graphical window. A vector will be returned that is the 

tangent to the line at the point you have picked.
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5.1.8 Normal in surface

Mouse menu: Contextual->Normal in surface

Using this option, you can pick over a surface in the graphical window. A vector will be returned that is 

the normal to the surface at the point you have picked.

5.1.9 Arc center

Mouse menu: Contextual->Arc center

Using this option, you can left-click on an arc in the graphical window and a point will be created at its 

center.

5.1.10 Grid

It is possible to use an auxiliary grid of lines to define 2D points easily. The 'snap' function can be 

activated to force points to grid intersections.

From the preferences window (see Preferences -pag. 81-) it is possible to set the separation between 

lines and to show the origin, extents, etc. of the coordinates.

There is a small button in the bottom right-hand corner that activates or deactivates the grid and 'snap' 

functions.

5.2 Entity selection

Many commands need to be supplied with entities before they can be applied and the method of 

selection is always the same. Before selecting entities, you are prompted to decide whether to select 

points, lines, surfaces or volumes (in some cases this decision is obvious or it is made within the context 

of the option).

Within one of the generic groups (points, lines, surfaces, volumes, nodes or elements) it does not matter 

what type of entity is selected (for example, an arc or a spline, both line entities are selected in the same 

way). After this, if one entity of the desired group is selected, it is colored red to indicate it has been 

selected and you are prompted to enter more entities. If you select away from any entity, a dynamic box 

is opened that can be defined by picking again in another place. All entities that are either totally or 

partly within this box are selected. Once again, you are then prompted to enter more entities. 

The normal selection mode is SwapSelection: If one entity is selected a second time, it becomes 

deselected and its color reverts to normal. In addition there are the options AddToSelection and 

RemoveFromSel, the former always adding to the selection, the latter always removing entities from the 

selection.

Note:  Instead of picking a start point and an end point for the selection box, it is possible to press and 

hold left mouse and move the cursor.

The Clear selection option, which is found in the Contextual  mouse menu, deselects all previously 
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selected entities.

It is also possible to select entities by entering their label in the command line. For instance, to select the 

entity with number 2, input this number, 2, in the command line. To select the entities 3 to 7, input 3:7 in 

the command line. Entering 3: will select all entities from number 3 to the end and entering :3 will select 

all options from the beginning to number 3.

If a layer named 'a'  exists, it is possible to select all entities belonging to that layer with command: 

layer:a . Using the command layer: selects all entities not belonging to any layer.

Another way of selecting points or nodes is to write:

plane:a,b,c,d,r

where a,b,c,d and r are real numbers that define a plane and a tolerance in the following way: 

ax+by+cz+d<r. Points close to that plane are chosen.

When selection lines or surfaces (geometry or mesh) it is possible to pick one or more entities, and use 

'ConnectedTangent' to select its connected neighbor entities, if the angle between them is smooth 

enougth. This is very interesting for example to select coplanar parts.

It is possible select a group on entities that are parents of a single 'lower entity' by using 'ParentsOf', and 

selecting the lower entity. (e.g. to select all surfaces that are sharing some line)

In some commands, another item is added to the selection group. This item, called AllTypes, means that 

entities of all levels (points...volumes) will be selected at the same time. In this case, only selection via a 

dynamic box is possible in the graphical window and all entities (points, lines, surfaces and volumes) in 

the box are selected.

To finish the entity selection, use escape (see Escape -pag. 23-).

If the Fast Selection option is used, entities are not colored red when selected and choosing an entity 

twice does not deselect it. This option is available via the Right buttons menu (see Tools -pag. 99-), in 

Utilities -> Variables.

Caution: Only use Fast Selection when you need to select a large number of entities, for example in a 

large mesh, as there is a risk of repeating entities.

Entities belonging to frozen layers (see Layers -pag. 95-) are not taken into account in the selection. 

Entities belonging to OFF layers cannot be selected directly in the graphical window, but can be 

selected by giving a number or range of numbers.

It is possible to add filters to the selection so that, after selecting some entities, only the ones satisfying 

the filter criteria will remain selected. To enter one filter, you must enter the word filter: in the command 

line followed by one option. The available options are:

HigherEntity

MinLength

MaxLength

EntityType

BadMinAngle
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BadMaxAngle

NumSides

Note: To apply selection filters you can also use the Selection window (see Selection window -pag. 

104-).

Note: MinLength and MaxLength can be used either in geometry lines or in elements of the mesh.

Note:  NumSides=x can be used for surfaces or volumes, to filter the entities with exactly x number of 

sides.

For example, the following command:

filter:HigherEntity=1

means that only the entities that have higher entity equal to one will be selected.

Note: A typical use of filter is to select only boundary lines (higherentiety=1).

5.3 Escape

The escape command is used for moving up a level within the Right buttons menus, for finishing most 

commands, or for finishing selections and other utilities. This command can be applied by:

1 pressing the middle mouse button;

2 pressing the ESC  key; 

3 pressing the escape button in the Right buttons menu;

4 writing the reserved word escape in the command line. This is useful in scripts (see Batch file -pag. 

34- ). 

All the above options give the same result.

Caution: Escape  is a reserved word. It cannot be used in any other context. 
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Browser to read and write files and projects

GiD includes the usual ways of saving and reading saved information (Save, Read) as well as other 

operations, such as importing external files, saving in other formats and so on.

6.1 New

Menu: Files->New

Toolbar:

New

Selecting New opens a new project with no title assigned to it.

If a project is currently open and changes have been made since it was last saved, GiD will give the 

option to save before opening the new project.

6.2 Open

Menu: Files->Open

Toolbar:

Open

With this command, a project previously saved with Save (see Save -pag. 26-) or with Save ASCII 

project (see ASCII project -pag. 37-) can be opened.

Generally, there is no difference between using a project name with the .gid extension or using one 

without it.
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6.3 Save

Menu: Files->Save...

Toolbar:

Save

Using the Save command saves all the information relating to a project - geometry, conditions, 

materials, mesh, etc. - to the disk.

When a project is saved, GiD creates a directory with the project name and the extension .gid. Files 

containing all the information are written to this directory. Some of these files are binary and others are 

ASCII. You can then work with this project directory as if it were a file.

You do not need to write the .gid extension because it will automatically be added to the directory name.

Caution:  Be careful if changing some files manually in the Project .gid directory. If done in this way, 

some information may be corrupted.

Advice:  It is advisable to save the project at regular intervals so as not to lose any important 

information. It is possible to back up files automatically by selecting this option in the Preferences menu 

(see Preferences -pag. 81-).

6.4 Save as

Menu: Files->Save as...

With this command, GiD allows you to save the current project with another name.

When it is selected, an auxiliary window appears with all the existing projects and directories to facilitate 

the introduction of the project's new name and directory.

6.5 Import

GiD lets you import geometrical models or meshes in the following formats.

6.5.1 IGES

Menu:  Files->Import->IGES... 

With this option it is possible to import a file in IGES format (version 5.3); GiD is able to read most of the 

entities, which are:

Entity number and type (Notes)

100 Circular arc

102 Composite curve

104 Conic arc (ellipse, hyperbola and parabola)

106 Copious data (forms 1, 2, 12 and 63)
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108 Plane (form1 bounded)

110 Line

112 Parametric spline curve

114 Parametric spline surface 

116 Point

118 Ruled surface

120 Surface of revolution

122 Tabulated cylinder

123 Direction

124 Transformation matrix (form 0)

126 Rational B-spline curve 

128 Rational B-spline surface 

134 Node

136 Element

140 Offset surface entity

141 Bounded entity

142 Curve on a parametric surface

143 Bounded surface

144 Trimmed surface

184 Solid assembly

186 Manifold solid B-rep object 

190 Plane

192 Right circular cylindrical surface

194 Right circular conical surface entity 

196 Spherical surface

198 Toroidal surface

308 Subfigure definition

314 Color definition

402 Associativity instance

406 Property entity

408 Singular subfigure instance

502 Vertex

504 Edge

508 Loop

510 Face
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514 Shell

The variable ImportTolerance (see Preferences -pag. 81- ) controls the creation of new points when an 

IGES file is read. Points are therefore defined as unique if they lie further away than this tolerance 

distance from another already defined point. Curves are considered identical if they have the same 

points at their extremes and the "mean proportional distance" between them is smaller than the 

tolerance. Surfaces can also be collapsed. 

Entities that are read in and transformed are not necessarily identical to the original entity. For example, 

surfaces may be transformed into planes, Coons or NURBS surfaces defining their contours and shape.

6.5.2 DXF

Menu:  Files->Import->DXF... 

With this option it is possible to read a file in DXF format (AutoCAD 2002 version).

GiD is able to read most of the entities, which are: POINT, LINE, ARC, CIRCLE, ELLIPSE, SPLINE, 

LWPOLYLINE, MLINE, POLYLINE, VERTEX, TRACE, SOLID, 3DFACE, 3DSOLID, BLOCK, INSERT

A very important parameter to consider is how the points must be joined. This means that points that are 

close to each other must be converted to a single point. This is done by defining the variable 

ImportTolerance (see Preferences -pag. 81- ). Points closer together than ImportTolerance will be 

considered as a single point. Straight lines that share both points are also converted to a single line. 

You can use the Collapse function (see Collapse -pag. 77- ) to join more entities. 

6.5.3 Parasolid

Menu:  Files->Import->Parasolid... 

With this option it is possible to read a file in the Parasolid format (version 14000 - ASCII or binary).

The most usual Parasolid file extension is .x_t for ASCII and .x_b for binary format.

The variable ImportTolerance (see Preferences -pag. 81- ) controls the creation of new points when a 

Parasolid file is read. Points are therefore defined as unique if they lie further away than this tolerance 

distance from another already defined point. Curves are considered identical if they have the same 

points at their extremes and the "mean proportional distance" between them is smaller than the 

tolerance. Surfaces can also be collapsed. 

6.5.4 ACIS

Menu:  Files->Import->ACIS... 

With this option it is possible to read a file in ACIS format (version 7.0). GiD reads the ASCII version with 

the SAT Save File Format. ACIS files (in ASCII) have the .sat extension.
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6.5.5 VDA

Menu:  Files->Import->VDA... 

With this option it is possible to read a file in VDA 2.0 format.

A very important parameter to consider is how the points must be joined. This means that points that are 

close to each other must be converted to a single point. This is done by defining the variable 

ImportTolerance (see Preferences -pag. 81- ). Points closer together than ImportTolerance will be 

considered as a single point. Straight lines that share both points are also converted to a single line. 

The Collapse function (see Collapse -pag. 77- ) can be used to join more entities. 

6.5.6 Rhinoceros

Menu:  Files->Import->Rhinoceros... 

With this option it is possible to read Rhinoceros 4.0 CAD files. This files have the .3dm extension.

6.5.7 Shapefile

Menu:  Files->Import->Shapefile... 

With this option it is possible to read a GIS file written in ESRI Shapefile format (version 1000). 

Shapefiles have the .shp extension.

6.5.8 XYZ points

Menu: Files->Import->XYZ points...

With this option it is possible to read a set of geometric points. This format is ASCII and consists the 

coordinates of the points separated with spaces. 

Note: If only 2 coordinates are specified, z=0 is assumed.

If 'Automatic collapse after import' was set, after the import near points will be joined, The variable 

ImportTolerance (see Preferences -pag. 81-) controls the joining distance.

6.5.9 KML

Menu: Files->Import->KML...

With this option it is possible to read files with the format KML. It uses in georeferenced images.

The variable ImportTolerance (see Preferences -pag. 81-) controls the creation of new points when the 

file is read.

6.5.10 NASTRAN mesh

Menu:  Files->Import->NASTRAN mesh... 

With this option it is possible to read a file in NASTRAN format (version 68), with GiD accepting most of 

its entities, which are:
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Entity name ( Notes)

CBAR CBEAM CROD CCABLE CBUSH CELAS1 CELAS2 CELAS3 RBAR (translated as 2 node bars)

CQUAD4 CQUADR

CHEXA

CTETRA

CPENTA

CTRIA3 CTRIAR

CONM1 CONM2 (translated as 1 node element)

CORD1C CORD1R CORD1S

CORD2C CORD2R CORD2S

GRID

There are two options that can be used when reading a mesh if GiD already contains a mesh:

a  Erasing the old mesh (Erase);

b  Adding the new mesh to the old one without sharing the nodes; the nodes will be duplicated although 

they may occupy the same position in the space (AddNotShare).

The properties and materials of elements are currently ignored, because of the difficulties in associating 

the NASTRAN file properties with the requirements of the analysis programs. Therefore, you have to 

assign the materials "a posteriori" accordingly. However, in order to make this easier, the elements will 

be partitioned in different layers, each with the name PIdn, where n is the property identity number 

associated with the elements as defined in the NASTRAN file. Note that CELAS2 elements do not have 

associated property identities so these will be created by default when the file is read.

6.5.11 STL mesh

Menu:  Files->Import->STL mesh... 

With this option it is possible to read a mesh in STL format. The STL binary format is also supported.

The variable ImportTolerance (see Preferences -pag. 81- ) controls the creation of new points when the 

file is read. 

6.5.12 VRML mesh

Menu:  Files->Import->VRML mesh... 

With this option it is possible to read a mesh in VRML 2.0 format. The compressed gzip format is also 

supported.

6.5.13 3DStudio mesh

Menu:  Files->Import->3DStudio... 

With this option it is possible to read a mesh in .3ds  3DStudio format. 
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6.5.14 CGNS mesh

Menu:  Files->Import->CGNS... 

With this option it is possible to read a .cgns mesh with CGNS binary format. CGNS is an standard 

format, specialized for the storage and retrieval of CFD (computational fluid dynamics) data.

6.5.15 GiD mesh

Menu:  Files->Import->GiD mesh... 

With this option it is possible to read a GiD ASCII mesh (saved with Export GiD Mesh) in order to 

visualize it within GiD.

It is also possible to read a new mesh and add it to the existing one. In this case, you are prompted to 

keep the former one or join it to the new mesh.

The format of the file describing the mesh must have the following structure:

mesh dimension 3 elemtype tetrahedra nnode 4

coordinates

1 0 0 0

2 3 0 0

3 6 0 0

4 3 3 0

5 3 1.5 4

6 3 1.5 -4

7 1.5 0 2

end coordinates

elements

1 1 2 4 5 1

2 2 3 4 5 1

3 1 4 2 6 1

4 2 4 3 6 1

5 1 2 5 7 1

end elements

The code nnode means the number of nodes per element and dimension can be either:

2: 2 dimensions. Nodes have just two coordinates.

3: 3 dimensions. Nodes have three coordinates.

Where elemtype must be:

Linear
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Triangle

Quadrilateral

Tetrahedra

Hexahedra

Prism

Pyramid

Point

Sphere

Circle

For sphere and circle elements after the connectivities the radius must be specified, and for circle 

elements also the three normal components could be written (z direction is considered by default)

Every element may have an optional number after the definition of the connectivity. This number usually 

defines the material type and it is useful to divide the mesh into layers to visualize it better. GiD offers 

the possibility of dividing the problem into different layers according to the different materials through the 

option Material (see Layers -pag. 95- ). For sphere elements is necessary to additionally specify its 

radius. 

Note:  The = sign is optional, but if it is present it is necessary to leave a space. 

If it is necessary to enter different types of elements, every type must belong to a different mesh. More 

than one mesh can be entered by writing one after the other, all of them in the same file. The only 

difference is that all meshes except the first one have nothing between coordinates and end 

coordinates. They share the first mesh's points. Example: to enter tetrahedron elements and triangle 

elements,

mesh dimension = 3 elemtype tetrahedra nnode = 4

coordinates

1 0 0 0

2 3 0 0

3 6 0 0

4 3 3 0

5 3 1.5 4

6 3 1.5 -4

7 1.5 0 2

end coordinates

elements

1 1 2 4 5 1

2 2 3 4 5 1

3 1 4 2 6 1

4 2 4 3 6 1
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5 1 2 5 7 1

end elements

mesh dimension = 3 elemtype triangle nnode = 3

coordinates

end coordinates

elements

1 1 2 4 1

2 2 3 4 1

3 1 4 2 1

4 2 4 3 1

5 1 2 5 1

end elements

6.5.16 Surface mesh

Menu: Files->Import->Surface mesh...

With this option a mesh can be read from a file in GiD or STL format (see GiD mesh -pag. 37-). 

Elements of this mesh must be triangles or quadrilaterals. This mesh is converted by GiD into a set of 

surfaces, points and lines. The geometric definition of surfaces is the mesh itself, but GiD treats them as 

truly geometric entities. For example, these surfaces can be used as the boundary of a volume, and a 

new mesh can be generated over them.

You are asked for the value of an angle. An angle between elements bigger than this value is 

considered to be an edge, and lines are inserted over them. As a consequence, a set of boundary and 

interior lines are created and attached to the surfaces to mark their edges.

6.5.17 Ply

Menu: Files->Import->Ply...

With this option it is possible to read files with format Ply. Generally, it saves ploygons.

The variable ImportTolerance (see Preferences -pag. 81-) controls the creation of new points when the 

file is read.

6.5.18 VTK Voxels

Menu: Files->Import->VTK Voxels...

GiD can import a mesh from a file with VTK structured data point format 

(http://www.vtk.org/pdf/file-formats.pdf). This format represent a scalar field over a rectilinear 3D grid. 
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In the "VTK voxels read" dialog box we can specify the isosurface value for the boundary of the body we 

want to extract from the volume. Besides we can choose among 3 different methods:

Marching cube: the well known method  for isosurface extraction is applied an the result is a triangle 

mesh on the boundary of the body.

Orthogonal Hexahedra: an orthogonal mesh of cubes is extracted from the volume selecting all the 

voxels withing the body bounded by the isosurface value.

Uniform Hexahedra: an uniform mesh of hexahedra fited to the boundary is generated applying a dual 

.

Isosurface Stuffing: the patterns of isosurface stuffing are aplied on the cartesian grid defined in VTK 

file to obtain a volume mesh.

6.5.19 XYZ nodes

Menu: Files->Import->XYZ nodes...

With this option it is possible to read a set of mesh nodes. This format is ASCII and consists in the 

coordinates of the nodes separated by spaces.

Note: If only 2 coordinates are specified, z=0 is assumed.

If 'Automatic collapse after import' was set, after the import near points will be joined, The variable 

ImportTolerance (see Preferences -pag. 81-) controls the joining distance.

6.5.20 Batch file

Menu: Files->Import->Batch file...

Sometimes, you may wish to organise a number of commands into a group outside GiD, ready to be 

implemented in one go. To do so, commands can be written in a file and GiD will read this file and 

execute the commands. These commands are the same ones as are used in GiD when entered in the 

command line or using the commands in the Right buttons menu.

Example: Many points have been digitalized and their coordinates saved in a file. These points are to 

be joined with straight lines to create the outline of the geometry. To do so, the file would look similar to 
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this:

geometry create line

 3.7 4.5 8

 2 5 9

 4,5,6

  ...

 1 7 0.0

 escape

A batch file can also be loaded into GiD by giving its name with the option -b  when opening GiD (see 

INVOKING GiD -pag. 13-). Another way to read batch files to create dynamic presentations is with the 

Read batch window (see Read batch window -pag. 101-). One GiD session can be registered in a batch 

file. This can be useful for checking the batch commands or to repeat one session (see Preferences 

-pag. 81-).

BATCH FILE COMMANDS

There are some special commands to be added to a batch file that are treated differently from regular 

GiD commands. Their format is one or several words after the control string ***** (five asterisks) and 

everything in one line.

Write a log file

*****OUTPUTFILENAME filename

filename is substituted with a real file name where all the session warnings (those which appear in the 

GiD messages warning line) are written. This can be useful when running GiD in batch mode with the 

option -n (see INVOKING GiD -pag. 13-) and GiD output is desired.

Execute a Tcl command in a batch file

*****TCL tcl_command

Note: If this command is used in a batch file and GiD is invoked with the option -n, it will not work. So 

that Tcl commands are executed when GiD is run without a window, you should use the -n2 option (see 

INVOKING GiD -pag. 13-).

Insert comments in the code of a batch file

geometry create line 1,2

*****COMMENTS -this is a comment-

2,3 escape

Print messages in the lower GiD messages line

geometry create line 1,2

*****PRINT -This is a message that will appear in the messages line-

2,3 escape
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Print messages in a window

geometry create line 1,2

*****PRINT1 -This is a message that will appear in a new window-

2,3 escape

6.5.21 Insert GiD geometry

Menu: Files->Import->Insert GiD geometry...

This command lets you insert one previously created GiD model inside another one. Entities from the 

old and the new model are not collapsed.

You can perform one Collapse operation (see Collapse -pag. 77-) to join the old and new models.

6.6 Export

GiD lets you export geometrical models or meshes in the following formats.

6.6.1 IGES

Menu:  Files->Export->IGES... 

GiD can export the geometry in IGES format (version 5.3).

If the preference 'IGES:B-Rep output style' is set (see Preferences -pag. 81- ), then the output file is 

written in Boundary representation solid model style; otherwise the surfaces are written as separated 

trimmed surfaces, without topological information, and the volumes are ignored. 

The IGES geometric entities generated are:

116 Point

110 Line

102 Composite curve

126 Rational B-spline curve

128 Rational B-spline surface

142 Curve on a parametric surface

144 Trimmed surface

and the topological entities are (B Rep style):

186 Manifold solid B-rep object 

502 Vertex

504 Edge

508 Loop

510 Face
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514 Shell

6.6.2 DXF

Menu:  Files->Export->DXF... 

GiD can export the geometry in DXF format (AutoCAD 2002 version). Points and curves are correctly 

exported, but a surface must be converted into a mesh of triangles, because DXF does not support 

Trimmed NURBS Surfaces.

6.6.3 ACIS

Menu:  Files->Export->ACIS... 

GiD can export the geometry in ACIS ASCII format, version 5.0 (files with .sat extension).

6.6.4 Rhinoceros

Menu: Files->Export->Rhinoceros...

With this option it is possible to write Rhinoceros 4.0 CAD files. This files have the .3dm extension.

6.6.5 GiD mesh

Menu: Files->Export->GiD mesh...

With this option a file is written with all of the project's mesh or meshes inside. This file can be read with 

Import GiD Mesh (see GiD mesh -pag. 37-).

6.6.6 Text data report

Menu:  Files->Export->Text data report... 

With this option a file is written containing all the information within the project. It is created in a way that 

is easily understood when read with an editor. This is useful for checking the information.

Note:   This ASCII format is only used to check information. It cannot be read again by GiD. To write 

ASCII files that can be read again use the option SaveAsciiProj (see ASCII project -pag. 37- ). 

6.6.7 ASCII project

Menu:  Files->Export->ASCII project... 

This option saves a project in the same way as regular Save (see Save -pag. 32- ) but files are written in 

ASCII. It may be useful for copying projects between incompatible machines. GiD also allows this 

information to be written in a file (see Text data report -pag. 43- ). 

Projects saved in this way may be read with the same open command (see Open -pag. 31- ). 
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6.6.8 ON layers

Menu: Files->Export->ON layers...

With this option, only the geometrical entities with their layers set to ON will be saved in a new project 

(see Layers -pag. 95-).

Note:  Lower entities necessary to define the saved entities will be also saved in the new project (e.g. 

the two extreme points of a line are also saved if the line is saved).

6.6.9 Calculation file

Menu:  Files->Export->Calculation file... 

If GiD runs the solver module automatically, this command is not necessary. However, it is useful if the 

solver program has to be run outside GiD, or to check the data input prior to any calculations.

This command writes the data file needed by the solver module.

The format of this file must be defined in a Template File  (see Template File ). GiD  uses the template 

file of the current Problem Type  to write the data file; so, to run this command, a problem type must be 

selected. 

When testing a new problem type definition, GiD produces messages about errors within the 

configuration. When the error is corrected, the command can be used again without leaving the example 

and without having to reassign any conditions or meshing.

6.6.10 Using a .bas template

Menu: Files->Export->Using template .bas

This command does the same thing as Export -> Calculation file (see Calculation file -pag. 44-), but it 

uses a .bas file provided by the user, instead of using the template file of the current problem type. This 

means it is not necessary to select a problem type in order to run this command.

When choosing 'Others...' from the submenu, GiD asks for a .bas file (see Template File) and, using that 

file, writes the data file needed by the solver module. There are some .bas codes available in the 

submenu which write output files in some formats (DXF, NASTRAN, STL, VRML). These example .bas 

files are located in the Templates directory of the main GiD directory. It is possible to add other .bas files 

to that directory so they appear in the submenu.

6.7 Preprocess/Postprocess

Menu: Files->Preprocess

Menu: Files->Postprocess

Toolbar:

Toggle Pre/postprocess
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This command allows you to move between GiD Preprocess and Postprocess.

6.8 Print to file

Menu: Files->Print to file...

Toolbar:

Take a snapshot

This option asks you for a file name and saves an image in the required format. The properties of the 

image (resolution, size, etc.) can be assigned in Page/image setup (see Page/Image setup -pag. 39-).

The accepted formats are as follows:

Postscript screen: Postscript. Useful for sending to a postscript printer. It is a snapshot of the screen.

Postscript vectorial: Postscript. Useful for sending to a postscript printer. It gives a higher quality 

result, but can only be used for small models. Otherwise, very large files are created and it takes a 

long time to print them.

EPS screen: Encapsulated postscript. Useful for inserting into documents.

EPS vectorial: Encapsulated postscript. Useful for inserting into documents. It gives a higher quality 

result than EPS screen, but the resulting file is much bigger.

BMP: Windows Bitmap image file.

GIF: Graphics Interchange Format image file.

JPEG: Joint Photographic Experts Group image file.

PNG: Portable Network Graphics image file.

TGA: Truevision TarGA image file.

TIFF: Tagged Image File Format.

VRML: Writes a VRML model file with the current visualization.

6.9 Page/Image setup

Menu: Files->Page/image setup...
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Page/Image setup

This is the window where some print properties (page size, borders, etc.) and image properties (image 

resolution and Auto crop image option) can be set up. These settings are applied when sending an 

image to a printer (see Print -pag. 40-), or to a file (see Print to file -pag. 45-).

Note: it's possible to create images with more resolution as the screen, e.g. interesting in order to print a 

poster.

6.10 Print

Menu: Files->Print...

Toolbar:

Print

Sends the current image to the selected printer.

6.11 Recent projects/post files

Menu: Files->Recent files

You can quickly gain access to files opened recently with GiD.

Recent Post Files: a list of the most recents files read in PostProcess is shown, so the user can 

selecet them quickier. The number of files can be adjusted here General -pag. 82-.

Recent Projects: a list of the most recent GiD projects are shown. The number of projects can be 

adjusted here General -pag. 82-.
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6.12 Quit

Menu: Files->Quit

Mouse menu: Quit

Toolbar:

Quit

The Quit command is used to finish the working session. If there have been changes since the session 

was last saved, GiD asks you to save them.
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Visualization commands change the way information is displayed in the graphical window. They have no 

effect on the definition of the geometry or any other data.

Generally, they can be used within any other command without leaving it. When the visualization 

process finishes, the first command continues.

They can all be accessed from the View pull-down menu, and most of them also by clicking the right 

mouse button.

7.1 Zoom

Menu:  View->Zoom 

Mouse menu:  Zoom 

Toolbar:

Zoom in

Toolbar:

Zoom out

Toolbar:

Zoom frame

Zoom is used to change how large or small objects appear in the window.

Zoom in: Pick inside the graphical window. A dynamic box is opened. Pick again and the visualization 

changes to display only the part within the defined box.

Zoom out: Pick inside the graphical window. A dynamic box is opened. Pick again and the 

visualization changes so that everything in the graphical window is reduced to the size of the box.

Zoom dynamic: Left-click on the point that is to be the centre of the zoomed image. Moving the 

mouse to the right enlarges the image and moving the mouse to the left reduces its size. Left-click 

once more to finish.

Zoom previous: GiD goes to the previous saved zoom.

Zoom next: If Zoom previous has been selected, this option goes back to next view in the list.

Zoom frame: Choose a visualization size so as to display everything inside the window.

Zoom points: Enter two points (see Point definition -pag. 23- ), and a visualization size is chosen so 

as to display these two points inside the window. This option only appears in the Right buttons menu 

(see USER INTERFACE -pag. 17- ). 

Note: Instead of picking twice to begin and end the rectangle, hold down the left mouse button and 

move the cursor.
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7.2 Rotate

Menu: View->Rotate

Mouse menu: Rotate

Toolbar:

Rotate trackball

There are various ways to rotate the image in order to view it from different angles. This does not affect 

the geometry.

Note: Instead of picking twice to begin and end the rotation, hold down the left mouse button and move 

the cursor.

7.2.1 Rotate trackball

With this option you can rotate the image as if using a trackball device. This means that when you 

left-click on a point and move the mouse, the geometric point tries to follow the mouse pointer. This can 

be imagined as a ball over the graphical window which is moved with the mouse.

The left mouse button can be pressed several times to engage and disengage the movement. To cancel 

this function, use escape (see Escape -pag. 29-).

7.2.2 Rotate screen axes

This option allows a dynamic rotation about the screen axes. Screen axes are defined as:

X-axis: The horizontal axis.

Y-axis: The vertical axis.

Z-axis: The axis at a right angle to the screen.

When entering this command, Z-axis is set by default and moving the mouse to the left or to the right will 

rotate the geometry around this axis. Clicking the left mouse button changes the axis. To cancel this 

function, use escape (see Escape -pag. 29-).

Can be changed the axis about which the image in rotated by entering the letters x, y or z in the 

command line.

To move the geometry by a fixed angle, enter the number of degrees, positive or negative, in the 

command line.

7.2.3 Rotate object axes

This option allows a dynamic rotation of the object about its own axes. These are displayed in the 

bottom left-hand corner of the screen.

When entering this command, Z-axis is set by default and moving the mouse to the left or to the right will 

rotate the geometry around this axis. Clicking the left mouse button changes the axes. To cancel this 
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function, use escape (see Escape -pag. 29-).

Can be changed the axis about which the image in rotated by entering the letters x, y or z in the 

command line.

To move the geometry by a fixed angle, enter the number of degrees, positive or negative, in the 

command line.

7.2.4 Rotate center

The default center of rotation is defined as a point approximately in the center of the geometry.

If you wish to change this center point, use this command to enter a point (see Point definition -pag. 23-

 ). This new centre of rotation will be maintained until the next zoom frame (see Zoom -pag. 49- ). 

In the Contextual   mouse menu (the menu which appears when you right-click over the graphical 

window) the option 'Automatic rotation center' / 'No automatic rotation center' is listed. If this option is 

active, for each 'Zoom In' / 'Zoom Out' / 'Pan' the point of the geometry or mesh nearest to the center of 

the screen will be selected as the center of rotation for subsequent rotations. This variable is also 

present in the Right buttons  menu under Utilities -> Variables. 

If a new Rotation center is selected, this option is deactivated.

7.2.5 Plane XY (Original)

This option changes the view to the original one, i.e. with the screen at a right angle to the Z-axis and 

with the X-axis lying horizontally and pointing to the right.

7.2.6 Plane XZ

This option changes the view so that the screen is at a right angle to the Y-axis with the X-axis lying 

horizontally and pointing to the right.

7.2.7 Plane YZ

This option changes the view so that the screen is at a right angle to the X-axis with the Y-axis lying 

horizontally and pointing to the right.

7.2.8 Isometric

This option changes the view to isometric one, i.e. with the screen at the viewing direction that the 

angles between the projection of the x, y, and z axes are all the same.

7.2.9 Rotate points

This option only appears in the Right buttons  menu (see USER INTERFACE -pag. 17- ). 

The new position of the geometry after the rotation can be defined as the direction orthogonal to the 

screen via a pair of points:
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1 The target point , the point you are looking at. 

2 The viewpoint , the point you are looking from. 

7.2.10 Rotate angle

This option only appears in the Right buttons  menu (see USER INTERFACE -pag. 17- ). 

The new position of the geometry after the rotation can be defined as the direction orthogonal to the 

screen via a pair of angles:

1 The angle in the plane XY  starting from the X-axis. 

2 The elevation angle  from the XY plane. 

As an example, the initial view (at a right angle to the Z-axis and with the X-axis horizontal) can be 

obtained with:

rotate angle 270 90

7.3 Pan

Menu:  View->Pan 

Mouse menu:  Pan 

Toolbar:

Pan dynamic

Two points: This command allows the geometry to be moved within the graphical window. To do this, 

pick two points in the graphical window.

Dynamic: In this case the object can be moved around following the movements of the mouse.

7.4 Redraw

Menu: View->Redraw

Mouse menu: Redraw

Toolbar:

Redraw

This command redraws the geometrical model or the mesh (depending on the visualization mode, see 

Mode -pag. 58-) in the graphical window. For those machines that include overlays, none of the layers 

that stay underneath is affected, so the redraw is carried out more quickly and the drawings underneath 

remain untouched.
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7.5 Render

Menu: View->Render

Mouse menu: Render

Using this option changes the way the model is viewed. There are three principal options:

Normal: This is the usual way of viewing the image. You can see both the geometry and mesh 

including all definition lines. 

Flat lighting: Solid model with flat illumination and lines.

Smooth lighting: Solid model with smooth illumination (better quality).

Change light direction: With this option you can change the VECTOR  of the light direction 

interactively; this can also be done by entering the VECTOR components in the command line.

Customize: You can define your own rendering with its own properties. 

Customize render window

You can choose how to visualize each entity, and save these properties in a new Render mode, which 

will appear in the View -> Render menu or in the mouse menu, next to standard GiD render modes.

Reflection: visual effect to simulate a mirroring surface. A cubic environment with rectangular images 

is projected over the model. 

The six images can be predefined patterns or user defined (from an image file).
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Render meaning: 

The rendering of a volume mesh can be distinguished from the rendering of its contour surfaces by the 

different ways of representing elements (boundary elements in the case of volume, and elements in the 

case of surfaces):

Volume mesh render: Boundary faces of volume mesh elements are shown in the color of the layer 

that the volume belongs to, with thick black borders.

Volume mesh render

Surface mesh render: Surface elements are represented as usual, in the color of the layer that the 

surface belongs to
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Surface mesh render

Volume and surface mesh render together: Boundary faces of volume mesh elements are shown as 

in "Volume mesh render", but the thick borders are colored as the layer that the contour volume 

surface belongs to. In the picture below, the volume layer is green and the contour volume surface 

layer color is red.

Volume and surface mesh render together

Note: The rendering of a volume mesh can be viewed with the boundary faces visible as if they were 

surface elements by using the option View mesh boundary (see View mesh boundary -pag. 146-).

Note: The quality of visualization is controlled via preferences (see Preferences -pag. 81-).
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7.6 Perspective

Menu: View->Prespective

By default, a model is viewed inside GiD using an orthogonal projection.

Perspective window

With this option it is possible to change to a perspective projection. In this mode, you can choose a 

distortion factor for the perspective. This can be updated at any time.

7.7 Clip planes

Menu: View->Clip planes...

 This window lets you hide the front or back of the view.
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Clip planes window

Clip planes is a way to prevent GiD from drawing elements of the geometry or mesh that are either very 

close to or far from the observer.

By moving the Near plane bar, the geometry that is closer to the viewer is hidden, while moving the Far 

plane bar hides the geometry that is further from the viewer.

To see the changes as they are performed, select Dynamic update. Selecting Fixed distance leaves a 

constant distance between both planes.

A new center of rotation can be entered or picked in the graphical window.

The Increase boundaries option adjusts the maximum setting possible for the Far plane and Near plane 

bars.

Note: All this information is reset when performing a zoom frame. (see Zoom -pag. 49-).

7.8 Advanced Options

With this window the user is able to enjoy the stereoscopic ( or 3D) experience, and to enable shadow 

drawing of the model.

Be aware that both options can be costly if the model is big.
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Stereoscopic and shadow options

Stereoscopic vision

The best experience is achieved with the Perspective view activated, for that purpose the 'Perspective' 

checkbox has been included in the top right of the window and with the '-->' button the perspective 

window can be opened. 

The different options are: 

Use stereo: enable or disable the stereoscopic view. 

stereo mode: here with the user can selected how to experience the stereoscopic view by using: 

Anaglyph colours: software mode which uses the red and cyan colours to generate the visualization 

for the left and right eyes respectively. To enjoy this view, the user needs the typical red-cyan glasses, 

like this one (from wikipedia.org): 

Quad buffers: the hardware( OpenGL's quad buffers) is used to generate the views for the left and right 

eyes. The user will need special hardware to enjoy this option. 

eye distance: fixes the distance between left and right eyes to generate the visualizations, which 

influences the stereo perception. Best results are achieved in the range 0.2 - 0.5. 
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switch eyes: switches the left-right eye view. 

eye distance mode: the eye distance can be specified in absolute mode, i.e. the distance is always 

the same (in meters) regardless the dimension of the currently visualized model, or scaled with the 

model. Best results are achieved with 'scaled with the model'. 

left/right colour mask: in the anaglyph stereo mode, this option allows the user to specify different 

colour filters for the left and right eyes by using the red, green, blue or alpha channel of the colour 

buffer. The default is red for the left eye and cyan ( blue + green) for the right eye, but other colour 

filters are yellow ( red + green) and blue ( blue) or green ( green) and magenta ( red + blue). 

dynamic update: if on, any change on the window will be shown immediately in the model 

visualization window. 

When the stereoscopic mode is on the following considerations should be done: 

Animation: if the selected stereo mode is quad buffers, then the left and right eye frames are stored 

together in a double width frame in the animation file which can be viewed with special viewers. Only 

avi files are supported. In the anaglyph mode, the animation is saved as it is viewed on the graphical 

window. 

Colour of Layers and Contour Fill: if the selected stereo mode is anaglyphs some colour artefacts 

will occur: red tones are only viewed from one eye and blue tones from the other one. Specific 

Contour fill colours scales has been added for anaglyphs stereo mode, the user may check Options 

--> Contour Fill --> Colour scale --> 3D anaglyph. It is also recommended, in this mode, to avoid pure 

reds, blue and greens as colours for layers or sets. 

Shadows

Herewith the user is able to control several shadow options. To be able to see the shadows, an 

hardware accelerated OpenGL 1.5 or upwards is needed, and best results are achieved with a good 

graphic card. OpenGL 2.0 or the framebuffer object  extensions is need to get a 'finer silhouette'. GiD 

uses the shadow mapping tecnique to visualize the shadows of the model allowing self-shadows.

 Use shadow: enables or disables the shadows visualization.

shadow color:  this option controls if the shadows should be black or shoule be drawn with and 

dimmable ambient light.

shadow bias: this advanced options allows the user to adjust the offset between the oclusor and the 

shadow. The default value is -0.002.

finer silhoutte: this advanced option allows the user to control the granularity of the shadow, i.e., the 

resolution of the texture to be used to create the shadow. By default, i.e. deactivated, the same 

graphical window is used to created the shadow texture. An accelerated OpenGL 2.0, or the 

framebuffer object extension is needed for this option to be used. If checked, the options are 

medium: which uses a texture of 1024 x 1024 pixels to create the shadow map, using 4 MB of 

memory,

high:  which uses a texture of 2048 x 2048 pixels to create the shadow map, using 16 MB of 

memory,

very high: which uses a texture of 4096 x 4096 pixels to create the shadow map, using 64 MB 

of memory,

highest: which uses a texture of 8192 x 8192 pixels to create the shadow map, using 256 MB 

of memory.
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7.9 Label

Menu: View->Label

Mouse menu: Label

With this option you can choose whether or not the entities should have their labels displayed. As 

suggested below, there are three options: show all entities with labels, show no entities with labels, or 

show some with and some without. The options are:

All/All in: All entities in the graphical window will have their labels displayed.

Select->Points, lines, surfaces or volumes: To select some entities of a particular type, choose the 

desired entity type, then select entities in the usual way 

(see Entity selection -pag. 27-). 

Off: No entity has its label displayed.

There is a graphical preference (see Graphical -pag. 83-) to show the entity label, its layer name or both

7.10 Entities

With this option, it is possible to choose just some of the points, lines, surfaces or volumes to be drawn. 

It is useful for making drawings faster or clearer in some instances.

Note: This option is only available in the Right buttons menu (see USER INTERFACE -pag. 17-).

7.11 Normals

Menu: View->Normals->Lines

Menu: View->Normals->Surfaces

With this command GiD draws the direction of lines and the normal of surfaces.

Normals -> Lines: draws the direction of the selected lines. If the line lies on the plane z=0, GiD also 

displays the normal of the line in 2D.

Normals -> Surfaces: draws the normals of the selected surfaces. There are two ways of viewing 

surface normals: Normal (as an array) or Colored (the front and back faces of the surface are colored 

differently). Any surfaces belonging to the plane z=0 will, by default, have their normals oriented 

towards z positive. In this case, they are defined as anti-clockwise surfaces in 2D.

Viewing commands (zoom, rotation, etc.) can be applied and the normals will remain on the screen.

It is possible to swap the direction of lines or surfaces using the Swap normals command (see Swap 

normals -pag. 115-).

7.12 Higher entities

Menu: View->Higher entities

With this option, it is possible to color-code geometrical entities according to their Higher Entity number. 
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The Higher Entity number is the number of other entities that a given entity belongs to.

If mesh mode is set, you can view the higher entities of mesh nodes.

7.13 Curvature

Menu: View->Curvature

Definition of the surface curvature at a point:

For two-dimensional surfaces embedded in R3, consider the intersection of the surface with a plane 

containing the normal vector at a point and another arbitrary vector tangent to the surface. This 

intersection is a plane curve and has a curvature. This is the Normal curvature. The maximum and 

minimum values of the normal curvature at a point are called the principal curvatures, k1 and k2, and 

the extremal directions are called principal directions.

It is possible to draw some typical surface curvatures:

Mean curvature: is equal to the mean of the two principal curvatures k1 and k2. Mean curvature is 

closely related to the first variation of surface area, in particular a minimal surface like a soap film has 

mean curvature zero and soap bubble has constant mean curvature.

Gaussian curvature: is equal to the product of the principal curvatures, k1k2. Is positive for spheres, 

negative for one-sheet hyperboloids and zero for planes. It determines whether a surface is locally 

convex (when it is positive) or locally saddle (when it is negative).

Maximum curvature: The greatest principal curvature k1

Minimum curvature: The second principal curvature k2

Also the principal curvature directions can be shown as unitary vectors.

7.14 View entry

View can be read and saved from this menu.

The default extension for these files is '.vv'.

7.14.1 Save/Read View

Menu: View->View->Save...

Menu: View->View->Read...

The first of these two options lets you save the actual view configuration to a file. That configuration can 

than be loaded at any time using the View -> Read command.

The view file store something like this:

BeginZE C:\temp\example.gid\example.vv

   x -541.13 27938.6

   y 11314.9 -11314.9

   z -56207 46237.2

   e 17074
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   v 0.381929 -0.247061 -0.199851

   r 0.867842

   m 0.79804 0.158159 -0.581479 0 -0.535598 0.62838 -0.564157 0 0.276163 

0.761659 0.586182 0 0 0 0 1

   c 13698.7 -9.09495e-013 4984.91

   pd 0

   pno 0

   pfo 0

   pf 4

   pv 0

   NowUse 0

   DrawingType 1

   LightVector 90 90 150 0

EndZE C:\temp\example.gid\example.vv

The abreviations stand for: 

x - left and right clip planes

y - top and bottom clip planes

z - near and far clip planes

e - margin between view and model box

v - rotation vector

r - rotation factor

m - rotation matrix

c - figure center

pd - perspective distance

pno - perspective near plane

pfo - perspective far planes

pf - perspective factor

pv - perspective view

NowUse - current use: 0=geometry, 1=mesh, post=2, graphs=3

DrawingType - render mode

LightVector - light direction

7.15 Recent View Files

the most recent read and saved views can be accesed from this menu
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7.16 Background Image

Menu: View->Background image

GiD allows an image to be used as a background for visualization purposes (the supported image 

formats are gif, png, jpeg, tiff, bmp, tga and ppm). There are the following options:

Fit screen: an image will be shown in GiD's background window; it will be modified if necessary so 

that it fills the screen correctly.

Real size:  the image will not be deformed; the image is placed in a plane. Three points must be 

entered: two of them to define the line where the bottom line of the image lies, and a stand-up point, 

which defines the upper direction of the image.

If a file with the same name as the image, and the appropiated extension exists, it is used to 

georeference the image

The extension must be:

tif or tiff --> .tfw

jpg or jpeg --> .jgw

png --> .pgw

gif --> .gfw

bmp --> .bpw

the content of this ASCII file must be:

Mxx

Myx

Mxy

Myy

Dx

Dy

The image coordinates are calculated as:

x'=Mxx*x+Mxy*y+Dx

y'=Myx*x+Myy*y+Dy

Default: use this option to restore the default background.

7.17 Image to clipboard

Menu: View->Image to clipboard

This option takes the image of the model in the actual view and sends it to the clipboard; it can then be 

pasted wherever you wish.

7.18 Multiple windows

Menu: View->Multiple windows...
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The Multiple windows command lets you have several views of the same project. Different views can be 

displayed inside the program main window or in supplementary windows.

7.19 Mode

Menu: View->Mode

This command lets you choose the GiD mode you wish to work with (Preprocess or Postprocess), and 

the different visualization options in each mode:

In Preprocess:  This command allows Mesh or Geometry visualization to be set.

Toolbar:

Toggle geometry-mesh view

The Toggle command changes from one visualization to another. If mesh visualization is selected and 

no mesh exists, you are asked to generate one.

In Postprocess:  This command allows Graphs or Mesh visualization to be set.

Toolbar:

Toggle pre/postprocess

This command allows you to move between GiD Preprocess and Postprocess.
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All available geometrical operations - generating, manipulating and deleting entities - are included in this 

chapter.

8.1 View geometry

Menu: Geometry->View geometry

Toolbar:

Toggle geometry-mesh view

This command changes from mesh visualization to geometry visualization.

8.2 Create

This menu is for the generation of all the different possible geometrical entities. Usually, new entities are 

created inside the current layer (see Layers -pag. 95-).

8.2.1 Point creation

Menu: Geometry->Create->Point

Individual points are created by entering each point in the usual way (see Point definition -pag. 23-). The 

points can then be joined together to form lines.

Caution: It is impossible to create new points joining old ones.

The Number option lets you choose the label that will be assigned to the next point created. If a point 

with this number already exists, the old line changes its number.

8.2.2 Straight line creation

Menu:  Geometry->Create->Straight line 

Toolbar:

Create line

To create a straight line, start by entering just two points (see Point definition -pag. 23- ), and then 

continue entering points in order to create more lines from the first one. Every part of the total line 

created is an independent line. 

It is important to note that when creating lines, new points are also being created (if existing ones are 

not used).
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The Close option joins the first point and the last point created with a straight line and finishes.

The Undo option undoes the creation of the last point (if new) and the last line. It is possible to continue 

undoing all the way back to the first point.

The Number option lets you choose the label that will be assigned to the next line created. If a line with 

this number already exists, the old line changes its number.

If Join is chosen, it is maintained for all points until No join is selected.

8.2.3 NURBS line creation

Menu:  Geometry->Create->NURBS line 

Toolbar:

Create NURBS line

NURBS are non-uniform rational B-splines. They are a type of curve that can interpolate a set of points. 

NURBS can also be defined by their control polygon, another set of points that the curve approximates 

smoothly.

There are two ways of creating a NURBS line using this command, either by entering some interpolated 

points or entering the points that form the control polygon.

The Undo option undoes the creation of the last point; this can be done all the way back to the first 

point.

By default, a NURBS will be a cubic polynomial passing through all the points. However, this option can 

be changed by calling ByControlPts, which defines NURBS by their control polygon. This polygon is a 

set of points where the first and the last points match the first and last points of the curve. The rest of 

the points do not lie on the curve. It can be assumed that the curve approximates the points of the 

polygon in a smooth way. In this case, the user chooses the degree of the curve, which will be the 

degree of the connected polynomials that define the NURBS.

Instead of entering interpolated points, the Fitting option lets you approximate a line using a minimum 

squared criteria. You also have to select the degree of approximation for this curve.

When defining interpolating curves, you can choose to define the tangents to one or both ends (using 

the Tangents option). These tangents can be customized, in that they can either be defined by picking 

their direction on the screen or by considering an existing line as a tangent to the NURBS if it follows a 

previous curve (the option ByLine). The Next option allows only one tangent to be defined.

In this way, it is possible to create a closed NURBS by selecting the initial point as the end one and 

choosing one of the options 'Tangent', 'Next', or 'ByLine'.

When a NURBS has been created, all the interior points (except the first and last) are not really entity 

points unless they previously existed.

The Number option lets you choose the label that will be assigned to the next created line. If a line with 
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this number already exists, its number is changed.

To enter rational weights on the curve, the Edit NURBS line/surface command (see Edit NURBS 

line/surface -pag. 73- ) can be used. 

8.2.4 Parametric line

Menu: Geometry->Create->Parametric line

Tool to create a parametric approximated curve

Parametric line window

The data that must be input are the mathematical formulae of the coordinates X(t), Y(t) and Z(t), where 

't' is the parameter of the curve, and its value belongs to the interval [ t0-t1 ]. The curve is created by 

approximation and is a NURBS (Non-Uniform Rational B-Spline) which is created with N points. In GiD 

these kinds of curves are cubic (order 3).

The valid mathematical funcions are all Tcl functions: 

+ - * / %

abs cosh log sqrt acos double log10 srand asin exp pow tan atan floor rand 

tanh atan2 fmod round ceil hypot sin cos int sinh

EXAMPLE

We fill the formula bars with the expression of a conic helix. 

That helix starts with radius R0=4 and finishes with radius R1=1, performing N=3 turns from t=0.0 to 

t=1.0, the height also changes from 0 to H=5.
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Example of a conic helix with a unique curve or with points only

8.2.5 Polyline creation

Menu: Geometry->Create->Polyline

Toolbar:

Create Polyline

A polyline is a set of at least two other lines of any type (including polylines themselves). Every line must 

share one or two of its endpoints with the endpoints of other lines.

There are two possible ways to create a polyline, either by selecting one line and searching the rest until 

a corner or end is reached, or by selecting several lines (see Entity selection -pag. 27-). In the case of 

the latter, the order of selection is not important but all of them must join each other by sharing common 

points.

Polylines are drawn in green to show the difference between the other lines, which are drawn in blue.

Polylines are widely used when creating 4-sided surfaces (see 4-sided surface creation -pag. 69-) and 

automatic 4-sided surfaces (see Automatic 4-sided surface creation -pag. 69-).

When deleting a polyline, all its lines are deleted. When exploding it (see Polyline -pag. 73-), the polyline 

will disappear and its individual lines will appear.

It is not possible to create third level polylines: one former polyline can be included inside another, but 

this is the limit and these two cannot be included within a further polyline.

The Number option lets you choose the label that will be assigned to the next created line. If a line with 

this number already exists, its number is changed.
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8.2.6 Arc creation

Menu: Geometry->Create->Arc

Toolbar:

Create arc

To create an arc you can either enter three points (By 3 points, see Point definition -pag. 23-) or enter a 

radius and the two tangent lines at the arc's ends (Fillet curves).

It is important to note that when creating an arc, new points are also being created (if existing ones are 

not being used).

An arc that begins and ends at the same point (i.e. where the first and third points are the same) will be 

created as a circle. An arc will always include the second point that is entered, though this one is only 

used as a reference and, if it is not an existing point, is automatically erased when the arc is created.

The Undo option undoes the creation of the last point (if it is a new one). It is possible to continue 

undoing all the way back to the first point.

The Fillet curves option lets you input a radius and select two lines that share one common point. An arc 

will then be created and the two lines will be modified to be tangent and continuous with this new arc.

To convert one arc to another one with the same center and in the same plane but with a 

complementary angle, the Swap arc command can be used (see Swap arc -pag. 73-).

8.2.7 NURBS surface creation

Menu: Geometry->Create->NURBS surface

Toolbar:

Create NURBS surface

NURBS are non-uniform rational B-splines. They are a type of surface that is defined by its control 

polygon (one set of points that the surface approximates smoothly), one set of knots for the two 

directions u and v (a non-decreasing list of real numbers between 0 and 1) and, optionally, one set of 

rational weights.

To draw the isoparametric lines in u,v=0.5, check the surface drawing type option in the Preferences 

-pag. 81- window.

By contour: this creates a NURBS according to its contour lines. GiD automatically calculates the 

interior information of the surface so as to interpolate the boundaries smoothly. To create a NURBS 

surface, some lines must be selected (see Entity selection -pag. 27-). The order of selection is not 

important but all of them must join each other by sharing common points and must form a closed 

contour. The number of lines must be equal to or greater than one and their shape must be 

topologically similar to a triangle or a quadrilateral in the space if the algorithm is to work correctly. 
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This last argument is not necessary if all the lines lie in one plane. In this case, the surface is created 

as a trimmed one and any problems with the shape are avoided. It is possible to select the boundary 

lines and the boundary lines of interior holes at the same time, if all the lines belong to a plane.

Note: The No try planar option (found in the Contextual mouse menu) avoids the creation of a trimmed 

NURBS surface when lines are coplanar.

Note:  To enter rational weights for the surface, use the Edit NURBS surface command (see Edit 

NURBS line/surface -pag. 73-).

Automatic: this automatically creates all possible surfaces with the number of sides given by the user. 

Every new surface will be created in the current layer.

Caution: When creating more than one surface in one go, it is possible that some undesired surfaces 

may also be created. It is necessary to check the surfaces after creation and erase the undesired ones.

Trimmed: this option lets you select one existing NURBS surface and a set of closed lines that are 

inside the surface. Some of these lines may already belong to the contour of the existing surface. 

Some other lines may be created with an intersection with another surface. Another new surface will 

be created without changing the old one. It is possible to select the boundary lines and the boundary 

lines of interior holes at the same time, if all the lines belong to the surface:

Creation of a new trimmed surface with a hole

Untrimmed: this constructs one new surface with the selected surface as its base and with the natural 

contours of the NURBS surface as its contours. The resulting surface is not trimmed.

Parallel lines: this lets you create one surface given a set of parallel lines in the space. The new 

surface will interpolate all the selected lines.

By points/By line points: these two options are available in the Contextual  mouse menu after the 

NURBS surface creation tool is selected. By points creates a NURBS surface from a cloud of points, 

and By line points creates a NURBS surface from level curves. These two functions are very useful 

for creating relief and terrains. In the image below there is a NURBS surface created from level 

curves:
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Creation of a untrimmed surface from a collection of curves (by line points)

Note: This surface is an approximation to the selected points/lines, but there is no interpolation.

Search: this lets you select one line and then creates one surface that contains that line.

8.2.8 Parametric surface

Menu: Geometry->Create->Parametric surface

 Tool to create a parametric approximated surface

Parametric suface window

The required input data are the mathematical formulae of the coordinates X(u,v), Y(u,v) and Z(u,v), 

where 'u' and 'v' are the parameters of the surface, and its value belongs to the intervals set in 'u in' and 

'v in' respectively. The surface is created by approximation and is a NURBS (Non-Uniform Rational 

B-Spline), which is created with 'Number of points U' x 'Number of points V' points. In GiD these kinds of 
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surfaces are cubic (order 3).

 The valid mathematical funcions are all Tcl functions: 

+ - * / %

abs cosh log sqrt acos double log10 srand asin exp pow tan atan floor rand 

tanh atan2 fmod round ceil hypot sin cos int sinh

8.2.9 Contact surface creation

Menu: Geometry->Create->Contact surface

Contact surfaces are defined as being between two lines that are physically in the same place, but 

which have different line and point entities. From a contact surface, it is possible to generate contact 

elements, to be used by some calculation algorithms, which define a special contact between these two 

bodies. 

Using contact surface entities is like a meshing specification. In this way, equal meshes will be 

generated for the two lines, ensuring a one-to-one relationship between nodes.

Choose the Contact surface option from the menu, and then select some lines on both bodies.

Contact elements are, by default, 4-node planar quadrilaterals. However, you can select 2-node lines for 

all cases (see Element type -pag. 137-).

The 4-node planar quadrilaterals can be converted to the 8-node or 9-node for the quadratic case.

You can also select no mesh for the contact entity. This makes it possible to have exactly the same 

mesh for both lines but without any additional element between them.

8.2.10 Surface mesh

Menu: Geometry->Create->Surface mesh

With this option a Surface mesh can be created by selecting triangular or quadrilateral mesh elements 

(see Surface mesh -pag. 39-).

8.2.11 Geometry from mesh

Menu: Geometry->Create->Geometry from mesh

This option converts all our mesh model (only surface mesh, triangles and quadrilateral) to a geometry 

model, obtaining a NURBS surfaces based definition. Creates a group of new layers called 

"Reconstruction", inside you will see two new layers: the first "All Lines And Points" contains lines and 

point and the second "Reconstructed Nurbs" the surfaces. If some surface couldn't be reconstructed it 

will appear a third layer called "SurfMeshes Not Reconstructed" containing the remaining parts 

converted in Surfmeshes, see more infomation about Surf Mesh -pag. 39-.
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8.2.12 Volume creation

Menu:  Geometry->Create->Volume 

Toolbar:

Create volume

A volume is an entity formed by a closed set of surfaces that share the lines between them.

To create a volume, some surfaces must be selected (see Entity selection -pag. 27- ) using the By 

contour option. The order of selection is not important but all of them must join each other by sharing 

common lines and they must form a closed contour. 

If there is an error and the volume is not created, a window appears with some useful information.

The Search option lets you select one surface and create one of the volumes that contains this surface.

Volumes and their surfaces are automatically orientated so that they are meshed correctly.

An additional feature allows the selection of surfaces that form the outer part of the volume as well as 

the ones that form the holes at the same time. In this case, GiD automatically recognizes the holes.

The Automatic 6-sided volumes option creates all possible volumes that have 6 sides (contour 

surfaces). It can be applied several times over the geometry and volumes are not repeated. Every new 

volume will be created in the current layer.

This can be useful for structured meshing (see Structured -pag. 130- ). 

8.2.13 Contact creation

Menu: Geometry->Create->Contact volume

Contact volumes are defined between two surfaces that are physically in the same place but with 

different surfaces, lines and points. From a contact volume, it is possible to generate contact elements, 

to be used by some calculation algorithms, which define special contact between two bodies.

Those equivalent surfaces can be in the same location or can be separated by a movement (separated 

contact volume). The result will be equal meshes, ensuring a one-to-one relationship between nodes.

Choose 'contact volume' from the menu, and then select the surfaces. GiD automatically searches for 

possible contacts, combining the selected surfaces in pairs.

Contact elements are, by default, 8-node hexahedra or 6-node prisms (depending on the surface mesh). 

However, you can select 2-node lines for all cases (see Element type -pag. 137-).

The result elements can be also quadratic.

You can also select no mesh for the contact entity. This makes it possible to have exactly the same 

mesh for both surfaces but without any additional element between them.

When creating contact volumes, GiD internally checks what surfaces occupy the same location in the 
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space and creates the contact, therefore there is no need to specify what surfaces have to be in contact. 

For this reason, several surfaces can be selected at once and GiD performs the contact automatically, 

indicating the number of contact volumes that have been generated.

One feature of GiD is the option to create 'contact separated volumes' for surfaces that are not 

physically in contact.

For these separated volumes, GiD internally checks whether a unique solid-rigid movement exists 

between two surfaces and creates the contact. There is the possibility that multiple solid-rigid 

movements may exist. In this situation, GiD asks for the point image of a source point to define the 

movement and, consequently, applies the right contact.

8.2.14 Object

Menu:  Geometry->Create->Object 

Toolbar:

Create object

With this command it is possible to create the following kinds of objects:

Rectangle

Polygon

Circle

Sphere

Cylinder

Cone

Prism

Torus

When creating an object, GiD asks for a center and a normal. To enter the coordinates of the center you 

can click on the screen or select an existing point (see Point definition -pag. 23- ). To enter the normal, 

GiD displays a window where you can choose one of the three axes or enter the coordinates of a point. 

Window to define the direction of the normal to the plane
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The In screen  button in the Enter normal window lets you manually enter the coordinates of the point 

which defines the normal: you can directly click on the screen or pick an existing point using the 

Join  option in the Contextual  mouse menu. 

When using the commands sphere, cylinder, cone, prism or torus, the volume of the object is also 

created.

8.2.15 Automatic 4-sided surface creation

Note: The 4-sided surface has been substituted by the NURBS surface (see NURBS surface creation 

-pag. 69-). This new entity has all the functionality of the old one.

Note: It is still possible, however, to access to this function with the Right buttons menu (see Tools -pag. 

99-).

Inside this option, GiD creates as many 4-sided surfaces as it can find. Every new surface will be 

created in the current layer.

Caution:  When creating more than one surface at a time, some undesired surfaces may also be 

created. It is necessary to check the surfaces after creation and erase the undesired ones.

8.2.16 4-sided surface creation

Note:  The 4-sided surface has been substituted by the NURBS surface (see NURBS surface creation 

-pag. 69- ). This new entity has all the functionality of the old one. 

Note:  It is still possible, however, to access to this function with the Right buttons menu (see Tools 

-pag. 99- ). 

A 4-sided surface is an entity formed by a closed set of four lines in the space. Its mathematical 

definition is a bilinear Coon's surface. The surface is totally defined by the shape of the lines, with no 

information about the interior. This means that it will sometimes be necessary to use more surfaces to 

obtain a good shape definition. 

To create a 4-sided surface, several lines must be selected (see Entity selection -pag. 27- ). For the 

creation of a 4-sided surface defined by three lines, it is necessary to divide one of the lines into two 

pieces (see Divide -pag. 71- ). The order of selection is not important, but all of them must join each 

other by sharing common points and they must form a closed contour. If it cannot be created, 

information about the endpoints is displayed in a window. 

In order to make one or more lines form parts of a polyline (see Polyline creation -pag. 68- ), select the 

entire polyline as one of the lines and GiD will automatically select the piece or pieces of the polyline 

that are required. Using this facility, non-conforming surfaces can be created. This means creating a 

surface by using the entire line on one side of the polyline, and creating more than one 4-sided surface 

by using parts of it on the other side. 

When selecting more than four lines, GiD will automatically search for all the possible 4-sided surfaces 

that can be created with these lines. This allows the creation of many surfaces at the same time.

The Automatic button is equivalent to automatic 4-sided surface creation (see Automatic 4-sided surface 
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creation -pag. 75- ). 

If the surfaces lie on the z=0 plane, the orientation of the surfaces will be anti-clockwise in this plane 

(normal vector points towards z positive). Otherwise, the orientation will be arbitrary. This can be 

checked with the DrawNormals command (see Normals -pag. 60- ). 

The Number option lets you choose the label that will be assigned to the next created surface. If a 

surface with this number already exists, the old line changes its number.

Caution:   When creating more than one surface at a time, some undesired surfaces may also be 

created. It is necessary to check the surfaces after creation and erase the undesired ones. 

8.2.17 Planar surface creation

Note:  The planar surface has been substituted by the NURBS surface (see NURBS surface creation 

-pag. 69- ). The latter automatically detects if boundary lines lie in a plane and creates a planar NURBS. 

Note:  It is still possible, however, to access this function with the Right buttons menu (see Tools -pag. 

99- ). 

A planar surface is an entity formed by a closed set of lines, all of them lying on the same plane. These 

lines must share some common endpoints.

To create a planar surface, some lines must be selected (see Entity selection -pag. 27- ). The order of 

selection is not important but all of them must join each other by sharing common points and must form 

a closed contour. If all lines are not in the same plane the surface is not created. 

It is possible to add holes to a planar surface. To do so, it is first necessary to create the outside planar 

surface. After this, press the Hole button and select the created surface. Then select lines that form 

every hole, one by one. Finish with escape (see Escape -pag. 29- ). It is also possible to define the 

surface and holes at the same time, by selecting all the curves. 

If the surfaces lie on the plane z=0, the orientation of the surfaces will be anti-clockwise in this plane 

(the normal vector points towards z positive). Otherwise, orientation will be arbitrary. This can be 

checked with the DrawNormals command (see Normals -pag. 60- ). 

8.3 Delete

Menu: Geometry->Delete

Toolbar:

Delete

The deletion of entities can be done in two ways: at one level (point, line, surface or volume) or erasing 

all entities at once. A selection is made (see Entity selection -pag. 27-) in both cases. After pressing 

escape (see Escape -pag. 29-), the entities are erased.

To undo the selection of entities, press Clear selection in the Contextual menu.
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Entities that form the basis of higher entities cannot be erased. For example, if a surface is created over 

some lines, it is necessary to erase the surface before erasing the lines.

8.4 Edit

These are the GiD editing options for geometrical entities:

Move point

Divide lines, polylines or surfaces

Join lines end points

Force lines to be tangent

Swap arc

Explode or edit polylines

Edit SurfMesh

Edit NURBS lines or surfaces

Convert to NURBS lines or surfaces

Simplify NURBS lines or surfaces

Hole NURBS surface

Collapse or Uncollapse entities or model

Intersections between entities

Surface or volume boolean operations

8.4.1 Move point

Menu: Geometry->Edit->Move point

By using this command, an existing point is selected and moved. The new position is entered in the 

usual way (see Point definition -pag. 23-). If the new position is an existing point (when using join), GiD 

will determine the distance between the points and ask if they should be joined. If the answer is yes, 

both points are converted into one. Any lines of surfaces that include the point in question will be moved 

accordingly in order that any links are maintained; this may lead to these lines or surfaces being 

distorted.

8.4.2 Divide

Menu: Geometry->Edit->Divide

The Divide command can be applied either to lines, polylines , surfaces (including trimmed surfaces), 

and volumes.

Polylines: In the case of polylines, an existing interior point must be chosen. The polyline will be 

converted into two lines that may or may not be polylines.

Polyline division has the option Angle which allows you to divide the polyline at all the points where the 

angle between the sub-lines is greater than a given value.

Caution: An interior point must belong to the first level of a polyline (see Polyline creation -pag. 68-).

In the case of lines and surfaces, once the entity has been selected the division can be done in several 
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ways:

Number of divisions: The line or surface will be converted into equally spaced pieces. In the case of 

surfaces it is necessary to give the division direction as u or v. 

Near point: With this option one point must be selected near the line or the surface. Points inside the 

entities can be selected (see Point in line -pag. 26-, or Point in surface -pag. 26-). The line or the 

surface will be divided into two entities near that point. In the case of surfaces it is necessary to give 

the division direction as u or v.

Parameter:  One factor is given between 0.0 and 1.0 and the entity will be divided where the 

parametric variable takes that value. In the case of surfaces it is necessary to give the division 

direction as u or v.

Relative length:  (lines only) One factor is given between 0.0 and 1.0 to divide the line with relative 

arc length ratio equal to the selected factor. (Same concept as Parameter if the curve was arc length 

parameterized).

Length: (lines only) The length of the resulting divided lines is given, and GiD divides the line into as 

many lines as it can. If the length given is bigger than the length of the selected line, no division is 

made.

Split:  (surfaces or volumes) The surface/volume will be divided following the divide lines/surfaces. 

These lines/surfaces must share points/lines with the to be splitted (Command: Geometry Edit 

SplitSurf/SplitVolume ).

Note: After the division, the old entity disappears and the new entities are created.

8.4.3 Line operations

Menu: Geometry->Edit->Line operations

With this option you can edit groups of lines with respect to their topology and shape.

Join lines end points:

With the command Join lines end points, two lines must be selected. GiD determines the distance 

between the two closest endpoints, draws both points, and asks for confirmation. If one of the lines is a 

polyline, interior points are also considered. If accepted, the points are converted into one and the lines 

are distorted. The new point will then take the place of the first line's point.

(See Move point -pag. 77- for another method of converting two points to one.)

Caution: The second selected line cannot have higher entities (the second point is moved to the first).

Force to be tangent:
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With the command Force to be tangent, two lines (which share at least one point) must be selected. 

They must be NURBS lines, otherwise they will be rejected. You are asked to enter the maximum angle 

between lines to accept the operation, and GiD will modify the selected NURBS lines and force them to 

be tangents at their common point.

8.4.4 Swap arc

Menu: Geometry->Edit->Swap arc

This command lets you select and alter arcs. Lines that are not arcs are rejected. When you confirm the 

operation, the arc is converted to a new arc with the same center and in the same plane but opposite 

the old one. The old arc disappears and the angle of the new arc will be complementary to the angle of 

the old arc.

Caution: Arcs belonging to higher entities cannot be swapped.

8.4.5 Polyline

Menu: Geometry->Edit->Polylines

Explode polyline:

This command lets you select which polylines you wish to explode; lines that are not polylines or have 

higher entities or conditions are rejected. After confirmation, the polylines are exploded and converted 

back to their original lines. Polylines then disappear (see Polyline creation -pag. 68-).

Edit polyline:

The command Edit Polyline allows you to select which polylines you wish to edit; lines that are not 

polylines are rejected. It is possible to choose several options for the polylines:

Use points: When meshing this polyline, there will be at least one node at every point location that 

defines the polyline. These will be the endpoints of interior lines.

Not use points: When meshing this polyline, the mesh generator ignores the points and therefore the 

nodes will be placed anywhere. This is the default option. Nodes will only be put in the position of a 

point if there is a 4-sided surface over a part of a polyline (see Automatic 4-sided surface creation 

-pag. 75-).

Only points: When meshing this polyline, the nodes will only be placed where the geometry points 

are.

Note: If one condition is assigned to one interior point of a polyline (see Conditions -pag. 122-), one 

node of the mesh will be placed over that point.

8.4.6 SurfMesh

Menu: Geometry->Edit->SurfMesh

Select one or several surface meshes (see Surface mesh -pag. 39-). The options are:

Draw mesh: Surface will be drawn as a mesh.

No draw mesh: Surface will be drawn as a regular surface with magenta lines close to the boundary 

lines.
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8.4.7 Edit NURBS line/surface

Menu:  Geometry->Edit->Edit NURBS 

Edit NURBS line:

Tool to modify some NURBS geometric properties, like control points, degree, etc.

Edit NURBS line window

Once a NURBS line is selected (use the Pick  button in the Edit NURBS Line window), you can edit its 

control points (see NURBS line creation -pag. 66- ). Select the control points as if they were regular 

points and enter their new positions in the usual way (see Point definition -pag. 23- ). 

The Influence factor affects the movement propagation of the neighboring control points.

Available options:

Fix boundary  Check the fix boundary option if you do not want to move the boundary control points 

of the line. 

Insert knot:   You are asked for a knot value between 0.0 and 1.0 and this is then inserted. The 

program checks that the knot multiplicity is not greater than the order (order=degree+1). As the 

number of knots increases, the number of control points also increases, so this option can be used to 

have more points defining the same curve. 

Knot removal : the inverse of knot insertion. Remove knots if possible without change shape with a 

given tolerance. (interesting to save memory) 

Elevate degree:  With this option the degree of the curve is raised by one. The new curve will have 

the same shape but with more control points and knots. 

Reduce degree : the inverse of degree elevation. Decrease the polynomial degree if possible without 

change shape with a given tolerance. 

Change weight:  A new positive weight can be introduced for any control point, with the exception of 

the end points. 

Cancel weights:  All weights of the NURBS are converted to 1.0 and the curve is no longer rational. 
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Reparameterize:  With the same control points a new curve is calculated to get a better curve with a 

more uniform parameterization. 

Similar cubic:   This option converts the curve to a simplified one with degree=3, which is only an 

approximation of the original one. 

Edit NURBS surface:

Edit NURBS surface window

Once a NURBS surface is selected (use the Pick  button of the Edit NURBS Surface window), you can 

edit its control points intereactively (see NURBS surface creation -pag. 69- ). Select the control points as 

if they were regular points and enter their new positions in the usual way (see Point definition -pag. 23-

 ). 

Available options:

Insert knot:  You are asked for a knot value between 0.0 and 1.0 and it is then inserted. The program 

checks that the knot multiplicity is not greater than the order. This option can be used to have more 

points defining the same surface. 

knot removal:  the inverse of knot insertion. Remove knots if possible without change shape with a 

given tolerance. (interesting to save memory) 

Elevate degree:   With this option the degree of the surface is raised by one. The new surface will 

have the same shape but with more control points and knots. 

Reduce degree : the inverse of degree elevation. Decrease the polynomial degree if possible without 

change shape with a given tolerance. 

Change Weight:  A new positive weight can be introduced for any control point, with the exception of 

the end points that must have weight=1 (to force the surface to pass over the corner control points). 

Cancel weights:  This converts the weights of all the control points to 1.0 

Reparametrize:   This reparameterizes the surface obtaining an optimized surface. When a Nurbs 

surface is not well parameterized, the mesh is of a lower quality. 

Similar cubic:  This option converts the surface to a simplified one with degree=3 in both parametric 

directions, which is only an approximation of the original one. 
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All these options are available in U and V directions.

Control polygon of a NURB surface

The Movement type  menu of the Edit NURBS Surface window determines the way the selected knots 

will move. This movement can be along an axis (X-Axis, Y-Axis, Z-Axis), can describe the Normal of the 

surface (Normal), can follow the screen movement of the mouse (Screen), or the new location of the 

knot can be defined by introducing the coordinates of a point (Point). 

Note: The Insert knot and Degree elevate options can be chosen for either the u or the v parameter 

directions.

8.4.8 Convert to NURBS line/surface

Menu: Geometry->Edit->Convert to NURBS

This option converts the selected lines or surfaces to NURBS lines or NURBS surfaces.

Note: Some algorithms only work with NURBS entities.

8.4.9 Simplify NURBS line/surface

Menu: Geometry->Edit->Simplify NURBS

This option converts the selected NURBS lines or surfaces to other ones very similar to the originals but 

with a less complicated definition. It can be useful when importing data where a control polygon is too 

complex for GiD to display or mesh quickly.

The Model option performs the operation over all the geometrical entities in the model.

8.4.10 Hole NURBS surface

Menu: Geometry->Edit->Hole NURBS surface

With this option you can select one existing NURBS surface and a set of closed lines that are inside it 

and that form a hole. The lines may be created by an intersection with another surface. The hole will be 

added to the existing surface.
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8.4.11 Hole Volume

It is possible to add holes to a volume. 

To do so, start by creating the interior volumes as independent volumes. After this, click the Hole button 

and select the outside volume. Then, select the interior volumes that form every hole, one by one. Finish 

with escape (see Escape -pag. 29-).

It is possible to specify 'NoDeleteHoles' to not delete the volumes used to create the holes (or 

'DeleteHoles' to delete them)

8.4.12 Collapse

Menu: Geometry->Edit->Collapse

The Collapse function converts coincident entities, i.e. entities that are very close to each other, into 

one.

The ImportTolerance variable (see Preferences -pag. 81-) determines which entities will be collapsed. 

Where the distance between two points is less than the tolerance, they will be converted to one. With 

lines and surfaces, the maximum distance between both entities is calculated and if it is less than 

ImportTolerance, they are converted to one.

Select the type of entities - point, line, surface or volume - when in geometry  mode. All the lower 

entities that belong to the selected entities will automatically be computed. On pressing escape, the 

collapse operation will be performed.

The Model option performs the operation over all the geometrical entities in the model.

8.4.13 Uncollapse

Menu: Geometry->Edit->Uncollapse

The Uncollapse function lets you select lines, surfaces or volumes and duplicate all common lower 

entities.

Typically, if two surfaces share one line as an edge, after applying this function to both surfaces, that 

line and its shared points will be duplicated and every line will belong to a different surface.

This feature is interesting, for example, if you want to disconnect joined bodies or generate a 

non-conformal mesh with fewer elements than a conformal one.

8.4.14 Intersection

Menu: Geometry->Edit->Intersection

Using this option, the intersection of many geometrical entities can be performed.

8.4.14.1 Intersection: Lines

This option lets you select several lines for which GiD then tries to find as many intersection points as 

possible. Lines are divided where applicable.
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The 'No Divide Lines' option creates an intersection point but does not modify the lines.

8.4.14.2 Intersection: Surface-2 points

You need to select one surface and two points that lie approximately over it. GiD calculates the line 

intersection between the surface and a plane defined by the two given points and the average normal to 

the surface of these points.

Note: Planar surfaces cannot be used with this option.

Note: See Point in line -pag. 26-, Point in surface -pag. 26- which can be used to define the points.

8.4.14.3 Intersection: Surface-lines

You need to select one NURBS surface and several lines. GiD then calculates the intersection between 

the surface and the lines. Lines will be divided at the intersection point.

The 'No Divide Lines' option creates the intersection point but does not modify the lines.

The Extend/Divide lines option extends the lines until they reach the surface.

8.4.14.4 Intersection: Surfaces

This command creates the intersection lines between several surfaces.

The 'No Divide Lines' option creates the intersection point but does not split the contour lines.

By default the surfaces are divided, unless the No divide surface option is selected.

8.4.15 Surface boolean operations

Menu: Geometry->Edit->Surface boolean op.

You need to select two 2D surfaces located in the XY plane (order is important when dealing with 

subtraction).

The valid surface boolean operations are:

Union: Fuses two surfaces wherever they intersect to create a single, more complex volume.

Intersection: Creates a surface based on the intersecting points of two separate volumes.

Subtraction: Negates a specific portion of a surface to create a hole or indentation.

8.4.16 Volume boolean operations

Menu: Geometry->Edit->Volume boolean op.

The GiD Volume Boolean Modeler has been designed to accomplish geometric feats such as physically 

punching a hole through a volume, combining several volumes into one, and creating a new volume 

from the intersecting part of several separate volumes.
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The valid volume boolean operations are:

Union: Fuses several volumes wherever they intersect to create a single, more complex volume.

Intersection: Creates a volume based on the intersecting points of several separate volumes.

Subtraction: Negates a specific portion of a volume to create a hole or indentation.

First the volume where to substract must be selected, then the volumes to be substracted (order is 

important when dealing with subtraction).
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Within Utilities you can find commands that apply to the geometry and/or the mesh, as well as other 

functions that apply to the whole project.

9.1 Undo

Menu: Utilities->Undo...

Undo window

With this command you can undo any previous commands executed since the the project was last 

saved or read. To do this, select from the list of operations in the window so that they are highlighted 

red, and click undo.

9.2 Preferences

Menu:  Utilities->Preferences... 

Toolbar:

Preferences

Note:   There are many settings in GiD that have a predefined value, but that can be modified by the 

user. They can be accessed in one of two ways. Firstly, by opening the Preferences window from the 

Utilities pull-down menu, and secondly via the Variables command in the Utilities section of the Right 

buttons  menu (the latter is also available in the Contextual  mouse menu). Almost all the preferences 

variables are present in the Preferences window, but some advanced ones are only available in 

Variables command. 

In the following section the different options available in the Preferences window are shown and their 

different settings explained.
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Usually variables  are graphically set trough the preferences window, but some unusual variables must 

be set from the lower command line, with this command: 

Mescape Utilities Variables <varname> <varvalue>

if <varname> is not specified then the mouse contextual menu (see Mouse operations -pag. 21- ) will 

show the list of available variables. 

9.2.1 General

The first group of Preferences are general options, and are used to set the different ways of working 

with GiD.

General preferences

Language: This option sets the language GiD is working in. By now GiD messages are fully translated 

into English, Spanish, Russian and French. RamTranslator is used to deal with message catalogues 

for GiD and the translation of problem types (to see more information about RamTranslator visit 
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http://www.gidhome.com).

Splash window: If this option is set, when the program is opened again a welcome window is 

displayed. Variable: SplashWindow. Values: 1,0. Default is 1 (Yes).

Create new point: Alters the way in which the points are entered in GiD (see Point definition -pag. 23-

). Options are:

Always: If trying to create a new point in the vicinity of an existing one, the new point is always 

created.

Ask: If trying to create a new point in the vicinity of an existing one, GiD asks whether to make 

use of the existing point or create a new one.

Never: Only allows existing points to be selected. You can also change this when in point 

creation mode by setting No join until all points are entered.

Variable: CreateAlwaysNewPoint. Respective values: 1,0,-2. Default is 0 (Ask).

Display coordinates: If set, GiD shows the coordinates in the graphical window. Variable: 

DisplayCoordinates. Values: 1,0. Default is 1 (Yes).

Automatic redraw: If this option is not set, redraws caused by window expositions or internal functions 

are not performed. This avoids spending a lot of time redrawing when workig with large models. 

Variable: AutomaticRedraw. Values: 1,0. Default is 1 (Yes).

Popup messages: If beginner is selected then user will receive more popup messages that for a 

Normal one.

Reload last model: If set, when GiD is opened it reloads the last model that was saved. Variable: 

ReloadLastModel. Values: 1,0. Default is 0 (No).

Play sound: If this option is set, a sound is played to indicate a task has finished. Variable: Sound. 

Values: 1,0. Default is 0 (No).

Shrink windows when selecting: If this option is set, some windows are resized when selecting, in 

order to facilitate the selection. Variable: SmallWinSelecting. Values: 1,0. Default is 0 (No).

Num of recent projects: number of items to be showed in the recent projects menu (Files menu).

Num of recent post files: number of items to be showed in the recent post files menu (Files menu).

Num of recent view files: number of items to be showed in the recent view files menu (View menu).

Backup time: If this option is set and a model name is given, the model is saved automatically with the 

frequency given (in minutes). Note:  The mesh is not saved in automatic backup to save time. 

Variable: BackUpMinutes. Default is 20 minutes.

Write batchfile: If this option is set and a filename is given, all commands used during the current 

session are saved to this file. It can be executed later by means of a script file with the predefined 

commands to be run in GiD (see Batch file -pag. 40-). Variable: BatchFileToWrite.

Write rotations in batch: If this option is set and the batch file name is given, all dynamic rotations and 

movements are stored there as well. In this way you can see these movements when reading this 

batch file with 'Read batch window'. Variable: WriteRotationsInBatch. Values: 1,0. Default is 0 (No).

9.2.2 Graphical

The second group of preferences  are graphical options, and are used to set different ways of 

visualizing the model. They do not change the geometry or the model information.
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Graphical preferences

Fast visualization mode/Safe visualization mode: the generic OpenGL by software driver can solve 

graphical problems, but it is recommended to try to use the hardware acceleration if it is possible 

(because it is faster than the software option)

Selection lines by software(emulateFrontBuffer): if there are problems drawing lines check this box.

Smoothed Elements: If this option is set, when rendering a mesh (see Render -pag. 53-) the 

intersection between elements with a small angle between their normals will be illuminated as if it 

were a continuous solid. If it is not set, illumination is made considering every element as planar. 

Variable: LightSmoothedElems. Values: 1,0. Default is 1 (Yes). The angle (in degrees) is the 

maximum angle between the normals of two elements to allow smooth lighting between them. If the 

angle is greater than this, one edge is drawn between them. Variable: CosSmoothedElems. Saved as 

the cosine of this angle. Default is 0.8. 

Surface drawing type: Lets you choose how to draw the surfaces when in wire frame (normal) mode. 
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Options are:

None: Surfaces are not drawn.

Boundary lines: One magenta line is drawn for every contour line. This set of lines has a small 

offset towards the interior of the surface.

Isoparametric lines: Two yellow lines are drawn for every NURBS surface, one for u=0.5 and 

one for v=0.5.

Both: Draws both Boundary lines and Isoparametric lines.

Variable: DrawSurfaceMode. Default is 1 (Boundary lines).

Draw quadratic elements: With this option you can specify how to visualize quadratic elements. 

Options are:

No: If this option is set, quadratic elements are drawn as if they were linear.

As lines: If this option is set, elements are drawn taking into account all quadratic nodes, but 

edges are drawn using straight lines between nodes.

As curves: If this option is set, elements are drawn taking into account all quadratic nodes, and 

edges are represented using quadratic curves. This option is more realistic, but it may make 

some visualization aspects slower when dealing with large models.

Entity labels show: to show identifier number, the layer name of the entity or both of them.

Change color:

It is possible to change the default color of several visual items in GiD. One possibility is to change 

the background color of the GiD graphical window. Variable: BackgroundColor. Value: hexadecimal 

RGB char. Default is (255,255,255) (white). Other possibilities include the color of the entities in 

normal mode (no render). These are also accessible through the Variables menu.

GUI attenuated: Set the GUI appearance to standard or attenuated color. The change is updated after 

restarting GiD.

Two colors background: to set a two colors degradation for the background.

Curve precision: This option determines the precision with which curves are drawn. The internal 

definition of curves does not change. Selecting the Dynamic option allows this setting to be changed 

while drawing a curve in order to test the level of precision. Variable: CurvePrecision. Values: 1.0 to 

0.0 from best to worst. Default is 1.0.

Surface precision: This option determines the precision with which surfaces are drawn in render 

mode. The internal definition of surfaces does not change. Variable: SurfacePrecision. Values: 1.0 to 

0.0 from best to worst. Default is 0.6

Automatic rotation center: If this option is active, each time 'Zoom In' / 'Zoom Out' / 'Pan' is used, the 

point of the geometry or mesh nearest to the center of the screen will be taken as the center of 

rotation for subsequent rotations. Variable: AutomaticRotationCenter. Values: 0,1. Default is 1 (yes). 

This is also available by right-clicking the mouse, under Rotation -> Center. If a new Rotation center 

is selected (see Rotate center -pag. 51-), then this option is deactivated. 

Fast rotation: This allows fast rotation of the object. Variable: FastRotation. Value: 0,1. Default is 0 

(No).

If this option is set various further options are available, though these only apply when rotating.

Points, lines, surfaces, volumes: This determines whether the entities will be drawn when 

rotating. Variables: the same. Values: 0,1. Default is 0 (No).

Always Geometry: With this option set, when you view and rotate the mesh, the geometry is 
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drawn instead. Variable: UseAlwaysGeom. Values: 0,1. Default is 0 (No).

Draw graphic objects: If this option is not set, when rotating the geometry, some graphical and 

temporal objects like normals or materials or conditions symbols are not drawn. Variable: 

DrawGraphicObjects. Values: 0,1. Default is 1 (Yes).

Curve precision: This is the same as the general item Curve precision, but only applies when 

rotating. Variable: CurvePrecision. Values: 1.0 to 0.0 from best to worst. Default is 0.8 

9.2.3 Meshing

The third group of preferences are meshing options.

Preferences window

Quadratic type:This property set the quadratic type of the elements generated. It is applied to the 

mesh of the whole model. User can choose between three options: 

Linear: linear elements are made.

Quadratic: the elements will be quadratic, with a node in the middle of each edge:

Linear: 3 nodes.

Triangle: 6 nodes.

Quadrilateral: 8 nodes.

Tetrahedra: 10 nodes.

Hexahedra: 20 nodes.
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Prisms: 15 nodes.

Quadratic9: option is similar to Quadratic, but will generate 9-noded quadrilaterals and 

27-noded hexahedra (an extra node in the middle of the element).

The different conectivities can be seen at Element type -pag. 137-.

Unstructured mesher:

GiD can use three kinds of surface mesher.

Rfast meshes are the most efficient in speed and reliability. With deformed surfaces they can 

give distorted elements.

Rsurf meshes are generated directly in the space. Quality is better but it is slower and can fail 

for distorted surfaces.

Rjump meshes are generated directly in the space, and contact lines between surfaces which 

are almost tangent (less than 10 degrees between tangent vectors) are skipped when 

meshing. Contact points between almost tangent lines (less than 10 degrees between tangent 

vectors) are skipped too. With this surface mesher, you can generate meshes with fewer 

elements than other meshers because it is less dependent on the dimensions of geometrical 

surfaces. However, it is slower and can fail for distorted surface patches.

If any entity has Skip or NoSkip Mesh Criteria (see Mesh criteria -pag. 140-), the surfaces 

involved are meshed with the Rjump mesher, even if another mesher is set in this window. These 

mesh generators are based on the advancing front generation mesh technique in order to 

improve speed and portability. Variable: SurfaceMesher. Values: 0 (Rfast), 1 (Rsurf) and 4 

(Rjump). Default is 0 (Rfast).Note: GiD can try another mesher internally when one of them fails 

to generate the mesh for one surface.

GiD can use two kinds of volume mesher:

Advancing front: The unstructured volume mesher is based on the advancing front technique.

Delaunay: The unstructured volume mesher is based on the Delaunay algorithm. It isn't 

constrained.

Isosurface Stuffing: The unstructured volume mesher aplies the patterns of isosurface stuffing 

on a modified cartesian mesh of the model.

Automatic correct sizes: This preference lets GiD make an automatic mesh size correction when 

meshing begins. If None is set, no size correction is made; if Normal is set, a size correction is made 

according to the sizes of geometrical entities and the compatibility between meshing sizes of 

neighboring entities; if Hard is set, the Normal correction is made and, furthermore, an automatic 

chordal error criteria is applied to assign sizes to surfaces which are the contours of some volume, so 

as to improve volume meshes. Variable: AutomaticCorrectSizes. Values: 0 (None), 1 (Normal) and 2 

(Hard). Default is 1 (Normal).

Unstructured size transitions: This controls whether the transitions between different element sizes 

are slow or fast. Variable: SizeTransitionsFactor. Values: 1.0 to 0.0 from slower to faster transition. 

Default is 0.6.

Regular transition near boundary: This preference is to control the transition of sizes patern. If this 

preference is set, the transitions size follows in a more paralel way the elements in the oundary of the 

mesh; otherwise, if the preference is not set, the size transition is more uniform along the mesh. The 

following picture shows an example of this two ways of size transitions. Variable: 
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BoundaryWeightedTransition. Values: 0,1. Default is 1.

Example of size transition if 'Regular transition near 

boundary' is set.

Example of size transition if 'Regular transition near 

boundary' is not set.

Allow automatic structured: If this preference is set, functions like Assign sizes by Chordal Error will 

define some surfaces as structured with highly distorted elements over them. Variable: 

AllowAutomaticStructured. Values: 0,1. Default is 0 (No).

Symmetrical structured triangles: If this preference is set, structured triangle meshes will be 

topologically symmetrical. Variable: SymmetricalStructuredTriangles. Values: 0,1. Default is 1 (Yes).

Symmetrical structured tetrahedra: If this preference is set, structured tetrahedron meshes will be 

topologically symmetrical. Variable: SymmetricalStructuredTetrahedra. Values: 0,1. Default is 1 (Yes).

Boundary layer mesh:These preferences control the boundary layer mesh properties.

Stretching function: this variable set the stretching function which controls the height of each 

layer of boundary layer mesh. Options are the next ones, where 'h_i' is the height at level 'i' 

and 'r' is the grow factor:

Function 1 (Geometric): This function is the geometric progression, and its expression 

is: h_i = h_0*(r^0+r^1+r^2+···+r^(i-1) 

Function 2 (Exponential): This function the exponential progression, and its expression 

is: h_i = exp(r*i + ln(h_0)).

Function 3: This function is represented by: h_i = h_0 * (1 + i*(1+r*(1+r)*i))) . This 

function typically grows faster than the Geometric one.

Variable: BoundaryLayer(GrowLaw). Values: 0 (Function 1), 1 (Function 2) and 2 (Function 3). Default is 

0 (Function 1).

Grow Factor: This variable controls whether the stretching function grows slower (smaller 

values) or faster (bigger values). When Function 1 is used, grow factor must be greater than 

1.0, and when Function 2 or 3 are used, grow factor must be a positive number. Variable: 

BoundaryLayer(GrowFactor). Value: positive real number. Default is 2.0.

The red line below these options shows schematically the difference of heigt of the different layers of 

boundary layer mesh.

Boundary layer mesh in separated Layer: if this preference is set, the mesh elements which 

own to a boundary layer mesh will own to separated layers. The name of these layers will be 

the same as the Layer name of the geometrical entity where elements are, but with the prefix 

'BLM_'. Variable: BoundaryLayer(MeshInSpecificLayer). Values: 0,1. Default is 0.

Smoothing: You can choose the level of smoothing required to enhance the mesh after the 
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generation. Options are:

Normal: only the standard smoothing is performed.

HighAngle: an additional smoothing with angle criteria is performed.

HighGeom: an additional smoothing with chordal error criteria is performed.

Variable: HighQualitySmoothing. Values: 0 (Normal), 1 (HighAngle) and 2 (HighGeom). Default is 1 

(HighAngle).

Mesh until End: If this preference is set, the mesh generator will continue until it has completed the 

operation even if there are surfaces or volumes that cannot be meshed. Variable: MeshUntilEnd. 

Values: 0,1. Default is 1 (Yes).

No Mesh Frozen layers: If this preference is set, entities belonging to a frozen layer will not be 

meshed. Variable: NoMeshFrozenLayers. Values: 0,1. Default is 1 (Yes).

Chordal error: using this option, user can assign a relative chordal error to the whole model. User can 

introduce a relative value (which is percentage, so as the surface and line elements in the mesh won't 

present more chordal error than this percentage of the element size), an absolut value (which is the 

máximum chordal error (distance) allowed in the model), and the minimum element size of the mesh 

(taking into account that in some geometries the element size to achieve a certain limit chordal error 

should bbe very small; this option allows the user to fix a minimum element size). If both relative and 

absolut chordal error limit is set, the more restrictive is applied depending on each element.

  Variable: ChordalError(ApplyChordalErrorToModel) (values 0,1), ChordalError(RelativeChordalError) 

(percentage, positive value), ChordalError(MaxChordalError) (positive value: it is a distance) and 

  ChordalError(MinElemSize) (positive value: it is a distance). Defaults are 0, 0.0, 0.0 and 0.0 (no 

chordal error criteria applied).

Sphere mesher:

           Algorithm: 

                     1 = Optimization radius: iterative, optimizes distances and positions for minimum porosity. 

                     (ref:Carlos Labra, Eugenio Oñate. High-density sphere packing for discrete element 

method simulations, Communications in Numerical Methods in Engineering 2009)

                     2 = Predefined porosity: iterative with fixed radius .Experimental.

                     3 = Radius expansion : iterative, corrects positions and increases radius. 

                     4 = Optimization radius fast: it's 'Optimization radius' with less precision. (Experimental)

                     5 = Explicit: iterative, radius defined with porosity and optimizes positions.(Experimental)

           Max. iterations: Maximum number of iterations for the choosed algorithm.

           Advanced preferences:

           Main:

                    MaxIterLocal: Number of iterations for filters.

                    Tolerance: Tolerance of distance function to terminate the process.

                    MinRadius: minimum radius Factor ( Minimum radius = MinRadius*UserRadius(size of 

element/2) ). 
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                    MaxRadius: maximum radius Factor (Maximum radius = MaxRadius*UserRadius(size of 

element/2) ). 

                    DeltaPosition: perturbation of initial position factor ( Maximum perturbation = 

DeltaPosition*UserSize ).

                    DeltaRadius: Randomness of initial radius.( Minimum radius = (1-DeltaRadius)*UserRadius; 

Maximum radius = (1+DeltaRadius)*UserRadius] ).

NOTE: Delta postition & Delta radius: define randomness of generations ex: if both of them equals 0, 

the generation will be structured.

NOTE: Maximum values recomended for Delta position & Delta radius:

                                      2D: delta position: 0.6; delta radius:0.6

                                      3D: delta position: 0.4; delta radius:0.4

                   Preprocess: initial generation of spheres with porosity.

                   Porosity: Value of porosity for preprocess.

                   Postprocess: correction of final positions.Experimental.

                   Overlaps: checked permits overlaping between spheres. If not checked corrects radius of 

the sphere.

            Filters:

                 Filter: Number of global iterations before activate sphere size filter. 

                 Search: Number of gloabal iterations before activate the search of new overlapings between 

spheres.

                 SearchType: Type of search: ( 1=SpatialSearch(Tree-based) 2:WeightedDelaunyRemeshing 

)

                 ContactFactor: Sphere Neighborhood factor distance( Vecinas si : 

Distance(sphere1,sphere2) < ContactFactor*(sphere1.Radius+sphere2.Radius) )

                 NeighborFactor: Penalty factor between overlaped spheres (in optimization algorithm must be 

1.0)

                 FacetFactor: Penalty factor between overlaped sphere wiht a surface (in optimization 

algorithm must be 1.0).

                 OverlapFactor: Factor to eliminate sphere with overlaps ( delete sphere if maximum Overlap 

> OverlapFactor * Sphere radius )
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Sphere Filter options

Mesh always by default: Changes the default meshing criteria. Entities will always be meshed even if 

they have higher entities. Example: If surfaces are checked when meshing a volume, volume 

elements and surface elements will be obtained. Variable: ForceMeshEntities. Values: 0 (No entity), 1 

(Points), 2 (Lines), 3 (Points and Lines), 4 (Surfaces), 5 (Points and Surfaces), 6 (Lines and 

Surfaces), 7 (Points, Lines and Surfaces). Default is 0 (No entity).

Avoid elements with all its nodes in boundary: if this option is set, there won't be any element in the 

mesh which has all its nodes in the boundary of the geometrical entity. Variable: 

AvoidElementsInBoundary. Values: 0,1. Default is 0 (No).

Allow quadrilateral dominant meshes: If this preference is set, unstructured quadrilateral mesh 

generator is allowed to use some triangles in the quadrilateral mesh to improve elements quality. This 

option only affect to the mesh of surfaces which do not own to any volume. Variable: 

AllowQuadTriMeshes. Values: 0, 1. Default is 0 (No).

9.2.4 Exchange

The fourth group of preferences are geometry exchange (import and export) options.
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Exchange preferences

Import options:

Automatic Collapse After Import: If this option is set then after reading one IGES file, one global 

collapse is made. If it is not set, all surfaces and lines will be independent of each other. 

Variable: AutoCollapseAfterImport. Default is active (1).

Automatic Import tolerance: When importing a file or collapsing entities, any points closer together 

than this distance are considered to be the same (see IGES -pag. 32-). Lines and surfaces can also 

be collapsed.

Variable: ImportTolerance. Default is 0.001.

Collapse

Ignoring Layers: Entities are also collapsed if they belong to different layers.

Each layer separately: Entities in different layers are not collapsed. (Entities belonging to 

frozen layers are never considered.)

Variable: CollapseIgnoringLayers. Value: 0 (Each layer separately), 1 (Ignoring Layers). Default is 1 

(Ignoring Layers).

IGES: Curve on surface from 3D: If this option is set, IGES curves on surface entities are created 

from the direct 3D space definition (recommended); if the option is not set, IGES curves are created 

from the surface space parameter definition. 

Variable: IGESCurveOnSurfaceFrom3D. Value: 0 (space parameter definition), 1 (3D space definition). 

Default is 1 (3D space definition).

IGES: Create all in 'layer to use': If this option is set the IGES entities are created in the current layer 

to use, instead of using the file layers.

Variable: IGESCreateAllInLayerToUse. Value: 0 (IGES entities created in the file layers), 1 (IGES 

entities created in the current layer to use).

Export options:
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IGES: B-Rep output style: If this option is set, exported IGES volumes are written with Boundary 

Representation Solid Model style; otherwise its surfaces are written as separated trimmed surfaces 

without topological information.

   Some CADs are not able to read the IGES B-Rep style and then can be interesting to use the 

alternative style.

Variable: IGESSolidsManifoldBRep. Value: 0 (no B-Rep output style), 1 (B-Rep output stype). Default is 

1 (B-Rep output style).

9.2.5 Fonts

The fifth group of preferences deals with the fonts used inside GiD.

Fonts preferences

Normal font: This is the font normally used inside GiD.

Fixed font: This font must have the same spacing for every letter. It is used in places where this 

property is necessary.

Big font: Used in some dialog boxes.

Comments/Legend font: Used for comments and legend.

Labels/Dimensions font: Used in labels and dimensions.

Asian font: Used to draw asian characters in graphical window.

9.2.6 Format

The sixth group of preferences deals with numerical formats used inside GiD.
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Format preferences

Generic format: This option refers to numerical formats used in other GiD utilities (for example in the 

coordinates display).

Results format: This option refers to numerical formats in results (Postprocess).

9.2.7 Grid

The seventh group of preferences contains grid options (see Grid -pag. 27-).

Grid preferences

Show grid lines: If this option is set, grid lines are shown. Variable: Grid(Show). Value: 0,1. Default is 

0 (No show). It's possible to show/hide grid with the grid button that is located on the bottom right part 

of the main window.

Show labels: If this option is set, labels of the major lines are showed.
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Variable: Grid(DrawLabels). Value: 0,1. Default is 0 (no show labels)

Activate snap: If this option is set, snap is activated. Variable: Grid(Active). Value: 0,1. Default is 0 

(No activate).

X/Y Spacing: These options determine the spacing between grid lines in the X and Y directions. 

Variable: Grid(SpacingX)) and Grid(SpacingY)). Default value is 1.0 in both directions.

Major line every: This option specifies the number of lines between principal lines in the grid. Variable: 

Grid(MajorLineEvery). Default value is 5 lines.

X/Y Extents: These options determine the extension of the grid in the X and Y directions. Variable: 

Grid(ExtentsX)) and Grid(ExtentsY)). Default value is 15.0 in X direction and 10.0 in Y direction.

Draw axis: If this option is set, 2D axes are shown in the grid (X and Y). Variable: Grid(DrawAxis). 

Value: 0,1. Default is 0 (No axis drawn).

X/Y Center: These options determine the position of the center of the grid. Variable: Grid(CenterX)) 

and Grid(CenterY)). Default value is 0.0 (center is at x=0.0,y=0.0).

9.3 Layers

Menu: Utilities->Layers...

Mouse menu: Layers

Toolbar:

Layers

Layers are a way to split a complex drawing up into separate pieces. The idea is that any entity can 

belong to one layer or to none (an entity cannot belong to more than one layer). In this way, it is 

possible to view only some layers and not others. It is also useful for making it easier to select entities in 

the graphical window.

Layers window
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NOTE: with a double click between title bar and icon bar, Layers window will be integrated in the main 

window. To recuperate the original window do the same.

The commands relating to layers are as follows:

Layer To use: Selects a layer to be used as a default. All the new entities will be created within this 

layer. All the layers can be selected here. Next to the Layer To use button, there is an arrow facing 

down. This is a menu which lets you select a point, a line, a surface or a volume; the layer to which 

that entity belongs will be set as the default layer.

On: Entities belonging to this layer will be drawn and can be selected in the graphical window.

Off: Entities belonging to this layer will not be drawn and cannot be selected in the graphical window.

Color: Changes the color of the layer. This color is used when performing a rendering (see Render 

-pag. 53-). The color can also be chosen by clicking on the colored box next to the layer name in the 

list.

Lock/Unlock

(Freeze/Unfreeze): Entities belonging to this layer will be drawn but cannot be selected in any way. 

When copying entities (see Copy -pag. 108-) and sharing old entities, entities belonging to frozen 

layers are not taken into account and not even a range of numbers (see Entity selection -pag. 27-) 

can be selected. The opposite command is Unlock, where the entities belonging to this layer can be 

selected, copied and shared.

Opaque/Transparent 

: Entities belonging to this layer will be rendered (see Render -pag. 53-) opaque or transparent, the 

opacity gradient can be set by the color window. 

Sel...: In the layer window, there is the option select which allows the selection of several layers. This 

can be useful when using a large number of layers. After pressing Sel... a new window appears to 

allow the input of a string of characters that will match the layer's name. In this string, the characters *

 and ? are wildcards that match any characters or character, respectively, in the layer's name. So, the 

string select will match select, selection, select-surface and so on.

New: Creates a new layer. If no name is given, the layer will be called "Layer#". The new layer will be 

used as the default layer until the end of the session or until another layer is selected as the default.

Delete: Deletes a layer. A layer can only be deleted if it has no entities in it.

Rename: Changes the name of a layer.

alphabetic: If this option is set, layers are sorted alphabetically (by name).

To back: Sends entities to the back of its layer. When an entity is "at the back" it is not visible and 

cannot be selected, moved, copied or deleted. To bring the entities of a layer back "to the front" 

again, select a layer and choose the Bring to front option from the To back menu. There is another 

option, Bring All to front, which brings all entities of all layers to the front. If the Opposite option is 

flagged, entities which are not selected will go to the back. 

Sent To: Moves entities to a new layer. No new entities are created. They are only moved from one 

layer to another. When in geometry  mode and selecting point, line, surface, volume or all, the all 

option can only be used to select entities in the graphical window and to change all the entities in the 

dynamic box to a new layer. When in mesh  mode, it is possible to choose nodes, elements or all. 
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With the special option Also lower entities, entities that are lower entities of the selected ones can 

also be sent to a new layer. Example: If this flag is set and one surface is selected, its lines and its 

points are also sent to the layer. 

Set layer to use of an entity: This option permits set layer to use of an entity selecting it.

Close: Closes the Layers window.

Important:  Mesh generation does not depend on the state of the layers when the generation is 

performed (see Layers -pag. 101-). All layers are meshed and every node and element will be assigned 

to the layer where the original geometrical entity was. The only exception to this rule is in the case of a 

frozen layer if the No mesh frozen layers option is selected (see Preferences -pag. 87--> Meshing).

9.4 GMed

GMed is an acronym for GiD Medical. GMed is an adaptive and user-friendly graphical user interface for 

modelling, data input and visualization all types of medical data. GMed is focused in the medical image 

processing in the biomechanical research field to generating meshes from the medical images, to apply 

in Computational Fluid Dynamics (CFD) or structural mechanics (stress analysis, flow problems, etc.). 

GMed contains several tools for the images treatment using advanced images processing. 

Although it's main purpose is medical image processing it is not restricted only to work with images 

coming from that field provided that the data set be stored in one of the format recognized by GMed.

The image formats recognized by GMed are:

3D scalar DICOM Series

3D vector DICOM Series

4D scalar DICOM Series

4D vector DICOM Series

VTK Structured Points

VTK Image Data

The architecture of GMed is shown below in the following picture:
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GMed is based on ITK and VTK. ITK ( http://www.itk.org/) is a cross-platform system which provide an 

extensible suite of software tool for image analysis. VTK (http://www.vtk.org/) is the leading platform for 

3D computer graphics and visualization.

The communication between GiD and GMed is done through Tcl.

With GMed the user can load any of the supported input image data format and visualize it with different 

techniques implemented in VTK. Besides the data can be processed in order to obtain a geometric 

representation of the region of interest. This geometric information is imported into GiD in an automatic 

way.

GMed can be downloaded from "Internet Retrieve" or from the website (www.gidhome.com) an installed 

as plug-in in GiD. It comes in different flavors:

GMed Common: this is the basic module of GMed. It provides the functionalities to read the images, 

visualization and a few filters.

GMed Advanced: this module add to the Common module a superset of the filters

GMed CMR4D: this module implements a hardcoded filter pipeline specific to the analysis of 4D blood 

flow within the aorta.

GMed CMRScar: this module implements a hardcoded filter pipeline specific to the analysis of scar 

formation in the heart muscle.

The license for those modules can be downloaded on demand, and conditions for each license can be 
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consulted in the website (www.gidhome.com), or contacting gid@cimne.upc.edu.

9.5 Tools

Menu: Utilities->Tools

In this menu there are some options to change the appearance of windows and some tools related to 

different aspects of GiD.

9.5.1 Toolbars

Menu: Utilities->Tools->Toolbars...

In this menu you can customize GiD toolbars. They can be displayed inside another window, can appear 

independently in their own dialog box, or can be hidden.

When you select this option, the following window appears:

Toolbars window

Within this window you can choose where on the screen the toolbar is to be displayed - inside, outside, 

top left, bottom right, etc. - or you can switch it off. The GiD toolbars are:

Right buttons: These are the buttons that usually appear on the right-hand side of the window. They 

can perform most of the functions available in the program.

Command line: The bar where commands can be written using the keyboard. It usually appears at 

the bottom of the screen.

Up menu: The pull-down menus located above the graphical window.

Geometry & View bar  and Standard bar: These are icon toolbars used to perform certain 

operations. Click the middle or right mouse button over an icon to get help.

Macros toolbar: This is an icon toolbar where default and user macros are placed.

Note: To make the Up menu appear again, the shortcuts Control-U or Control-Shift-u can be used.
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9.5.2 Save window configuration

Menu: Utilities->Tools->Save window configuration...

It is possible to save a window configuration to a file. Then, if GiD is opened again with the -c  option 

(see INVOKING GiD -pag. 13-) and the file in question, the windows are opened in the same place and 

are the same size as before.

9.5.3 Move screen objects

Menu: Utilities->Tools->Move screen objects

This option lets you move screen objects (objects that do not belong to the model) such as axes, 

comments, legends, etc.

9.5.4 Coordinates window

Menu: Utilities->Tools->Coordinates window...

This option opens a window used to enter points (see Point definition -pag. 23-). It can be used in any 

place where it is possible to enter a point.

Coordiante window

To accept one point in this window, click Apply or press the Return key.

The Coordinate system option lets you select between:

Cartesian: Cartesian coordinate system.

Cylindrical: Enter the radius in the XY plane, the anti-clockwise angle in the XY plane from the x axis 

(theta), and the z coordinate.

Spherical: Enter the radius, the anti-clockwise angle in the XY plane from the x axis (theta), and the 

angle with the z axis (phi).
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The Local axes option lets you choose:

Global: Global axes.

Relative center:  Define a center of coordinates. All new points created with this window will be 

related to this center. In the window where the relative center is entered, you can select a point from 

the graphical window with the Pick button.

Relative last: The last point entered is the relative center of coordinates.

Define new...: This lets you define a new local axes. Once defined, you can select it.

Any local axes: All local axes defined with this option (see Local axes -pag. 126-), will be listed here. 

Points entered will be related to these axes.

Create new point shows the current way of entering points. The Change button opens the preferences 

window (see Preferences -pag. 87- -> General) where it can be changed.

The Pick button allows you to select a point from the window which is then inserted in the point fields. 

From here it can be edited and used.

9.5.5 Read batch window

Menu: Utilities->Tools->Read batch window

A batch file can be read to execute some functions (see Batch file -pag. 40-) or to create an animated 

view of these operations. This latter case can be performed with the Read batch window.

Read batch window

Once a file is selected, it is possible to ***pause it at certain points to highlight interesting parts*** , 

execute it interactively, and make it stop at interesting points. To allow all the movements (rotations and 

so on) be executed in the same way as originally, the Write rotations in batch: option must be flagged in 

the preferences window (see Preferences -pag. 87- -> General) when creating the batch.

There are several ways to halt the batch while it is running. One of them is to include stops in the show 

file section with the Mark break button, and selecting Internal stop. These marks can be saved in the 
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batch file by clicking the Write... button.

The Show info option lets the program write all the usual messages in the GiD messages window.

9.5.6 Comments

Menu: Utilities->Tools->Comments...

Comments can be added to images created with GiD by using this command. Click Apply to display the 

text on the screen as it will appear when printed - either to a file (see Print to file -pag. 45-) or otherwise; 

comments can be changed at any time by clicking the Comments button in the Utilities menu (either 

pull-down or Right buttons menus).

9.5.7 Animation controls

Menu: Utilities->Tools->Animation controls...

Animation controls

This windows lets you create animations while using GiD. Any of these formats can be selected: MPEG, 

AVI True Color, AVI 15bpp (reduced number of colors: 32768) and GIF. AVI with MJPEG compression 

is also supported. After giving a name and a delay time between frames (for 20 frames per second, a 

delay of 1/20 = 50 ms. should be entered) the process can be started by clicking on the start button (film 

roll and arrow icon); the green LED will change to red.

Simply click on the film roll and arrow button to add frame by frame the pictures you want to include in 

the animation. The Save redraws option tells GiD to save every redraw automatically to the animation 

file, so no user intervention is needed to store frames.

The animation can be finished at any time by clicking the end button (closed film roll icon); the red LED 

will change to green.

Note: To avoid problems when trying to view an MPEG  format animation in Microsoft Windows, it is 
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strongly recommended that you use the Default  menu to select a 'standard' size and click the 

Resize  button. The graphical window will change to this 'standard' size. When you have finished the 

animation, simply select Default on the menu and click the Resize button and the previous size will be 

restored.

Note: AVI files with MJPEG compression can be viewed with xanim on Linux and Unix machines, and 

with DirectX 8.x installed on Microsoft Windows machines.

9.5.8 Animation script

Menu: Utilities->Tools->Animation script...

Animation script window

This windows lets you manage and define the movements of the animation. You can chose one of the 

following movements:

zoom/pan: Define a linear movement from Start view to End view in a specify Duration time.

rotation: Define a rotation of the Object or of the Screen by entering Center  point, the three axes 

angles and Duration time.

render: Command to change the render state to Normal, Flat or Smooth

9.5.9 Macros

Menu:  Utilities->Tools->Macros... 
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Window for creating and recording macros

Windows 'Macros' allow you to create sequences of commands and give them a name. This group of 

commands can also be recorded from one execution set inside the program.

It is possible to assign a keyboard shortcut to a given macro.

Note:  Macros are considered as a user preference and not related to the active model. So, to transfer a 

set of macros from one user to another it is necessary to copy the appropiated 'Macros.tcl' file (its 

location is platform dependent) 

9.5.10 Selection window

Menu:  Utilities->Tools->Selection window... 

Mouse menu:  Contextual->Sel window 

For those functions where some entities are to be selected (creation of a surface or a volume, copying 

entities, etc.), it is possible to use the Selection window. The selection window lets you take control of 

the selection process.
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Selection window

Note:  The Sel window option is only available in the mouse menu during the selection process. 

The Selection window has the following options:

Select all: If this option is chosen all entities are selected. If a filter is selected, it is applied to all 

entities.

From, To: This option lets you select a range of entities. If a filter is selected, it is only applied to that 

range of entities. To see the ID numbers of entities, use the Label command (see Label -pag. 60- ). 

Mode: There are three selection modes:

Swap : If you select an entity that is already selected, the entity is deselected, and vice versa. 

Add : In this mode it is impossible to deselect an entity. Only new entities are added to the 

current selection. 

Remove : In this mode it is impossible to add entities to the selection. This mode is used to 

remove entities from the current selection. 

Filter: If a filter is selected, only the entities that satisfy the filter criteria will be selected. This menu 

changes depending on what type of entity is being selected:

Points

Higher entities: You are asked for a value, and all points with this Higher Entity number 

are selected (Higher Entity number is the number of lines that a point belongs to).

Label: Selects all points where a Label is shown or not (On or Off).

Material: All points with a chosen material assigned are selected.

Condition: All points with a chosen condition assigned are selected.

Lines

Higher entities: You are asked for a value, and all lines with this Higher Entity number 

are selected (Higher Entity number is the number of surfaces that a line belongs to).

Label: Selects all lines where a Label is shown or not (On or Off).

Material: All lines with a chosen material assigned are selected.

Condition: All lines with a chosen condition assigned are selected.

Min. length: Selects only the lines whose length is greater than the given length.

Max. length: Selects only the lines whose length is smaller than the given length.

Entity type: Selects only the lines which fit the specified type: StLine (Straight Line), 

ArcLine, PolyLine or NurbLine.

Surfaces

Higher entities: You are asked for a value, and all surfaces with this Higher Entity 

number are selected (Higher Entity number is the number of volumes that a surface 
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belongs to).

Label: Selects all surfaces where a Label is shown or not (On or Off).

Material: All surfaces with a chosen material assigned are selected.

Condition: All surfaces with a chosen condition assigned are selected.

Entity type: Type of surface.

Volumes

Label: Selects all volumes where a Label is shown or not (On or Off).

Material: All volumes with a chosen material assigned are selected.

Condition: All volumes with a chosen condition assigned are selected.

Entity type: Type of volume.

Nodes

Label: Selects all nodes where a Label is shown or not (On or Off).

Condition: All nodes with a chosen condition assigned are selected.

Elements

Label: Selects all elements where a Label is shown or not (On or Off).

Material: All elements with a chosen material assigned are selected.

Condition: All elements with a chosen condition assigned are selected.

Min Angle: Selects only the elements with an angle greater than the figure specified in 

degrees (see Mesh quality -pag. 146- ). 

Max Angle: Selects only the elements with an angle smaller than the figure specified in 

degrees (see Mesh quality -pag. 146- ). 

Min Edge: Sets the minimum edge length accepted (see Mesh quality -pag. 146- ). 

Max Edge: Sets the maximum edge length accepted (see Mesh quality -pag. 146- ). 

Shape quality: Sets the minimum shape quality accepted (see Mesh quality -pag. 146-

 ). 

Minimum Jacobian: Sets the minimum jacobian accepted (see Mesh quality -pag. 146-

 ). 

Entity type: Type of element (see Element type -pag. 137- ). 

Clear: Clears the current selection.

9.5.11 Calculator

Menu: Utilities->Tools->Calculator...
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vector calculator

This option opens a scalar and vector calculator. Clicking the help button open a dedicated help section.

It is possible to transfer scalar and vector points and distances between the calculator and the main 

graphical display.

9.5.12 Report

Menu: Utilities->Tools->Report...

report window

This option creates a report in html format to which figures, comments, titles, etc. can be added. This 

report can be saved to a file and then reloaded in another GiD session where it can be edited or have 

more information added to it.
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9.5.13 Notes

Menu: Utilities->Tools->Notes...

This is a simple text editor for writing small notes regarding the model. The content is saved in a file 

named ModelName.txt, with utf-8 encoding.

9.6 Copy

Menu: Utilities->Copy...

Toolbar:

Copy / Transform

Copy window

Copy is a general function that allows you to select a group of entities and copy them with a movement 

operation performed, either translation, rotation, mirror, scale or offset.

Select the type of entities to copy. In geometry mode choose between point, line, surface and volume; 

in mesh mode choose between nodes and elements. All the lower entities belonging to the selected one 

will automatically be computed. Next, the type of movement needs to be chosen and its parameters 

defined. The options are:
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Rotation: It is necessary to enter two points in 3D, or one point in 2D. These two points define the 

axis of rotation and its orientation. In 2D, the axis goes from the defined point towards z positive. 

Enter the angle of rotation in degrees; it can be positive or negative. The direction is defined by the 

right hand rule. In 2D, the direction is counter-clockwise.

Translation: Two points are defined. Relative movements can be obtained by defining the first point 

as 0,0,0 and considering the second point as the translation vector (see Point definition -pag. 23-).

Mirror: Three points are defined (they cannot be in a line). These points form the mirror plane. In 2D, 

the mirror line is defined by two points.

Scale:  This is defined by a center and a point. Every coordinate of the point is the scale factor for 

every x,y,z axis. A scale factor greater than one increases the size, while a scale factor less than one 

decreases the size. It may also be negative, changing the sign of the corresponding coordinates.

Offset: This is defined by one positive or negative scalar magnitude. Each entity will be moved in the 

direction of its normal, by the magnitude given. In 2D, the normal is considered to lie in the plane z=0. 

This option works either for lines, surfaces or mesh elements.

Sweep: This is an option for copying figures along a line (path line). You can simply copy the figures 

(and then specify a number of copies) or extrude them. Both methods have basically the same 

options.

The 'end scale' factor determines how the figure is scaled along the path curve (the scale value starts at 

1.0 and varies in a linear way until the 'end scale' value). This scale value must be greater than zero.The 

extrusion (and the copy) always starts on the start point of the path line. If you select 'twist mode' as on, 

then the relative position of the figure to copy with respect to the start of the path line is conserved along 

the line.
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Twist mode off and on

In a non-planar curve, there is not only curvature, but also torsion. This may cause some unexpected 

behaviour, because the figure also has a rotation along the tangent direction of the path:

Natural twist option

Next the 'XY plane' option is used, which makes certain that the initial vector will remain in this plane 

during extrusion. (In this example, the axis is Z).
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The option 'ByDer2' uses the second derivate of the path line as a normal to the plane in which that 

initial vector has to remain. A rotation along the path line can be forced using the 'Angle' parameter 

(degrees):

Finally, if the path line is a polyline, then the extrusion will be divided into several parts:

Align:  This is an option to move figures from a generic position to the desired one. Set the new 

location specifying three source points and three destination points: the first point defines the exact 

destination of the source point; the second point is not necessarily the exact destination, but a point 

over the destination straight line; the third point is not necessarily the exact destination, but a point 

over the destination plane
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Tool to align parts

Other available options are:

Duplicate entities: If this option is not set and after the copy operation an entity occupies the same 

position as an existing one that does not belong to a frozen layer, both entities are converted into one.

Extrude: This option can be set to either lines, surfaces or volumes. When a movement is selected, 

the copy is made and lines connecting the old and new points are created. These lines will either be 

straight lines or arcs depending on the movement type. If extrude surface is chosen, NURBS surfaces 

connecting old and new lines will also be created. If Volumes is chosen, the volume contained 

between old and new surfaces is also created. This option is not allowed when copying volumes.

Create contacts:  Creates separated contact volumes (see Contact creation -pag. 73-) for every 

copied surface. This option is only available when copying surfaces.

Maintain layers: If this option is not set the new entities created will be placed in the layer to use; 

otherwise, the new entities are copied to the same layers as their originals.

Multiple copies: By selecting this option and giving the number of repetitions, the selected operation 

is performed this number of times. This option is not available for mirror.

Note:  Entities belonging to a frozen layer (see Layers -pag. 101-), are not checked when sharing old 

entities.

9.7 Move

Menu: Utilities->Move...

This command works like Copy but moves the entities instead of copying them. The program 

automatically checks to see if any of the entities must be copied instead of being moved (for example, if 

they also belong to other higher level entities) and performs the appropriate operation.

Options like Extrude, Multiple copy and Create contacts are disabled for movements.

9.8 Status

Menu: Utilities->Status...
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Project status window

The Status option gives useful information about general project data.

9.9 List

Menu: Utilities->List...
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List entities window

The List command gives information about the selected entities. This information is read-only.

If the Mass option is checked, information about physical properties is given: lengths of lines, center of 

mass, areas of surfaces, volumes of solids. It works for both the geometry and the mesh.

All this information can be sent to the active report (see Report -pag. 113-) by using the  button.

9.10 Renumber

Menu: Utilities->Renumber

When creating new entities, the label of the new entity will be the lowest number greater than 0 that still 

does not exist for this entity type. If an entity is deleted, a gap is left in the labels list. This gap will be 

filled with a new entity, but it is also possible to renumber the geometry, changing the previous entity 

labels. There are no problems with materials and conditions applied to entities.

In geometry mode, the renumbered entities are the geometrical ones.

In mesh mode, the renumbered entities are the mesh ones. In this case, renumbering not only fills the 

gaps in the labels list but also changes the node numbers so as to minimize the difference in node 

numbers within each element. This can be useful when the calculating module uses band or skyline 

storage methods.

The nodes renumeration algorithm can be set with the variable 'RenumberMethod' (see Preferences 

-pag. 87-)

Accepted values are:

-2 : Avoid nodes and elements renumeration, entities numbers are set increasingly when they are 
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generated. 

-1 : Avoid nodes renumeration, nodes numbers are set increasingly when they are generated

 0 : Geometrical algorimth, ordered by the distance to some coordinate. It is the default value

 1 : Reverse Cuthill-McKee algorimth, similar to the previous one, but following element's connectivities

 2 : ordered following the XYZ axes, interesting for special cases with geometry aligned to the axes

Note:  When generating a mesh using GiD it is not necessary to use this command because it is 

automatically applied when generating the mesh.

Note:  Negative numbers in this variable are understood as internal checks and tests, so they are not 

loaded from the model if it's meshing preferences are set.

9.11 Id

Menu:  Utilities->Id 

This command gives the label and coordinates of an existing or new point. Different options for getting 

information about an existing point are available in the Contextual  menu. 

9.12 Signal

Menu:  Utilities->Signal 

With this option you can select one entity (a point, line, surface or volume), and a pair of crossed red 

lines will signal the center of the entity in the graphical window.

They must be existing entities, except the special case of points or nodes, where they can be existing or 

defined with any of the usual methods.

The Superpose Lines option (in the Contextual   menu) is useful when in render mode. Depending 

whether it is set or not, the crossed red lines will either be in front of the object or partially hidden by the 

model. 

9.13 Swap normals

Menu: Utilities->Swap normals

This command can be applied to lines or surfaces (in geometry mode) or to elements (in mesh mode). A 

selection is made (see Entity selection -pag. 27-) and the orientation of the selected entities is inverted.

Viewing commands (zoom, rotation, etc.) can be applied and the normals will remain on the screen.

When this command is applied to surfaces or mesh elements, you can choose one of the following 

options:

Select: Inverts the direction of the normals of the selected surfaces.

Make coherent: Inverts the normals of all selected surfaces or elements so that all of them have their 

normal in the same direction as adjacent entities. This direction is arbitrary, but is common to all 

adjacent entities.
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Select by normal: You are prompted to enter a vector and all selected entities' normals are swapped 

so as to have their normal in the same direction (dot product positive) as the given vector.

Note: With the Color option set (available in the Contextual mouse menu), all surfaces or elements are 

drawn in filled color. Their front side will be drawn in their regular color, and their back face in yellow.

Note: Volumes are correctly oriented by GiD, regardless of their surface orientation.

9.14 Distance

Menu: Utilities->Distance

The Distance command gives the distance between two existing or new points.

9.15 Dimensions

Menu: Utilities->Dimension

With the dimensions option it is possible to add textual information to your model. This information can 

be moved to a different layer or deleted.

The following options are available:

Menu: Utilities->Dimension->Create

Vertex: Shows the coordinates of a vertex. Click over an existing point and then click where you want 

the dimension to be written.

Distance: Shows the distance between two points. You have to select two points and then click 

where you want the dimension to be written.

Angle: Shows the size of an angle in degrees. You have to select three points and then click where 

you want the dimension to be written.

Radius: Shows the center and radius of an arc. You have to select an existing arc and then click 

where you want the dimension to be written.
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Text: Shows a text string defined by the user. Enter the text and click where you want the text to be 

written.

Menu: Utilities->Dimension->Delete

Deletes a "dimension". Select the dimension you want to delete and press ESC.

Menu: Utilities->Dimension->Edit

Select the dimension you want to edit, change the text, and click OK.

Menu: Utilities->Dimension->ShowBox

This option lets you change the appearance of a "dimension"; a "dimension" can be drawn with or 

without a box. Choose ShowBox on or off, select a "dimension", and press ESC.

9.16 Repair model

Menu: Utilities->Dimension->Repair model

This option checks the coherence of the database information. Only use it if there are problems. When 

used, a window notifies you of any repaired items and may give some warnings about incorrect entities.
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All the data that defines the problem and that is managed in the data menus, depends on the Problem 

Type  and will change for every different problem type. The following help will describe the common 

interfaces to all the possible data.

Data for a problem is defined by the following parameters: conditions (see Conditions -pag. 122-), 

materials properties (see Materials -pag. 123-), units (see Data units -pag. 125-), problem data (see 

Problem data -pag. 125-), and intervals data (see Interval data -pag. 124-) that define the problem. The 

conditions and materials have to be assigned to geometrical entities. It is also possible to define new 

reference systems (see Local axes -pag. 126-).

The various windows will differ according to the specifications of the problem (thermoelastic, impact, 

metal-forming, etc.), the different types of elements (2D or 3D, beams, shells, plates, etc.) and also the 

different requirements and specifications of the particular solver.

All the commands and facilities that are explained in this manual are generally available for the different 

solvers. However, there may be some commands and facilities that are only available to some of them 

and therefore some displays may look slightly different from those explained in these pages.

10.1 Problem type

Menu: Data->Problem type

This option lets you choose between all installed Problem Types. When selecting a new problem type, 

all information about materials, conditions and other data parameters that were already selected or 

defined is lost.

Note:  When defining a new problem type which is not already installed, it must be selected by other 

means. One possibility is to select Problem type -> Load... . Another possibility is to select "data defaults 

problemtype" in the Right buttons menu or enter it in the command line.

A problem type is considered to be installed when it has been copied to the GiD Problem Types 

directory or to another subdirectory within this.

Note: Instead of copying the problem type to the Problem Types directory, it is also possible to create a 

Windows shell link (a direct access), or a UNIX link, pointing to the real location. This option is 

particularly interesting for developers, as it avoids duplicating the code.

10.1.1 Transform problem type

Menu: Data->Problem type->Transform...

This option can be found inside the Problem Type menu and is useful for updating a model from an old 

problem type to a newer one that is similar to the first.

When converting, it tries to maintain all the conditions and materials assigned to the geometry or mesh. 

Also, it tries to maintain the rest of the data.
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It will typically be used when a problem type has been updated and it is necessary to reuse a model 

defined with the old version.

10.1.2 Internet Retrieve

Menu: Data->Problem type->Internet Retrive...

With this option it is possible to download new problem types or update existing ones.

Note: You need to be connected to the internet to use this option.

Select a list item and use the Problem type info and Problem type news  buttons to get information 

about them.

Use the Retrieve Problem type button to download the selected problem type. The problem type will be 

installed inside the Problem Types directory.

10.1.3 Load

Menu: Data->Problem type->Load...

The Load... option allows you to load a previously installed problem type from the current or another 

directory. This possibility is useful when developing a new problem type which cannot be installed until it 

is finished, or if the developer does not have permission to write to the Problem Types directory.
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10.1.4 Unload

Menu: Data->Problem type->Unload

This option unloads the problem type currently in use.

Sometimes it is easier to work with a model that does not have an associated problem type. It is also 

useful for sending a model to another user who does not have the problem type in question.

10.1.5 Debugger

Menu: Data->Problem type->Debugger...

This tool is a graphical debugger for the scripting language Tcl/Tk.

This debugger has additional capabilities such as:

Editing the code. It is possible to edit the code inside its own editor and resend the new code without 

closing the debugged program.

The Tcl/Tk source code is colorized and supports automatic indentation.

When one source code line stops the debugger, it is possible to view all the variables and expression 

values, as well as change them.

It has additional options to measure execution times in the debugged program.

Debugger
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It is possible to use Tcl/Tk to enhance a problem type (see TCL/TK EXTENSION).

Tcl code can be invoked inside GiD from a problem type (.tcl, .bas, .bat or .xml files), from user-defined 

macros, from a batch file, etc.

More information can be found in this debugger's own help section.

10.2 Conditions

Menu: Data->Conditions

Conditions are all the properties of a problem (except materials) that can be assigned to an entity.

An example would be the boundary forces and displacement constraints in a solid mechanic analysis or 

initial velocities in a CFD analysis. Information about contact between master-slave nodes can also be 

considered as conditions.

Caution: Once a mesh has been generated, any changes made to the condition assignments require 

you to regenerate the mesh in order to transfer these new conditions. If this new generation has not 

been performed, GiD will warn you when the data for the analysis is being written.

10.2.1 Assign condition

A condition is assigned to geometric entities or layers that have the given field values.

If you are using the AssignCond command in the Right buttons menu, the Change option allows you to 

define the field values. Do not forget to change these values before assigning. Selecting DeleteAll 

erases all the entities that have this particular condition assigned.

Conditions can be assigned both to the geometry and to the mesh, but it is advisable to assign them to 

the geometry because in this way the conditions will then be transferred automatically to the mesh. If 

assigned to the mesh, any re-meshing will cause the conditions to be lost.

The UnAssign command inside AssignCond allows a condition to be unassigned, either from all entities, 

or just from those that have a specified field value.

Caution: Once a mesh has been generated, any changes made to the condition assignments require 

the mesh to be regenerated.

Some conditions may have a behaviour that depends on the type of the chosen axes. You can choose 

whether to use global axes or any of the local axes previously defined with the local axes command (see 

Local axes -pag. 126-), or, alternatively, another kind of automatic local axes calculations. In this second 

case, different axes are created according to the adopted criteria of tangency and orthogonality with the 

geometry. Conditions file (.cnd)

10.2.2 Draw condition

The DrawAll option draws all the conditions assigned to all the entities. This means that a graphical 

symbol or condition name will be drawn over every entity that has this condition.
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If one particular condition is selected, you can choose Draw for just one field. Draw is like DrawAll, but 

for one particular condition only. If one field is chosen, the value of this field is written over all the entities 

that have this condition assigned.

If the condition has any field which refers to the type of axes, the latter can be visualized by means of 

Draw local axes.

The Draw colors option draws groups of entities with different colors depending on the values assigned 

to them for this condition.

You can apply all graphical functions (zoom, rotate, ...) and all the condition symbols are maintained in 

active mode in the graphical window until you select escape or click Finish in the conditions window.

10.2.3 Unassign condition

When using the UnAssign window, you can choose between several possibilities:

Unassign one condition from some selected entities.

Unassign one condition from all the entities that may have this assigned.

Unassign all conditions of a book from all the entities that may have them assigned.

Unassign all conditions from all the entities that may have them assigned.

When using the command line or the Right buttons menu, UnAssign works as the fourth option above, 

i.e. all conditions. To unassign only one condition, use the DeleteAll command (see Assign condition 

-pag. 128-).

10.3 Materials

Menu: Data->Materials

For any problem that needs a definition of materials, there is a database of existing materials that can 

be assigned to entities. You can also create new materials derived from existing ones and assign them 

as well.

Caution: Once a mesh has been generated, any changes made to the assigned materials require you 

to regenerate the mesh or reassign these materials to the mesh directly. If only the material definition is 

changed (i.e. some field value) then is not necessary to re-mesh again.

10.3.1 Assign material

This option is used for assigning a material to some selected entities.

When working in geometry  mode, the kind of entity to which you wish to assign a material must be 

selected, i.e. point, line, surface or volume; when working in mesh  mode, you select directly the 

elements to which the material is to be assigned. 

Note: A material cannot be applied over nodes; a material only assigned to points will be transferred to 

1-node elements if generated, but not to nodes themselves.

If assigning from the command line, the UnAssignMat option erases all the assignments of a particular 
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material.

Caution: Once a mesh has been generated, any changes made to the assigned materials require you 

to regenerate the mesh or reassign these materials directly to the mesh.

10.3.2 Draw material

This option draws a color indicating the selected material for all the entities that have it assigned. It is 

possible to draw just one material type or, alternatively, to draw all materials. To select just some of 

them use a:b and all material numbers that lie between a and b will be drawn.

10.3.3 Unassign material

When using the UnAssign window, you are presented with several possibilities:

Unassign one material from some selected entities.

Unassign one material from all the entities that may have this assigned.

Unassign all materials from all the entities that may have them assigned.

When using the command line, UnAssign works as the third option here, i.e. all materials. For only one 

material, use UnAssignMat (see Assign material -pag. 129-).

10.3.4 New material

When using the NewMaterial command, a new material is created taking an existing one as a base 

material. Base material means that the new material will have the same fields as the base one. 

Following this, all the new values for the fields can be entered in the command line.

It is also possible to redefine an existing material.

To create a new material or redefine an old one using the materials window, write a new name or an 

existing one and change some of the properties. Then click Accept.

10.3.5 Exchange material

It is possible to import and export materials between the model database and an external one. Typically, 

one centralized database of materials is maintained and every new model gets its properties from there.

Note: If you wish to exchange materials with the problem type database, it is necessary to check that 

you have permission to read/write in that directory.

10.4 Interval data

Menu: Data->Interval Data

This is the information that is specific to each individual interval (see Intervals -pag. 125-).

It can be entered with the IntervalData command or in the Interval Data window.

If entered in the window, the data is not accepted until you click the Accept button.
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This data can be entered before or after meshing.

10.5 Problem data

Menu:  Data->Problem Data 

Problem data refers to all the data that is associated generally with the problem. This means that it is not 

related to a geometrical entity and it does not change for every interval of the analysis.

It can be entered with the ProblemData command in the Right buttons  menu or in the Problem Data 

window. 

If entered in a window, the data is not accepted until the you click the Accept button.

This data can be entered before or after meshing.

10.6 Data units

Menu:  Data->Data units 

Data units refer to the units defined in the problem. This option only appears if the problem type loaded 

has units defined.

You have to declare the length units of the current model and the unit system to be used when writing 

coordinates and data properties in the calculation file (values will be converted from the current units to 

the selected system units).

It is possible to set a user-defined unit system, but this feature can be disabled (see Unit System file 

(.uni) ). 

10.7 Intervals

Menu: Data->Intervals

Intervals are a way of separating information into several groups; information for every group can also 

be duplicated, if desired. When a new interval is defined, you can choose whether or not to copy all the 

new information about conditions assigned to entities.

Therefore, the correct way to work is to define all the conditions first and afterwards create the new 

intervals.

The options are:

New: You can define as many intervals as you wish using this command. When creating a new one, 

you can choose whether or not to copy the assigned conditions. To copy them, conditions must 

already have been assigned (see Conditions -pag. 128-).

Current: Chooses the current interval to use. Any subsequent conditions or interval data (see Interval 

data -pag. 130-) will be considered inside this interval.

Delete: Deletes one existing interval and all its related data.

These groups, or intervals, can be used to change some conditions or information, like the increment 

factor in an incremental analysis. They can also be useful in order to define load states for the same 
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geometry.

10.8 Local axes

Menu: Data->Local axes

With this option, GiD lets you define new coordinate reference systems. They can be writen not only 

using cartesian reference systems, but also with reference to Euler angles. All user-defined systems are 

automatically calculated and can be visualized one by one or all together.

There are several ways to define new local axes:

3 Points XZ: Enter three points that corresponds to the origin, the X-direction and the Z-direction. The 

origin and the last introduced point define the Z-axis, whereas the second point indicates the side of 

the x-z plane where the point lies.

X and angle: Enter two points and one angle. The first point is the center, the second point indicates 

the X-axis and the angle indicates the position of the Y and Z axes. In the graphical window it is 

possible to set this angle by moving the mouse. It also indicates where the origin of the angle is. The 

angle can be entered either by clicking the mouse or by entering the exact value in degrees.

When defining local axes, the definition mode is done through three points 3PointsXZ.

Local axes can be used later when creating a point (see Point creation -pag. 65-) or in some conditions 

that have a field related to these axes (see Conditions -pag. 128-).
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Generating a mesh is the process by which a finite element mesh is calculated from the geometry 

definition. This mesh will be used for the FEM analysis at a later stage. Conditions (see Conditions -pag. 

128-) and materials (see Materials -pag. 129-) assigned to geometric entities will be transferred to the 

nodes and elements of the new mesh.

What is meshed and how it is meshed is controlled by some default options which can be changed with 

the commands described later.

The generation does not depend on whether layers are ON or OFF at the moment of generation (see 

Layers -pag. 101-), but frozen layers are not meshed if the preference NoMeshFrozenLayer is selected 

(see Preferences -pag. 87- -> Meshing). Every node and element will be assigned to the layer in which 

the original geometrical entity was defined.

The defaults are:

An entity is meshed if does not belong to a higher level entity.

A line mesh is made of two-noded elements and a surface mesh is made of non-structured triangular 

elements. The default for Structured meshes is quadrilateral elements. Unstructured Volume Meshes 

are composed of non-structured tetrahedral elements, Structured Volume Meshes are composed of 

hexahedra and Semi-Structured Volume Meshes are composed of prisms.

All these default elements use linear interpolations for the unknown variables.

11.1 Unstructured

Menu:  Mesh->Unstructured 

Note:  Size is given by the average side length (edge) of the corresponding mesh element. 

Assign sizes on points, lines, surfaces or volumes:

It is possible to assign different sizes to different entities of the mesh. This means that in the vicinity of 

these entities, the generated elements will be approximately of that size. All the entities that do not have 

an assigned size when meshing take the default one. Points do not take any size if none is given.

Assigning the size 0.0 to an entity is the same as setting the default size. The transition between 

different sizes is controlled by a parameter in preferences (see Preferences -pag. 87-  -> Meshing). 

Sizes by chordal error:

Menu:  Mesh->Unstructured->By chordal error... 

The By chordal error option asks for a chordal error (the maximum distance between the generated 

element and the real geometry) and also minimum and maximum size limits. GiD assigns the 

corresponding sizes to all the entities to satisfy this condition. It will only change the current sizes if the 

new one is smaller than the one defined previously. In structured surfaces, stretching is permitted. This 

means that if necessary, elements can have very different sizes in the two principal directions. 
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Note:  Entities are assigned a size between the minimum and maximum; however, when generating the 

mesh, GiD may adapt the size of the elements if necessary, sometimes exceeding the minimum and 

maximum limits. 

Assign sizes by chordal error window

In this window you can view the effect of different chordal error values on the number of elements that 

will be created over a line. Any line of the geometry can be picked and be used in this window.

Correct sizes:

Menu:  Mesh->Unstructured->Correct sizes... 

When the Correct sizes option is selected, a window appears. In this window it is possible to enter a 

minimum and a maximum mesh size.

Correct meshing sizes window

If the By geometry option is activated, sizes are assigned to all the entities depending on the shape of 

the geometry. This means that smaller surfaces will have smaller elements.

If the Correct incompatible sizes option is activated, some sizes are reduced to ensure that the 

transitions between sizes in close entities are not too fast.
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It will only change the existing sizes if the new size is smaller than that previously defined.

Note:   Applying the last two options with default values is the same as setting the Automatic correct 

sizes preference to Normal in the preferences window (see section Preferences). 

Note:  When meshing a difficult volume, instead of trying to adjust element sizes and geometry detail, it 

may be useful to use the By geometry and Correct incompatible sizes options, setting the Maximum 

meshing size as equal to the default size for meshing, and setting the Minimum meshing size to reflect 

the details (10 times smaller, for example). Sometimes it is also necessary to assign sizes by cordal 

error. 

Sizes by background mesh:

Menu:  Mesh->Unstructured->Background mesh... 

With this option it is possible to assign sizes using a background mesh of triangles or tetrahedra. When 

this option is selected GiD asks for a file; that file must contain the background mesh. The background 

mesh must cover the whole domain, so it will usually be a previous mesh of the same model. The format 

of the file containing the background mesh is the following:

First line: BackgroundMesh V 1.0

Description of the mesh. The format of that mesh is described in the Mesh read  section (see GiD mesh 

-pag. 37- ). 

Desired sizes in the following format:

DesiredSize (Nodes or Elements)

  number of size

  node/element

...

Background mesh file example: 

BackgroundMesh V 1.0

MESH dimension 3 ElemType Triangle Nnode 3

Coordinates

      1 5.61705 4.81504 0.00000

 ...

     51 -5.64191 -1.53335 0.00000

end coordinates

Elements

      1 24 16 26 

      2 16 10 14 

...

     76 34 31 28 
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end elements

DesiredSize Elements

      1 0.20000

      2 0.20000

...

     75 1.50000

     76 1.50000

End DesiredSize

Assign entities:

This option is used to assign an unstructured mesh to geometrical entities (lines, surfaces or volumes). 

Using this option it is not necessary to specify an unstructured size for entities; the default size will be 

set for them.

CAUTION:   Be careful when assigning large sizes to entities close to others where a small size has 

been given. It may be impossible to obtain a mesh. 

CAUTION:  When using contact elements (see Contact surface creation -pag. 72-  and Contact creation 

-pag. 73- ), the same size must be used for contact and duplicate entities. 

11.2 Structured

Menu: Mesh->Structured

A structured mesh is defined as a mesh where all the nodes have the same number of elements around 

them.

The size of the elements is defined in a different way than for a non-structured mesh. In this case, the 

mesh is not defined by the size but by the number of elements that are required on every line. This 

number must be the same for all lines that are opposite each other on each surface. When meshing 

volumes, this definition must be the same for opposite surfaces.

To create a structured mesh, choose Structured -> Volumes/Surfaces/Lines. After selecting escape, the 

number of elements per line is given. Later, lines can be selected and related lines (when dealing with 

surfaces or volumes) are added or deleted from the group. This process can be repeated as many times 

as necessary until all lines have a new value. Lines with no numbering given will have two elements 

over them. All non-selected lines will also have two elements by default.

In the case of surfaces, structured meshes can be four-sided, three-sided or centered structured.
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Four-sided structured surface mesh

Three-sided structured surface mesh Centered structured surface mesh

By default, the generated elements in four-sided structured meshes are quadrilaterals, but they can be 

triangles. In this case, triangles can be symmetrical or non-symmetrical (see Preferences -pag. 87- -> 

Meshing).

Symmetrical structured triangle mesh Non-symmetrical structured triangle mesh

Three-sided structured meshes (relating to a three-sided surface) and centered structured meshes can 

only be meshed with triangles. Centered structured meshes can be centered either at a point on the 

surface itself, or at a point located on a particular surface boundary; for this, use the Set center option. If 

a center is not set, GiD will locate it automatically.



130 Reference Manual

Centered structured mesh whith center inside the 

surface

Centered structured mesh whith center in the surface 

boundary

When selecting this kind of structured mesh (i.e. centered), the following window appears where you 

need to enter the number of concentric and perimetric divisions, as well as the two weights to 

concentrate elements in the center of the structure or in the boundary.

Centered structured meshing window

In the case of volumes, a structured mesh is usually six-sided,but it can also be five-sided.
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Six-sided structured volume mesh

Structured volume mesh with a 

three-sided structured surface 

mesh at each end

Structured volume mesh with 

centered structured surface mesh 

at each end

By default, the generated elements in six-sided structured volume meshes will be hexahedra, but they 

can be tetrahedra or prisms. In the case of tetrahedra, they can be symmetrical or non-symmetrical (see 

Preferences -pag. 87--> Meshing).

Symmetrical structured tetrahedra mesh Non-symmetrical structured tetrahedra mesh

In the case of a centered structured or a three-sided surface in tops, the default element type is prism, 

but you can also choose to use tetrahedra.

In the case of a six-sided structured volume mesh, volumes must have six contour surfaces.

It is possible to mix some entities with structured meshes and others with unstructured ones.

To convert a structured entity to a non-structured one, select reset (see Reset mesh data -pag. 141-) or 

assign an unstructured mesh to it (see Unstructured -pag. 133-).

To change the default element type see Element type -pag. 137-.

Note 1:  One NURBS surface can be structured with any number of contour lines but it must have a 

good shape form. This means that it must have four large angles and the other angles must be small 

(four corners). With this criterion, the shape will be topologically similar to one quadrilateral.

Note 2:  When assigning structured divisions to a line or with difficult topology, GiD may need to 

reassign some number of divisions to make the structured mesh conformal; this will be done 

automatically. If it is impossible to create compatibility between surfaces, a message is displayed.
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Note 3: It is possible to assign a number of structured divisions to the boundary line of a surface or 

volume, and then create an unstructured mesh for the surface/volume.

11.2.1 Element concentration

Menu: Mesh->Structured->Lines

By default, all partitions in one structured line have the same approximate length. This command lets 

you select one line, which will be shown in the graphical window with an arrow indicating its direction. 

You then have to enter a positive or negative weight. If the weight is positive the elements will be 

concentrated towards the extremities of the line; if negative, the elements will be repelled.

As the magnitude of the weight increases, the difference between element sizes will be greater.

11.3 Semi-Structured

Menu: Mesh->SemiStructured

A semi-structured mesh is a mesh that is structured in only one direction of the volume and is 

unstructured in the other two directions. For example, in a prismatic volume, the meshing on the sides of 

the object could be structured, while the meshing on the surfaces at each end could be unstructured. 

The surfaces on both ends must be topologically equal.

Depending on the element type selected for each surfaces of the volume, the elements will be 

hexahedra, prisms or tetrahedra.

Note: When assigning divisions in the structured direction, GiD may need to reassign some number of 

divisions to make the structured mesh conformal with the surrounding ones; this will be done 

automatically. If it is impossible to create compatibility between surfaces, a message is displayed.
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Set Master surface or Structured direction:

The structured direction of the prismatic volume can be set by using this option. If no structured direction 

is set, GiD will assign it automatically. This option makes sense in the case of volumes with multiple 

prismatic directions, so you can specify which one you want to use.

With semi-structured volumes (since they are prismatic) two end surfaces can be distinguished. They 

will have topologically identical meshes, so one of them is obtained from the other. The Master surface 

is the one that is meshed first, so its mesh will determine the topology of the slave mesh at the opposite 

end. By selecting Set -> Master surface one top surface can be forced to be the Master one, and the 

structured direction is then set automatically.

Trick: there is a variable: AlignSemiStructuredNodes (see Preferences -pag. 87-) to force the prismatic 

nodes de be exactly aligned if possible.

11.4 Cartesian

Menu: Mesh->Cartesian

A cartesian mesh is a mesh where all elements are bricks with equal size, and edges parallel to the XYZ 

cartesian axes.

The grid nodes can be referenced with integer index i,j,k

This kind of grids are useful for Finite Differences methods.

example: from lef to right the original geometry and two cartesian meshes

It's possible to set this kind of meshing to any geometric entity: volumes, surfaces, lines and points. 

e.g, for a line entity the cutted voxels will be obtained as hexahedral elements.

The voxel size is set by the general mesh size (equal for X, Y and Z directions)

After generate this kind of mesh, there are available some read only variables, to know some 

information:

Cartesian(NGridPoints) : return the number of points of the grid on each direction x, y, z
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Cartesian(BoxSize) : dimensions of the box of the cartesian mesh bounding the model

Cartesian(Corner) : location of the left-down corner of the cartesian box

This GiD level variables can be asked with the Tcl command GiD_Set

There are other preference variables that could be set to handle the 

Cartesian(FromRenderMesh): value 1 to set that the cartesian mesh is obtained fastly from the render 

mesh

Cartesian(CondFaceElem) : to set where to transfer the conditions defined over face elements. value 0 

to transfer to body elements or 1 to tranfer to face elements

11.5 Boundary layer

Menu: Mesh->Boundary layer

A boundary layer mesh is one mesh attached to the boundary, and which has a certain distribution of 

nodes separated from the boundray following a certain stretching function. The streching function and 

the grow factor of the boundary layer meshes of a model can be set in Preferences->Meshing -pag. 92-.

User can define two main properties to the boundary layer meshes of each geometrical entity: First layer 

height and Number of layers. When selecting the entities which will have boundary layer mesh a window 

shows a schematic picture, where user can see the distribution of heights of each layer, and the total 

height of the boundary layer mesh when the assigned properties are set.

Only tetrahedra or triangle elements are generated in the boundary layer mesh, and there is no 

transition elements for conecting tetras to other kind of elements in the 'isotropic' mesh, so the mesh of 

the volume or surface which has a boundary layer mesh must be of tetrahedra or triangle.

Boundary layer mesh can only be generated with linear elements (not quadratic ones).
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Boundary layer mesh window

11.6 Element type

Menu: Mesh->Element type

With this command, the type of element you wish to use is selected. It is only necessary to do this when 

the element type is different from the default (see MESH -pag. 133-).

The types are as follows:

Default:  For surfaces and volumes. This option lets GiD assign a compatible element type to 

geometric entities, assigning the default ones if possible (see MESH -pag. 133-).

Linear: For lines.

Triangle and Quadrilateral: For surfaces.

Tetrahedron, Prism and Hexahedron: For volumes.

Point: Just for volumes. One node elements are generated.

Sphere: Just for volumes. One node elements with radius are generated

Circle:  Just for planar shape surfaces. One node elements with radius and the circle normal are 

generated

Linear and Quadrilateral: For contact surfaces.

Linear, Prism and Hexahedron: For contact volumes.

Quad dominant meshes can also be generated (which have both quadrilateral and triangle element type 

in the same surface). To generate this meshes, quadrilateral element type sholud be set to the 
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geometrical entity, and the optoin 'Allow quadrilateral dominant meshes' in Meshing -pag. 92-

 preferences should be checked.

By default, the elements are of minimum order: 3-noded triangle, 4-noded quadrilateral and so on. To 

increase the degree, use the Quadratic command (see Quadratic). Quadratic applies to all the elements 

of a problem.

Point, Sphere: 1 node.

Point connectivity:

Linear: 2 or 3 nodes.

Line connectivities:

Triangle: 3 or 6 nodes.

Triangle connectivities:

Quadrilateral: 4, 8 or 9 nodes.

Quadrilateral 

connectivities:

Tetrahedra: 4 or 10 nodes.

Tetrahedron connectivities:

Hexahedra: 8, 20 or 27 nodes.
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Hexahedron 

connectivities:

Prism: 6 , 15 or 18 nodes.

Prism connectivities:

 Pyramid: 5 or 13 nod

Pyramid connectivities:

The Linear option assures not only the meshing of lines, but also the creation of 2-node contact lines 

between surfaces or volumes if desired.

At contact surfaces, GiD elements are:

Linear: 2 or 3 nodes.

Triangle: 3 or 6 nodes.

Quadrilateral: 4, 8 or 9 nodes.

At contact volumes (and separated contacts), elements are:

Linear: 2 or 3 nodes.

Prism: 6 or 15 nodes.

Hexahedron: 8, 20 or 27 nodes.

To see how to get information from GiD concerning element faces see Multiple values return 

commands.

To decide which parts of the geometry should be meshed, use the Mesh criteria command (see Mesh 

criteria -pag. 140-).
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11.7 Mesh criteria

Menu: Mesh->Mesh criteria

GiD provides five different criteria to generate the mesh. The Default option skips meshing the 

boundaries, that is, lines for surface meshes and surfaces for volume meshes.

The Mesh option lets you choose the entities to be meshed, while the No Mesh option does the 

opposite.

The Skip option forces GiD to skip a geometrical entity when meshing (so the entity will not have mesh), 

while the No Skip option forces GiD not to skip the geometrical entity (so the entity will have mesh) 

when the RJUMP surface mesher is used (see Preferences -pag. 87--> Meshing).

The Automatic skip option lets GiD decide if the geometrical entity should be skipped or not skipped 

when the RJUMP surface mesher is used. This decision is taken according to the tangency between 

entities: those entities that are tangent enough will be skipped when meshing.

Using the Skip by... option user can apply some of the usefull following criteria to select the entities to be 

skipped, not to be skipped or to be skipped automatically.

Tangency limit angle: This criteria select the lines between surfaces in which angles between normals 

in the surfaces are lower than the value.

Take care layers: If this is set, lines between surfaces which are in different layers won't be selected.

Take care curvatures: This ratio means the diference between curvatures in the surfaces that share a 

line. If the ratio between the curvatures exceeds this value, the shared line is not considered to be 

selected. As an example, if this value is 0.1 (10%), the only lines which will be selected will be the 

ones in which the two surfaces that share the line have almost the same curvature (only a 10% of 

difference is accepted ). As this number increases, probably more lines will be selected. 

Lines of surfaces smaller than: All the lines of surfaces which have some line smaller than this value 

will be selected.

Window to assign skip criteria to lines.
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By clicking Select by criteria all the selected criteria are used to select the lines. 

Modify selection allows the user to modify manually the selection made.

 When Apply is clicked the marked option (Skip, No skip or Automatic skip) is aplied to the selected 

lines.

The Force points to option forces the selected points to belong to the surface or volume mesh, even 

though they do not necessarily belong to the surface or the volume.

Use the Duplicate option when you want to create a discontinuity in the mesh in a particular place by 

duplicating nodes. This is interesting, for example, when dealing with very thin shapes where it is difficult 

to represent the domain with two overlapped surfaces, and it is easier to have a single surface marked 

with this meshing option (like sails embedded in a volume, material cracks, etc.).

Marked lines and the deformated mesh after an structural analysis

It is possible to mark lines embedded in a 2D domain, or surfaces in the case of 3D domains.

11.8 Reset mesh data

Menu: Mesh->Reset mesh data

This command resets all the sizes assigned to entities. This means that all of them will be unassigned.

To unassign only certain entities, assign the size 0.0 (see Unstructured -pag. 133-) to the entities where 

the default size is required.

The information about element types, mesh criteria and quadratic parameters is also reset.

11.9 Draw

Menu: Mesh->Draw

This option is used to draw meshing properties in geometrical entities.

11.9.1 Sizes

Menu: Mesh->Draw->Sizes

When sizes are assigned to points, lines, surfaces or volumes using the Assign Unstruct sizes option, 

it is possible to draw the different assigned sizes in different colors.
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EXAMPLE

In the following example some different sizes are assigned to surfaces. Sizes of 3, 5 and 6 are assigned 

depending on the surface.

After choosing the Draw Sizes option (over surfaces) we get the following result:

11.9.2 Num of divisions

Menu: Mesh->Draw->Num of divisions

With this option you can see the number of divisions assigned to the structured lines of the model (see 

Structured -pag. 136-).

11.9.3 Element Type

Menu: Mesh->Draw->Element type

With this option you can see which element types have been assigned to each geometric entity. If no 

element type has been assigned, it is shown as Default (see MESH -pag. 133-).

11.9.4 Mesh / No mesh

Menu: Mesh->Draw->Mesh / No mesh

With this option you can see the entities that GiD has either been forced to mesh or forced not to mesh 

(see Mesh criteria -pag. 146-). If the meshing criteria have not been assigned to an entity, it is shown as 

Default (see MESH -pag. 133-).
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11.9.5 Structured Type

Menu: Mesh->Draw->Structured type

With this option you can see what kind of mesh will be generated for geometrical entities, i.e. 

Unstructured, Structured or Semi-Structured. If no level of structure has been assigned, it is shown as 

Default (see MESH -pag. 133-).

11.9.6 Skip entities (Rjump)

Menu: Mesh->Draw->Skip entities (Rjump)

With this option you can see which lines and points will be skipped when meshing using the meshing 

preferences set at that moment (see Preferences -pag. 87- -> Meshing), and the lines and points set as 

Skip or NoSkip mesh criteria (see Mesh criteria -pag. 146-).

11.9.7 Duplicate

Menu: Mesh->Draw->Duplicate

With this option you can see the entities that have been assigned duplicate mesh (Mesh criteria -pag. 

146-).

11.9.8 Force points to

Menu: Mesh->Draw->Force point to

With this option you can see the number of points forced to be in the mesh of a surface or volume (Mesh 

criteria -pag. 146-).

11.9.9 Boundary layer

Menu: Mesh->Draw->Boundary layer

With this option you can see the first layer height of the boundary layers set in the model. In '2 

dimensional' option the lines from wich the boundary layer will grow are shown, and in '3 dimensional' 

the surfaces.

In cases where two boundary layer meshes grows from the same geometrical entity (one for each side), 

the minimum value of the first layer heigt is shown.

11.10 Generate mesh

Menu: Mesh->Generate mesh...

When everything is ready for mesh generation, select this command. If there is a previously generated 

mesh, GiD asks if this should be erased. It will be lost from the memory, but will remain on the disk until 

the project is next saved (see Save -pag. 32-).

The mesher or mesher combination can be chosen in preferences (see Preferences -pag. 87-).

Next, GiD asks for a general element size which will be applied to all lines, surfaces and volumes that 

do not have one previously defined (see Unstructured -pag. 133-). GiD offers two default possibilities:
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One default size automatically calculated by the program to define a coarse mesh.

The last size given by the user in a previous meshing.

You can choose one of these or enter a new one.

The size is given by the average side of the corresponding triangle or quadrilateral.

During meshing a progress bar indicates the number of generated surfaces or volumes in relation to the 

total number of surfaces or volumes.

Meshing can be stopped at any time by clicking the Stop button. Sometimes it is necessary to press the 

button repeatedly or keep it pressed for a few seconds.

11.11 Erase mesh

Menu: Mesh->Erase mesh...

If the model has a mesh this option erases it.

11.12 Edit mesh

Menu: Mesh->Edit mesh

This option lets you modify a mesh. All modifications will be lost when the mesh is generated again.

11.12.1 Move node

Menu: Mesh->Edit mesh->Move node

By using this command, an existing node is selected and moved. The new position is entered in the 

usual way (see Point definition -pag. 23-).

11.12.2 Split Elements

Menu: Mesh->Edit mesh->Split elements

To split elements, select them in the usual way (see Entity selection -pag. 27-), and then press escape 

(see Escape -pag. 29-) to perform the action. Triangles can be split into triangles, quadrilaterals into two 

or four triangles, tetrahedra into tetrahedra, hexahedra into tetrahedra, and prisms into tetrahedra.

When splitting triangles, the new nodes can be located in the mid-edge or with an enhanced 

interpolation (modified Butterfly scheme) in order to obtain a smooth mesh.

When splitting quadrilaterals, if 'SymmetricalStructuredTriangles' is set (see Preferences 

-pag. 87- -> Meshing), then four triangles are generated for each quadrilateral; otherwise only two 

triangles are created per element.

When splitting hexahedra, if 'SymmetricalStructuredTetrahedra' is set (see Preferences -pag. 

87- -> Meshing) , then 24 tetrahedra are generated for each hexahedron; otherwise six tetrahedra are 

created per element.
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If original elements are quadratic, the triangles or tetrahedra obtained are quadratic. Otherwise, if 

original elements are linear, the triangles or tetrahedra obtained are linear.

In the case of quadratic quadrilaterals, extra nodes are generated. These nodes are not associated with 

geometric entities, they have simply been obtained by interpolating mesh node coordinates.

In the case of hexahedra or prisms, all selected elements must be of the same quadratic type.

With triangles or tetrahedra, when selecting only a part of the mesh, neighbor elements will be also 

splitted to mantain a conformal mesh. For tetrahedra is not possible to split them if they are connected 

with neighbor elements of another element type (to avoid create non-conformal meshes)

Note: Currently, the operation Split triangles and tetrahedra only works for linear elements.

11.12.3 Smooth Elements

Menu: Mesh->Edit mesh->Smooth elements

To smooth elements, select them in the usual way (see Entity selection -pag. 27-), and then press 

escape (see Escape -pag. 29-) to perform the action.

Currently only triangles, tetrahedra and hexahedra can be smoothed.

In the case of tetrahedra and hexahedra, element connectivity is conserved after the smoothing; 

however, with triangle elements this may be modified during the smoothing process.

All selected elements must be of the same quadratic type.

11.12.4 Collapse

Menu: Mesh->Edit mesh->Collapse

The Collapse function converts coincident entities, i.e. entities that are close each other, into one.

It is possible to collapse edges, nodes, elements or the whole mesh.

Collapse mesh collapses all the nodes of the mesh.

Collapse edges joins nodes that are connected by edges shorter than the Import Tolerance value.

Collapse nodes  asks you to select some nodes. Nodes closer together than the Import Tolerance 

value are collapsed.

Collapse elements asks you to select some elements. Then, the nodes of these elements that are 

closer together than the Import Tolerance value are collapsed.

Note: Entities belonging to a frozen layer (see Layers -pag. 101-) are not checked when collapsing.

11.12.5 Delete nodes/elements

Menu:  Mesh->Edit mesh->Delete 

To delete elements or nodes, select them in the usual way (see Entity selection -pag. 27- ), and then 

press escape (see Escape -pag. 29- ) to perform the action. 

Nodes that no longer belong to any element after the operation are also erased.
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Note:   It is possible to filter the selection, e.g. to select only triangles but not quadrilaterals (see 

Selection window -pag. 110- ). 

Note:  Only lonely nodes (nodes of the mesh that do not belong to any element) can be deleted. 

11.13 Show errors

Menu: Mesh->Show errors...

This option opens the mesh errors window. This window presents a list of the entities that GiD could not 

mesh, and some information about the problems that occurred during the meshing process. By 

right-clicking over an item in the list, advice will be displayed about how to solve the meshing problems 

for each geometrical entity.

11.14 View mesh boundary

Menu: Mesh->View mesh boundary

This option draws the boundaries of the mesh on the screen.

Boundaries for triangular or quadrilateral meshes are line elements.

Boundaries for tetrahedra or brick meshes are triangles or quadrilaterals. This option can be useful 

when rendering a volume mesh (see Render -pag. 53-).

11.15 Create boundary mesh

Menu: Mesh->Create boundary mesh

This option creates the boundary mesh of the existing mesh.

The boundary mesh for triangular or quadrilateral meshes is a line element mesh.

The boundary mesh for tetrahedra or brick meshes is a triangular or quadrilateral mesh.

11.16 Mesh quality

Menu: Mesh->Mesh quality

This option opens a window that shows information about the quality of the mesh elements.
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Mesh Quality window

There are six criteria used to measure the quality of the elements:

11.16.1 Minimum angle:  The quality criterion is the minimum angle in surface elements and the 

minimum dihedral angle for volume elements. This means that elements with a small angle are 

considered to be of a worse quality than ones with bigger angles.

11.16.2 Maximum angle:  This gives the maximum angle for every element. Elements with bigger 

angles are considered worse. Typically, the Minimum angle  criterion is good for qualifying 

triangles and tetrahedra and the Maximum angle  criterion is good for quadrilaterals and 

hexahedra

11.16.3 Element vol: The quality criterion is the size of elements (distance for lines, area for surfaces 

and volume for volumes). Elements with small "volume" are considered worse.

11.16.4 Minimum edge: The quality criterion is the size of the smaller edge of each element. Elements 

with smaller edges are considered worse.

11.16.5 Maximum edge: The quality criterion is the size of the largest edge of each element. Elements 

with bigger edges are considered worse.

11.16.6 Shape quality: The quality criterion measures the likeness of the element to the reference one 

(an equilateral triangle in the case of triangles, a regular tetrahedron in the case of tetrahedra, a 

square in the case of quadrilaterals and a cube in the case of hexahedra). Its value is 1 for a 

perfect element (the reference one), and it decreases as the element becomes worse. If it 

reaches a negative figure it means that the element has a negative Jacobian at some point. 

The mathematical expression of this quality measure for each type of element is as follows.

 Triangles: The shape quality (q) of triangles is measured as

where Area is the area of the triangle, and l_i (i=1..3) are the lengths of the triangle's edges.
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Tetrahedra: The shape quality (q) of tetrahedra is measured as

where Volume is the volume of the tetrahedron, and l_i (i=1..6) are the lengths of the tetrahedron's 

edges.

Quadrilaterals: The shape quality (q) of quadrilaterals is measured as the quality of the worst quality 

node. The quality of a node (q_n) is given by

where l_1 and l_2 are the lengths of concurrent edges of the node, and Area_n is the area of a fictitious 

parallelogram, made with these two edges.

Hexahedra: The shape quality (q) of hexahedra is measured as the quality of the worst quality node. 

The quality of a node (q_n) is given by

where l_1, l_2, l_3, A_1, A_2, A_3 are the lengths and areas of concurrent edges and faces of the node, 

and Volume_n is the volume of a fictitious parallelepiped, made with these concurrent faces.

11.16.7 Minimum Jacobian: The quality criterion is the value of the minimum Jacobian between the 

Jacobians calculated at each element Gauss point. If there are elements with negative 

Jacobians, problems may be encoutered in some calculation processes.

11.16.8 Radius: This option is only available for sphere and circle elements. It represents the radius of 

the element.

11.16.9 Space Filling: This option is only available for sphere elements. It tries to represent the void 

space around each sphere.

11.16.10 Num neighgours: This option is only available for sphere elements. It represents the number 

of neighbours each sphere has.

There are two visualization modes:

11.16.1 Normal: The graph shows the number of elements that have an angle of a certain size.

11.16.2 Accumulated: The graph shows the number of elements which have an angle of a given size 

or smaller.

In the MeshQuality window, if you double click on a value, the elements below this value are selected in 

red. These selected elements can be sent to a layer using the Send To Layer button in the Mesh Quality 

window.

EXAMPLE
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In this example we are studying the mesh using the minimum angle criterion. We can see that 

1511  elements approximately of our mesh have an angle of less than 43.7  degrees. If we double-click 

on the graphic, the 1511 elements which have an angle smaller than 43.7 degrees will be selected.

11.17 Mesh options from model

This option load the meshing preferences of the model. This preferences can be also loaded 

automatically when loading a model if the general preference 'Get meshing preferences from model' is 

set (General -pag. 88-).
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With this menu, you can initiate and manage the analysis of a problem. hereafter referred to as a 

"process". You will see in the sections that follow that several analyses, or processes, can be run at the 

same time.

12.1 Calculate

Menu: Calculate->Calculate

This option begins the process module. Once it is selected, you can continue working with GiD as usual.

12.2 Calculate remote

Menu: Calculate->Calculate remote

This option begins the process module on a remote machine. Once it is selected, you can continue 

working with GiD as usual.

Note:  ProcServer with the same model problem type must be installed and running on the remote 

machine in order to use this option. (ProcServer is not included with GiD.)

12.3 Cancel process

Menu: Calculate->Cancel process

Selecting a proces that is currently running and clicking this option will halt its execution.

12.4 View process info

Menu: Calculate->Viewprocess info...

Select a process that is currently running and click this option to open a window that shows information 

relating to the process, such as iterations, convergence, etc. Clicking Close will close the window, but 

will not halt the process.

12.5 Calculate window

Menu: Calculate->Calculate window...

Selecting this option opens a window in which a list of all the running processes is shown, along with 

some useful information like name, starting time, etc.
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Process window

The buttons in this window let you control some running process features, such as terminating the 

process (Terminate), starting a remote calculation (Start remote), or setting remote analysis properties 

(Remote...). These remote analysis properties are shown in the next figure.

Window to customize remote calculation options.
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GiD provides a help system based in html format. In the same window you can access the following 

sections: GiD Help, GiD Customization, FAQs, GiD Tutorials and What's New. These contents can also 

be accessed directly from Help Menu. The help window provides three ways of accessing a given topic: 

a) through a table of contents shown as a tree, b) through an indexed list of terms appearing inside the 

help, and c) through a search engine.

GiD help window

From the Help menu you can also register GiD (see Register GiD -pag. 154-) and Problem Types (see 

Register Problem types -pag. 155-).

13.1 Help

Menu: Help->Help

This option gives acces to the GiD Help.

13.2 Customization help

Menu: Help->Customization help

This option gives acces to the Customization part of GiD Help.
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13.3 Tutorials

Menu: Help->Tutorials

This option gives acces to some Tutorials which help the user how to use GiD.

13.4 What is new

Menu: Help->What is new

This option gives acces to a list of the new developements present in each versions of GiD.

13.5 FAQ

Menu: Help->FAQ

This option gives acces to a list of the Frequently Asked Questions (FAQ) related with GiD.

13.6 Register GiD

Menu: Help->Register...

In order to get the most of GiD, you need to register a password that can be obtained from 

http://www.gidhome.com. From this site you can obtain a permanent or temporary password. The 

password must be typed in the window shown below.

GiD register window

If you have previously registered your current copy of GiD (official versions only), the password can be 

reloaded by clicking the  icon and selecting the folder where the old password is.

After registering either a permantent or temporary password you will be able to generate and 

postprocess an unlimited number of nodes and elements.
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13.7 Register Problem types

Menu: Help->Register Problem type...

In the same way that some of GiD's capabilities have restricted access before it is registered, so not all 

problem types are available without registration. The layout of the Register Problem type window is 

shown below:

Problem type register window

If a problem type has been registered previously, the password can be reloaded by clicking and 

selecting the folder where the old password is.

A problem type does not need to be loaded to be registered. In this case, click the Choose a Problem 

type bar and a window similar to the one below will appear where you can choose a set of problem 

types to be registered. If a problem type is currently in use then it is selected by default.
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Choose Problem type window

The "Register from file..." menu, will ask the user for a .pwd text filename, that contain one line for each 

problemtype or GiD to be registered. It's interesting to register several modules, and GiD in a single 

step.

The contents of a passwordfile.pwd can be something like this:

machinename password # yyyy mm dd Password for module 

'RamSeries5.4/ramsolid.gid'

machinename password # yyyy mm dd Password for module 'kratos.gid'

machinename password # GiD 8

instead 'machinename' and 'password', for floating licences the server IP must be provided

13.7.1 Customizing Problem type registration

GiD provides a default validation when registering a module or problem type. This consists of checking 

that the password is not empty. If the password is valid, GiD appends a line to the file <problem 

type>/password.txt similar to this:

hostname password # 2008 01 19 Password for Problem type 

'/pathroot-to-problem-type/problemtype.gid'

This default validation can be overridden, but this involves Tcl programming. For a description of how to 

provide a custom password validation see ValidatePassword node.

13.8 Register from file

Menu: Help->Register from file

Register GiD and all problem types stored in a *.pwd file.
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13.9 Visit GiD web

Menu: Help->Visit GiD web

This command takes you to the GiD homepage (http://www.gidhome.com).

13.10 About

Menu: Help->About...

This command gives information about the program such as the version being run, the system or 

libraries.
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14.1 Introduction

Menu: Files->Postprocess

Toolbar:

Toggle pre/postprocess

This chapter describes some relevant aspects of the postprocessing step and the way to load results 

from a numerical analysis into GiD.

In GiD Postprocess you can study the results obtained from a solver program. GiD receives mesh and 

results information from the solver module, and if the solver module does not create any new mesh, the 

preprocess mesh is used.

The solver and GiD Postprocess communicate through the transfer of files.

The solver program has to write the results in a file that must have the extension .post.res, or the old 

.flavia.res, and its name must be the project name. If the solver writes a mesh, the file must have the 

extension .post.msh, or the old .flavia.msh. ( see POSTPROCESS DATA FILES).

The extensions .msh and .res are also allowed, but only files with the extensions .post.msh and 

.post.res (and the old ones .flavia.msh and .flavia.res) will automatically be read by GiD when 

postprocessing the GiD project.

There are two ways to postprocess inside GiD:

Postprocess inside a GiD project: Start GiD and open the GiD project (ProjectName.gid) you want 

to postprocess, and then select the Postprocess option from the files menu or click on the pre/post 

toolbar button. This way the file ProjectName.post.res, or the old ProjectName.flavia.res, will 

automatically be read by GiD, along with the file ProjectName.post.msh, or ProjectName.flavia.msh, if 

present.
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Postprocess other files: Start GiD and select the Postprocess option directly from the files menu or 

click on the pre/post toolbar button. Now open the pair files OtherModel.msh and OtherModel.res.

A list of the supported elements and results can be found here: Postprocess mesh format: 

ProjectName.post.msh

Once inside the postprocessing component of GiD, all the visualization features and management 

options of the preprocessing section are available: Zoom, Rotate (Rotate screen/object axes, Rotate 

trackball,etc.), Pan, Redraw, Render, Label, Clip Planes, Perspective, etc.

Note: There is no need to load a project into GiD to use its postprocessing facility; you can open mesh 

and results information directly from GiD Postprocess ( see Files menu -pag. 160-).

14.2 Files menu

Menu:  Files 

Several useful options can be found in the Files menu.

New : Clears all postprocess information present in GiD. 

Open : Reads postprocess information in GiD. If, for instance, the postprocess files are 'PostFile.msh' 

and 'PostFile.res' and a view file is present with the name 'PostFile.vv' then it will be also read. 

Open multiple : With this option you can load multiple meshes (pairs of .msh and .res, or .bin files) 

into GiD. This is useful, for instance, when performing an analysis where some or all steps require 

re-meshing. 

From the file browser window, you can select several pairs Project.post.msh and Project.post.res, in one 

go by left-clicking one file and then <Shift>-left-clicking another so that all the files in between are 

highlighted; further files can be added or removed individually with <Ctrl>-left-click. Normal operations, 

such as animation, displaying results and cuts, can be done over these meshes, and they will be 

actualized when the selected analysis/step is changed, for example by means of View results -> Default 

analysis/step (see Re-meshing and adaptivity ). 

Merge : Reads mesh and results information from an ASCII or a binary file and adds them to the 

current ones. If nodes are already present inside GiD, they will be overwritten. No renumeration is 

done. 

Import : 

 NASTRAN mesh: Reads a NASTRAN mesh file.

 FEMAP: Reads FEMAP Neutral ASCII files and binary files.

 TECPLOT ASCII: Reads TECPLOT 9.0 ASCII files.

 3DStudio file: Reads a mesh in .3ds 3DStudio format.

 XYZ points: Reads a set of points. Is an ASCII format. Has options to adapt the process of 

importation to differents ASCII files.

 Cuts: Reads cut planes, cut wires and iso-surface cuts in GiD so that the same cuts and 

cut-spheres can be used among several postprocess meshes.

 Graphs: Adds graphs to those that may or may not have already been created inside GiD. 

Export : 

 Post information

 ASCII files: saves meshes, sets and results to ASCII files using the new PostProcess 
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format (see Postprocess results format: ProjectName.post.res , Postprocess mesh 

format: ProjectName.post.msh ). If multiple meshes are read with the 'Open multiple' 

option explained above, only two files will be saved, one for the meshes and another 

one for the results, where each post information file (or pair .msh + .res) will define a 

Group (see Re-meshing and adaptivity ). 

 Binary (whole model): Saves meshes, sets and results to one binary file. If multiple 

meshes are read with the 'Open multiple' option explained above, only two files will be 

saved, one for the meshes and another one for the results, where each post information 

file (or pair .msh + .res) will define a Group (see Re-meshing and adaptivity ). 

 Binary (only results): Saves results information only, so the transition between Pre- and 

Postprocess will be quicker.

 ASCII boundaries: Saves the boundaries of the meshes and sets, with its nodal results, 

to ASCII files (one for mesh information ".msh", one for the results ".res"). The boundary 

of a hexahedron/tetrahedron mesh is a quadrilateral/triangle mesh. The boundary of a 

quadrilateral/triangle mesh is a line mesh. There is no boundary of a line/point mesh.

 Cut: Saves cut planes, cut wires and iso-surface mesh cuts so that the same cuts can be 

used among several postprocess meshes. Cut spheres can also be saved.

 Graph: Saves graphs in ASCII (gnuplot) format. If the option All is chosen, you will be asked 

for a prefix. GiD will then create a file for each graph with the names prefix -1.cur  , 

prefix-2.cur , prefix-3.cur  and so on... 

 Cover Mesh: After visualizing the cover mesh of the points/nodes, this mesh can be saved for 

other uses.

 Visible surfaces to STL: exports the displayed triangular and quadrilateral surfaces in ascii or 

binary STL format with this window:

Only the displayed meshes are written in the STL file. If the displayed meshes are deformed, 

then the meshes in the STL file are also deformed.

STL export windows with ascii or binary format.

Preprocess : Selecting this option will open an 'Are you sure?' dialog box. Clicking 'Yes' will return 

you to the preprocessing component of GiD. 
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Recent Post Files:  a list of the most recents files read in PostProcess is shown, so the user can 

selecet them quickier. The number of files can be adjusted here General -pag. 88- . 

Recent Projects:  a list of the most recent GiD projects are shown. The number of projects can be 

adjusted here General -pag. 88- . 

The rest of the options are the same as when in preprocessing mode.

14.3 Utilities menu

Menu: Utilities

Inside the Utilities menu, the options Id, Signal, Distance and Calculator have the same functionality as 

in preprocessing mode (see UTILITIES -pag. 87-). Other options in the Utilities menu are slightly 

different.

Status: A window appears showing the general postprocess status: number of meshes, elements, etc.

Status window

List:

Nodes: A window appears showing information about selected nodes: coordinates, which 

elements uses this node, the current visualized result, and all other nodal results defined over 

the selected nodes. 
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Elements: A window appears showing information about selected elements: connectivity, the 

gauss points defined on the selected elements, the current visualized result, and all other 

results defined over the gauss points of the selected elements. For spheres, their raius are 

also shown, and for circles, their radius and nomral.

All this information can be sent to the active report (see Report -pag. 113-) by using the button.

Collapse: Collapses nodes that are together in a set.

Join: Joins several sets into one.

Delete: Deletes meshes, sets and cuts.

Texture: Adds textures to sets (see Textures -pag. 170-).

The Copy tool introduces some changes:

Menu: Utilities->Copy...

Toolbar:
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Copy/Transform

When you select the Copy tool, the Transformations window appears. This window allows you to repeat 

the visualization using translation, rotation and mirror transformations, so that GiD can draw a whole 

model when only a part of it was analyzed.

Transformation: create option

The types of transformation are:

Translation: This is defined by two points. Relative movements can be obtained by defining the first 

point as 0,0,0 and considering the second point as the translation vector (see Point definition -pag. 

23-).

Rotation: It is necessary to enter two points in 3D or one point in 2D. In 3D, these two points define 

the rotation axis and its orientation. In 2D, the axis goes from the defined point towards z positive. 

Enter the angle of rotation in degrees. It can be positive or negative. In 3D, the direction is defined by 
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the right hand rule. In 2D, it is counter-clockwise.

Mirror: This is defined by three points that cannot be in a line. These points form a plane that is the 

mirror plane. In 2D, the mirror line is defined by two points.

The other available options are:

Copies: By entering the number of repetitions, the operation selected is performed this number of 

times.

View:  The transformation is only for viewing purposes. Show/Hide, Undo and Clear options are 

enabled.

Show/Hide Transform.:  Allows you to see either the original model or the one with the 

transformations active.

Undo:  Deletes the last transformation performed. It can be used repeadly to clear all 

transformations.

Clear: Clears all the transformations in one go. 

Create:  All the Post information (meshes & results) will be duplicated when performing the 

transformation. 

Crete volume/surfce: creates N-copies of the current meshes.

Extrude surface: creates a volume using the selected transformation by extruding the 

surfaces.

The DoIt button tells the program to perform the transformation that has been selected.

14.4 Do Cuts

Menu: Do cuts

Here you can cut and divide volumes, surfaces and cuts. A cut of a volume mesh results in a cut plane. 

The cut is done for all the meshes, even those that are switched Off. When cutting surfaces, a line set 

will be created. Here only those surfaces that are switched On are cut.

Another feature is that a cut can be deformed, if meshes are also told to do so (see Deform Mesh -pag. 

188-). A cut of a deformed mesh, when changing to the original shape, will be deformed accordingly.

When dividing volumes/surfaces, only those elements of the volumes/surfaces that are switched On and 

which lie on one side of a specified plane will be used to create another volume/surface.

Several dividing options can be found by right clicking on the graphical screen when the options 'cut' or 

'divide' are selected.

Cutting spheres will result in a mesh of circles.

Cut Plane:  Specify a plane which cuts the volumes/surfaces. Several options can be used to enter 

this plane. 

2 Points: the plane is defined by two points and the visual direction orthogonal to the screen. 

3 Points: the plane is defined by three points. When choosing the points, the nodes of the 

mesh can also be used. 

Succession:  This option is an enhancement of Cut Plane. Here you specify an axis that will 

be used to create cut planes orthogonal to this axis. The number of planes is also asked for.
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Divide by selection: To send the selected elements to an old or new set.

Divide Volume Sets:  Specify a plane which is used to divide the meshes. Several options can be 

used to enter this plane. With Two Points (the default), the plane is defined by the corresponding line 

and the direction orthogonal the screen. With Three Points, the plane is defined by three points. 

When choosing the points, the nodes of the mesh can also be used. After defining the plane, you 

should choose which section of the mesh should be saved by selecting the side of the plane to use. 

Only those elements that lie entirely on this side are selected. Only those volume meshes that are 

shown are divided.

Divide Surface Sets: Specify a plane which is used to divide the sets. Several options can be used 

to enter this plane. With Two Points (the default), the plane is defined by the corresponding line and 

the direction orthogonal to the screen. With Three Points, the plane is defined by three points. When 

choosing the points, the nodes of the mesh can also be used. After defining the plane, you should 

choose which section of the mesh should be saved by selecting the side of the plane to use. Only 

those elements that lie entirely on this side are selected. Only those surface meshes that are shown 

are divided. When doing a division, there are several useful options inside the Contextual  mouse 

menu (right-click in the graphical window):

exact: to do an exact division, i.e. elements are cut to create the division;

parallel planes: the remaining elements will be the ones between two parallel planes. A 

distance can also be entered, after choosing this option from the Contextual menu.

Divide lines: Specify a plane which is used to get the lines on one side of this plane

Cut Wire: Here you can define a 'wire' tied to the edges of the elements of the volumes/surfaces. So 

when the volumes/surfaces are deformed, the wire is deformed too. And vice versa, if a wire is 

defined while the volumes/surfaces are deformed, when turning them into its original shape, the 

cut-wire is "undeformed" with them.

Cut Spheres:  Here you can define a sphere which will be used to cut the volume and surface 

meshes, resulting in triangle or line cut meshes respectively.

Convert cuts to surface sets: With this options cuts can be converted to surface sets so they can be 

saved, or cut again.

Automatically convert cut to set: It this options is selected, cuts are automatically converted to sets 

(some operations are available for sets but not for cuts)

Cuts can also be read from and written to a file. The information stored to the file from a 'Cut Plane' is 

the plane equation that defines the plane ( Ax + By + Cz + D = 0), so it can be used with several 

models. The information stored in the file from a 'Cut Wire' is the points list of the cut-wire, i.e. the 

intersection between the wire and the edges of the meshes/sets. These files are standard ASCII files. A 

line of a 'Cut Plane' archive contains the four coefficients of the plane that defines the cut, separated by 

spaces. A line of a 'Cut Wire' archive contains the three coordinates of a point of the wire. Comment 

lines are allowed and should begin with a '#'.

An example of a 'Cut Plane' file where three planes were written:

         # planes created from a 'cut succession'

         -10.82439 0.5740206 0 51.62557

         -10.82439 0.5740206 0 12.45994

         -10.82439 0.5740206 0 -26.70569
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An example of a 'Cut Wire' file:

        -2.444425 3.883427 2.487002

         2.130787 2.762815 3.885021

         0.8411534 4.458836 3.215301

         4.270067 3.795048 2.037187

         5.66561 3.414776 0.8219391

         2.945865 3.600701 3.29012

         0.4487007 3.764661 3.574121

14.5 Point and Line options

As points and lines can be viewed, there are several interesting options for each of them.

Menu: Options->Geometry->Point options...

Point options:

Point options window

Here you can select whether to draw the points Quick, Nice or with the center of a Texture glued to the 

point. Quick: points will be drawn as big dots. Nice: points will be drawn as little spheres (quadrilateral 

meshes). For every draw style, the Point Size can be changed, but ranges vary between Quick, which 

depends on the graphics library, and Nice and Texture. When the Nice style is selected, the Nice detail 

level can be adjusted. The number represents the number of vertical and horizontal subdivisions of a 

sphere.

Note: The changes affect the representation of all the points - point elements and the arrow heads of 

vectors when using the Point detail level (see Display vectors -pag. 179-).

Menu: Options->Geometry->Line options...

Line options:
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Line options window

Here you can select whether to draw the lines with a Quick style or a Nice one. Selecting a Line Size of 

0.0 in the Nice style, will cause the lines not to be drawn. Quick: lines are drawn as 3-point thick lines. 

The line size is fixed. Nice: lines are drawn as long 4-sided or 8-sided prisms. The size and width of the 

lines can be changed. When the lines are drawn nicely, the number of sides of the prism used to draw 

them can be changed between 4 and 8 sides.

Note: Line options no longer affect the stream lines as before, but only the line elements. For stream 

lines options see Stream Lines -pag. 182-.

14.6 Display Style

Menu:  Window->View style... 

Below in an example of the View Style window, where almost all the interesting visualization options can 

be adjusted. It only deals with meshes, sets or cuts, and not with results.

View Style window

Selecting Volumes, Surfaces and/or Cuts, you can switch them On and Off, Delete them or rename 

them. By clicking on a Volume, Surface or Cut, and pressing Color... you can adjust the appearance of 

the selected set; you can change the color, including the Ambient, Diffuse, Specular, Shininess and 

transparency components, and return it to its Default color. The Diffuse component is used for all the 
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representations, while the others (Ambient, Specular and Shininess) have more effect in Render 

visualizations.

Also separate styles can be selected for each mesh independently, just by clicking on the icon in the 

column eith the header 'St '. 

Other interesting options which can be set for each individual mesh are:

I/O:  switch the mesh on and off 

Tr:  enable or disable the transparent mode for the mesh 

Int:  draw or not the interior elements of the mesh 

Ew: sets the  Edge width of the mesh. 

In the Style   menu you can choose how volumes, surfaces and cuts should be drawn. These options 

are: 

Boundaries:   All the edges of the boundaries and surface elements will be displayed in black. An 

edge is the line that belongs to just one surface element, or that belongs to two surface elements as 

long as the faces form an angle smaller than has been predefined (you can specify this angle in 

Results Options BorderAngle in the Right buttons menu). 

Hidden Boundaries:  The same as before, but here the edges that are behind the volumes, surfaces 

and cuts are removed. 

All Lines:  All the lines of surface elements are drawn. When drawing volumes, GiD only draws the 

surface/boundary elements of this volume mesh. How GiD can draw these interior elements is 

explained below. Each volume, surface and cut is drawn with its own colors. 

Hidden Lines:   The same as before, but here the lines that are behind the volumes, surfaces and 

cuts are removed. 

Body:  The elements of volumes, surfaces and cuts, are drawn in filled mode, i.e. they are drawn as 

solid elements. Each volume, surface and cut is drawn with its own colors. It can be very hard to 

recognize the shape of the meshes if no illumination is active. 

Body Boundaries:  Same as before, but with Hidden Boundaries drawn too. 

Body Lines:  Same as before, but with Hidden Lines drawn too. 

Points:  The nodes of the meshes are drawn. 

Any:  different styles has been set for each mesh. 

With the Render  menu you can select how the mesh should be displayed: 

Normal - no lighting;

Flat - lighting with sharpened edges;

Smooth - lighting with smoothed edges.

The light direction can also be changed by clicking on the lamp  icon. 

Near the Culling label, you can choose whether the Front Faces or Back Faces are culled, i.e. not 

drawn, or No Faces are culled. This option is useful for looking at volume meshes, etc.

Both geometry and mesh conditions can also be drawn if they are present in preprocess.

The following two options can be changed separately for each mesh/set/cut:

Massive lets you see the elements that are inside a volume mesh, and draw all the vectors inside a 
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volume/surface/cut when a Boundaries display style is used.

Transparent determines whether the volumes/surfaces/cuts will be drawn as transparent or opaque, so 

that, for instance, isosurfaces inside them can be viewed easily.

14.7 Textures

Menu: Utilities->Texture

In GiD it is also possible to assign a texture to a Set. Inside the Utilities -> Texture menu there are 

several options:

View No / Fast / Nice: switches between viewing the textures over the sets or not. 

When the texture is small and a pixel of the textures must be drawn over several pixels on the screen, 

the Fast mode just draws the pixels using the 'nearest neighbor' policy, while the Nice mode tries to 

interpolate the colours of the pixels from the original.

Add Screen Map / To 4 Sided / BoundImg to BoundSet: maps a texture to a set. 

ScreenMap: by picking four points over the screen, GiD projects the texture parallel to the 

screen, over the underlying sets. 

4 sided: GiD tries to match the 4 sides of the texture to the 4 sides of the set. The best results 

are achieved using quadrilateral sets which are more or less flat, at least in one direction. 

BoundImg to BoundSet: GiD looks for the border of the texture inside the image file and tries 

to glue it to the border of the set, for instance a texture circle to a circle set.

Change Flip Horiz. / Vert.: changes the orientation of the texture once it is applied to the Set.

Note:  When the display style of the visualization is changed, for instance from Body to Body 

Boundaries, the visualization of the texture is switched off. To view the texture, just select Utilities -> 

Texture -> View -> Fast/Nice.

Once the texture is applied to a Set, any deformed of the Set leads to a corresponding deformation of 

the texture. In this way the deformed texture can be visualized.

14.8 Cover mesh

Menu: Options->Geometry->Covering mesh

Another feature in GiD is the calculation of the involving mesh of a set of points or nodes. To switch the 

visualization of this mesh on and off just select Options -> Geometry -> Covering mesh. After saying 

'Yes' to the visualization of the covering mesh, you will be asked for a number. This number is the 

distance between the covering mesh and the points.

This option is not only available for points, but also for every mesh/set present in GiD.

Note:  This covering mesh is recalculated when the mesh is deformed. So in a particle movement 

system the covering mesh will also move along with the particles.

This mesh can also be saved through Files -> Export -> Cover mesh.
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14.9 Other options

Under the Utilities menu there are other interesting options for postprocess:

Collapse nodes: colapses all the nodes of the model

Join Volume/Surface meshes:  creates a single volume/surface mesh with all the shown 

volumes/surfaces.

14.10 PGF fonts

In postprocess a new fonts management system has been implemented. Now GiD uses directly True 

Type Fonts (R) to draw text inside the postprocess graphical windows.

This allows to draw the characters with smoothed edges.

The user can select the fonts for the diferent text objects with the Fonts  panel in the preferences 

window, when the postprocess mode is active. 

From this panel, the edge drawing mode of the leters can also be set between ' Smooth edges' and 

'Sharp edges'.

Fonts panel of the preferences window

Normal font: used to draw normal text in the GUI environment (TclTk).

Fixed fonts: used to draw fixed spaced text in the GUI environment (TclTk).

Big font: used to draw big text, like warnings and title, in the GUI environment (TclTk).

Graphical fonts: used to draw text in the graphical windows (OpenGL):

Default font: used to draw the text if it is not one of the below ones.

Axis font: used to draw the axis letter

Legend font: used to draw the legend and comments

Label font: used to draw the nodal, elemental, results o minimum and maximum labels

Asian font: used to draw the text when special charactes are detected, which requires special 
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utf-8 codes

TkDrawOGL font: used to draw the text provided by the drawopengl TCL command (Special 

functions).

Render mode: allows to enable or disable the smooth edge drawing.

The True Type Fonts used in GiD are the free ones provided with GiD and the ones provided by the 

system: %WINDIR%\fonts in Microsoft Windows, and several directories in Linux (remember to install 

the true type fonts, or free type fonts from your favorite package administrator).
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The kinds of results that will be displayed on screen can be grouped into five major categories:

Scalar view results: Show Minimum & Maximum, Contour Fill, Contour Text Ranges, Contour Lines, 

Iso Surface and its configuration options.

Vector view results: Mesh deformation, Display Vectors, Stream Lines (Particle Tracing)

Line diagrams: Scalar line diagram and vector diagrams.

Graph lines: XY plots.

Animation: Animation of the current result visualization.

The View Results  menu and window are used to manage the visualization of the different type of 

results.

Menu: View results

The View Results menu lets you select any type of result:

Contour fill

Smooth contour fill

Contour lines

Contour ranges

Show min/max

Display vectors

Iso surfaces

Stream lines

Graphs

Result surface

Deformation

Line diagrams

Integrate

Menu: Window->View results

The View Results window manages the visualization of the following type of results:

Contour fill

smooth contour fill

Contour ranges (if Result Range Tables are present)

Contour lines

Display vectors

Show min/max

Scalar and Vector line diagram (if Linear elements are present)

Result surface
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View Results window

As the results are grouped into steps and analyses, GiD must know which analysis and step is currently 

selected for displaying results. The Analysis menu of the View Results  window is used to select the 

current analysis and step to be used for the rest of the results options. If some of the results view 

requires another analysis or step, you will be asked for it.

Note: If you no longer wish to view results, you can select No Result in this window or in the View 

results menu.

15.1 View Results Bar

View Results Bar

This bar allow the user a quick access to the results visualization modes:
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No result: cleans all the results visualizations (contour fill, deformation, vectors, etc. 

except the graphs), leaving the mesh alone.

Togle mesh and graphs view: switches between the graphs visualization and the results 

visualization mode.

Default analysis/step: allows the set the default analysis and step. Used to create the 

menus with the result's names of the results present on the selected step and analysis.

Contour Fill: draws a Contour Fill of the selected result.

Contour Lines: draws the Contour Lines of the selected result.

Show min max: shows the maximum and minimum value of the selected result.

Display vectors: draws a vectors of the selected result. This includes vectors, stresses 

and local axes.

Iso surfaces: draws the isosurfaces of the selected result. The user can select the 

number of isosurfaces and the exact value for each of them.

Stream lines: draws stream lines of the selected nodal vector.

Result surface: draws a extruded surface acording to the selected result. If the result 

selected is a vector, uses the vector as extrude direction. If the result selected is a scalar, 

uses the normal of the noded (which is an average of the normals of the surrounding 

elements).

Deformation: deforms the mesh acording to the selected nodal vector.

Point evolution: displays a graph of the evolution of the selected result along all the 

steps, of the default analysis, for the selected nodes.

Line graph: also called 'section graph' displays a graph defined by the line conectig two 

selected nodes of the planar XY surface, or of the volume mesh.

Point graph: displays a graph of one result against another of the selected results. The 

option 'all steps' shows the evolution along all steps inside the default analysis, of this 

result vs. results graph.

Border graph: displays a graph of the results on the selected border, using the x, y, z or 

line distance as abscissa.

Integrated graph: Graph of an integrated result over a mesh.

Clear graphs: delete all the created graphs.

15.2 View results window
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View results window

From this window almost all the visualization options can be selected by the users.

For each individual visualization options, please look at the corresponding chapter.

For the 'Main mesh' and 'reference mesh' panel, please look here: Deform Mesh -pag. 188-.

To get the results grouped in folders like the image, please look at the format of the results here: Result.

15.3 Contour Fill

Menu:  View results->Contour Fill 

This option allows the visualization of colored zones, in which a variable or a component varies between 

two defined values. GiD can use as many colors as permitted by the graphical capabilities of the 

computer. When a high number of colors is used, the variation of these colors looks continuous, but the 

visualization becomes slower unless the Fast-Rotation option is used. A menu of the variables to be 

represented will be shown, and the one that is chosen will be displayed using the default analysis and 

step selected.

Vectors will be unfolded into their X, Y, and Z components and module. Symmetrical matrix values will 

be unfolded into the Sxx component, Syy component, Szz component, Sxy component, Syz component 

and Sxz component of the original matrix and also into the Si component, Sii component and Siii 

component in 3D problems or angular variation in 2D problems. Any of these components can be 

selected to be visualized.

Contour fill is supported for results defined over nodes or gauss points.

When using results defined over gauss points, they are extrapolated to the nodes so that discontinuities 

can appear between adjacent elements. If the gauss points results cannot be extrapolated to the nodes, 

they are drawn as coloured spheres. The radius and detail level of these spheres can be configured as 

well (see Point and Line options -pag. 173- ). 
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Several configuration options can be accessed via the Options  menu. 

Menu:  Options->Contour 

Number Of Colors:  Here the number of colors of the results color ramp can be specified. 

Width Intervals:  Fixes the width of each color zone. For instance, if a width interval of 2 is set, each 

color will represent a zone where the results differ by two units at the most. 

Set Limits:  This option is used to tell the program which contour limits it should use when there are 

no user defined limits: the absolute minimum and maximum of all sets or shown sets, for the actual 

step or for all steps. 

Define limits:   When choosing this option the Contour Limits window appears (this option is also 

available in the Postprocess toolbar). With this window you can set the minimum/maximum value that 

Contour Fill should use. Outliers will be drawn in the color defined in the Out Min Color/Out Max Color 

option. 

Reset Limit Values:  This option resets the values defined in the Define limits option. 

Reset All:  This option sets all Contour Fill options by default. 

Max/Min Options:   Inside this group, several options for the minimum or maximum value can be 

defined: 

ResetValue:   Here you can reset the maximum/minimum value, so that the default value is 

used. 

OutMaxColor / OutMinColor:  With this option you can specify how the outlying values should 

be drawn: Black, White, Max/Min Color, Transparent or Material. 

Def. MaxColor / Def. MinColor:   This option lets you define the color for the minimum or 

maximum value for the color scale to start with. 

Set Value:  this option allows the user to fix a Maximum or Minimum limit for the color scale. 

Color scale:  Specifies the properties of the color scale: 

Standard:  The color scale will be the default: starting from blue (minimum) through green to 

red (maximum). 

Inverse Standard:   The color scale will be the inverse of the default: starting from red 

(minimum) through green to blue (maximum). 

Terrain Map:  A physical map-like color ramp will be used. 

Black White:  Black for Minimum and White for Maximum, and a grey scale between these. 

White Black:  White for Minimum and White for Maximum, and a grey scale between these. 

Scale Ramp:  This option lets you specify how the ramp should change from minimum color to 

the maximum color: Tangent, ArcTangent or Linear. The default is ArcTangent. 

Scale Type:   Tells GiD how the colors between the minimum color and the maximum color 

should change: RGB or HSV. 

Smoothing type:  see Smooth Contour Fill -pag. 178-

Bright color:  enables or disables the shininess of the colours in Contour Fill. The shininess type can 

also be choosed between: metallic, plastic and rubber. 

Color window:  a window opens to let you configure the colour scale of the contours easily 
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Contour Colours window

15.4 Smooth Contour Fill

Menu: View results->Smooth Contour Fill

This option displays a Contour Fill (as explained in the previous section) with a local smoothing of the 

results defined over gauss points.

Smooth Contour fill is supported for results defined over gauss points.

Menu: Options->Contour

With the Smoothing type  option inside the menu Options -> Contour you can choose between these 

types of local smoothing:

Minimum value: The minimum value between two adjacent elements is the result that is used.

Maximum value: The maximum value between two adjacent elements is the result that is used.

Mean value: A mean value of the points between two adjacent elements is the result that is used.

15.5 Contour Lines

Menu: View results->Contour Lines

This display option is quite similar to Contour Fill (see Contour Fill -pag. 182-), but here the isolines of a 

certain nodal variable are drawn. In this case, each color ties several points with the same value of the 

variable chosen.

Here the configuration options are almost the same as the ones for Contour Fill (see Contour Fill -pag. 

182-), with the only difference being that the number given in the Number of Colors option will be used 

as the number of lines for this contour lines representation.

Contour lines are supported for results defined over nodes or gauss points.
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15.6 Contour Ranges

Menu: View results->Contour ranges

This is the same as the Contour Fill visualization type, but the coloured areas are created following a 

'Result range table' specified in the results file (see Result Range Table), and the names of these areas 

are visualized as text labels.

Contour ranges is supported for results defined over nodes or gauss points.

15.7 Show Minimum and Maximum

Menu: View results->Show Min Max

With this option you can see the minimum and maximum of the chosen result.

Show mix max is supported for results defined over nodes or gauss points.

Note: This minimum and maximum can be absolute - for all the meshes/sets/cuts - or relative (local) to 

the ones displayed. This can be selected from the pull-down menu Options -> Contour -> Set Limits.

15.8 Display vectors

Menu:  View results->Display Vectors 

This option displays a menu with results from vectors and matrices (where the principal values have 

been previously evaluated by the program). From the menu of variables, choose the one you wish to 

see displayed; it will be shown with the default analysis and step (this can be changed with the Default 

Analysis/Step option in the menu). Once a result is chosen, the program will display the nodal vectors of 

the chosen result. The vectors that are drawn can be scaled interactively. The factor can be applied 

several times and every time it changes to the new input value.

You can modify the colour of the vectors, which by default are drawn in green, so that all the vectors are 
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drawn in the same colour, or you can let the color of the vectors vary according to the result module.

When drawing a matrix result (3x3 symmetrical), such as the stress tensor, only a single color 

representation of principal values is available: blue when negative (also drawn as >< representing 

compressions), and red when positive (also drawn as <> representing tensions).

A vector will be separated into its X, Y, and Z components and its module. So either the X, Y or Z 

component or the whole vector (represented by the module) can be drawn. Symmetrical matrices will be 

unfolded into: Si component, Sii component, Siii component, and 'All' components. Any of these 

components can be selected to be visualized. Si, Sii and Siii represent the eigen values and vectors of 

the matrix results which are calculated by GiD, and which are ordered according to the eigen value.

Local axes can also be drawn by means of their Euler angles.

Display vectors is supported for results defined over nodes or gauss points.

Several configuration options can be accessed via the Options  menu. 

Menu:  Options->Vectors 

Color Mode:  This option lets you choose if vectors are drawn in one color (Mono Color) or in several 

colors (Color Modules). 

Number of Colors:  If you use Color Modules to draw vectors, it is possible to choose the number of 

colors. 

Offset:  With this option, you control where the vector should be in relation of the node, ranging from 

0, to tie the tail of the arrow to the node, to 1, to tie the tip of the arrow to the node. 

Change Color (mono):   When vectors are drawn in (Mono Color) Color Mode, they are drawn in 

green. You can change this green color selecting this entry. 

Note:  The above four options have no effect when viewing a matrix result or local axes. 

Detail:  The level of detail can be adjusted to draw the vectors quicker or nicer. The different options 

are: 

Point: the arrow head will be drawn as a point. The style used to draw these point like arrow 

heads can be modified through the point options window described before, see Point and Line 

options -pag. 173- . 

Lines: the arrow head will be drawn as four lines.

2 Triangles: the arrow head will be drawn with two intersecting triangles.

4 Triangles: the arrow head will be drawn as cones of four triangles.

8 Triangles: the arrow head will be drawn as cones of eight triangles.

Size:  allows the user to set the size of the vectors to be: 

Fixed sized:  then the factor used when the vectors are displayed is the number of pixels of 

the vector. 

Modulus dependent:   then the factor used when the vectors are displayed is the factor of 

magnification of the vector. 

Note:  This last option affects also matrix and local axes results. 

The displayed amount of vectors can also be limited when there are lots of vectors to be drawn, for 
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instance, when very dense meshes are used. The option allows to drawn only one vector of every N 

vectors. This 'N' can be customized by the user in the right buttons menu , under Results   --> 

Options  --> VectorFilterFactor . 

15.9 Iso surfaces

Menu:  View results->Iso Surfaces 

Here a surface is drawn that ties a fixed value inside a volume mesh; for surface meshes a line is 

drawn. To create isosurfaces there are several options:

Exact:  After choosing a result or a result component of the current analysis and step, you can input 

several fixed values and then for each given value an isosurface is drawn. 

Automatic:  Similarly, after choosing a result or a result component, you are asked for the number of 

isosurfaces to be created. GiD calculates the values between the Minimum and the Maximum (these 

are not included). 

Automatic Width:  After choosing a result or result component, you are asked for a width. This width 

is used to create as many isosurfaces as are needed between the Minimum and Maximum defined 

values (these are included). 

Iso surfaces are supported for results defined over nodes or gauss points.

Iso lines are created for triangles and quadrilaterals when the isosurface visualization is selected.

Several configuration options can be accessed via the Options  menu. These isolines can be switched 

on and off with the command Results --> IsoSurfaces --> DysplayStyle --> ShowIsolines   on the 

right buttons menu . 

Menu:  Options->Iso Surfaces 

Display Style:  For isosurfaces there is also a Display Style option, like for Volumes/Surfaces/Cuts. 

The available options are: All Lines, Hidden Lines, Body, Body Lines (see Display Style -pag. 174- ). 

Transparency:  The isosurfaces can be set to Transparent or Opaque (see Display Style -pag. 174-

 ). 

Color Mode:  allows the user to define the colours used to paint the iso surfaces: 

Monochrome:  all the isosurfaces are drawn with the same colour, which can be adjusted with 

'Change colour'. 

Result colour:   each isosurface is drawn with a colour indicating its value, the 

correspondence of which can be seen in the legend. 

Contour Fill colour:  the isosurfaces are drawn with the colour scale of the current contour fill, 

i.e., the current contour fill is also drawn over the isosurfaces. If no contour fill is displayed, 

then the monochrome colour is used. 

Change colour:  allows to define the dolour of the monochrome isosurfaces 

Convert to cuts:  Another interesting option is Convert To Cuts. With this options all the isosurfaces 

drawn will be turned into cuts, so that they can be saved, read, and have results drawn over them. 

Draw always:  with this option the isosurfaces will be drawn although the mesh is switched off. 

These options also are used for isolines.
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15.10 Stream Lines

Menu:  Vies results->Stream lines 

With this option you can display a stream line, or in fluid dynamics, a particle tracing, in a vector field. 

After choosing a vector result, using the default analysis and step selected, the program asks you for a 

point from which to start plotting the stream line. This point can be given in several ways:

The best way to choose initial points for the stream lines is to cut the mesh through the place where the 

user wants the stream lines, and then select the nodes of this cut.

Clicking on the screen:  The point will be the intersection between the line orthogonal to the screen 

and the plane parallel to the screen and containing the center of rotation. 

Joining a node:  The selected node will be used as a start point. 

Selecting nodes:  Here several nodes can be selected to start with. 

Along a line:   With this option you can define a segment along which several start points will be 

chosen. The number of points will also be asked for, including the ends of the segment. In the case of 

just one start point, this will be the center of the segment. 

In a quad:  Here you can enter four lines that define a quadrilateral area which will be used to create 

a N x M matrix of points. These points will be the start for the stream lines. When giving N x M, N lies 

on the first and third line, and M on the second and fourth. So, points (0, 0..N), (M, 0..N), (0..M, 0) and 

(0..M, N) will lie on the lines. But in case of N=1 or M=1, this will be the center of the line, and if N = 1 

and M = 1, this will be the center of the Quad. 

Intersect set:   The point will be the intersection between the line orthogonal to the screen and the 

current viewed sets nearest the viewpoint. 

When viewing Stream Lines, labels can be drawn to show the times at the start and end points of the 

stream line.

Stream lines can also be deleted and their color changed (green by default).

Stream lines are supported for results defined over nodes.

The following options can be chosen for Stream Lines:

Menu:  Options->Stream Lines 

Change color : allows the definition of the colour of the monochrome stream lines. 

Color Mode:  allows the user to define the colours used to paint the iso surfaces: 

Monochrome:   all the stream lines are drawn with the same colour, which can be adjusted 

with 'Change colour'. 

Stream contour filled:  the colour of the streamlines changes, ala Contour Fill acording to the 

modulus of the vector used to create the dtream line. 

Result contour filled:  the stream lines are drawn with the colour scale of the current contour 

fill, i.e., the current contour fill is also drawn over the stream lines. If no contour fill is displayed, 

then the monochrome colour is used. 

Delete : This option lets you select the stream lines to be deleted. 

Label : This option lets you select the kind of label: 

None:  No labels are drawn. 

0_End:   Labels are drawn according to the following convention: 0 at the start of the stream 
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line, and the total time taken for the particle to travel at the end. 

Ini_End:  Labels are drawn according to the following convention: 0 at the chosen point, with - 

time  before at the beginning of the stream line and + time  after at the end. 

Size, colour & detail : Here you can adjust the size, width and detail of the stream lines, together 

with the colour options, using the Stream line options window: 

Stream line options...

The type of stream can be:

points : showing the points calculated for the stream lines and used to draw them. 

ribbons:  stream ribbons showing the swirl of the velocitys field 

4 sided prisms:  stream 'tubes' with constant width. 

Set initial step : 0 for automatic step 

Set max length : To avoid infinite curves (e.g. in vortex) 

Set max points : To avoid curves with excessive (and memory expensive) number of points 

Set initial rotation : sets the initial rotation of the stream ribbons at the selected nodes. 

15.11 Graphs

Menu: View results->Graphs

From this menu several graphs types can be selected and deleted.

Graphs are supported for results defined over nodes.

Menu

Window --> View graphs...

From this menu the graphs window will pop up from where graphs can be created, customized and 

deleted.
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15.11.1 Graph Lines description

Here you can draw graphs in order to take a closer look at the results. Several graph types are 

available: point evolution against time, result 1 vs. result 2 over points, and result along a boundary line. 

You can also save or read a graph (see Files menu -pag. 166-). The format of the file will be described 

later (see Graph Lines File Format -pag. 185-).

In the View Results -> Graphs pull-down menu, there are the following options:

Clear graphs: delete all the created graphs.

Point evolution:  displays a graph of the evolution of the selected result along all the steps, of the 

default analysis, for the selected nodes.

Point graph:  displays a graph of one result against another of the selected results. The option 'all 

steps' shows the evolution along all steps inside the default analysis, of this result vs. results graph.

Border graph: displays a graph of the results on the selected border, using the x, y, z or line distance 

as abscissa.

Line graph:  also called 'section graph' displays a graph defined by the line conectig two selected 

nodes of surfaces or volumes, or any arbitrary points on any projectable surface and in any position.

You can view labels for the points of a graph. These labels include not only the graph point's number, 

but also its X and Y values. If some points on the graph are labeled, when returning to the normal 

results view, the labels also appear in the results view.

15.11.2 Graph Lines options

Menu: Options->Graphs

Outline in model: shows in the model where the line and border graphs are drawn

Grids: Tell GiD whether or not to draw grids.

Current Style: Choose what the new graphs should look like. The possible styles are: Dot, Line, and 

Dot-Line.

Change Style Graph: Change the style of the selected graph.

Change Colour Graph: Change the colour of the selected graph.

Change Line Width: Change the width of the graph lines.

Change Line Pattern: Switch between different line patterns, useful with a b/w printer.

Change Point Size: Change the point size for Dot and Dot-Line styles.

Change Title Graph: Change the title of the selected graph.

Invert graph sense: changes the orientation of the graph for the boundary and line graphs.

Delete graph: allows to delete single graphs.

Title: Change the title, change its position, or reset its value.

Reset axis values: resets the fixed limits of the x and y axis.

X_Axis: Set min and max values and divisions for the X axis, reset them, and change the label, and 

number of divisions of the grid.

Y_Axis: Set min and max values and divisions for the Y axis, reset them, and change the label, and 

number of divisions of the grid..

Clear graphs: deletes all graphs



183Graph Lines File Format

15.11.3 Graph Lines File Format

The graph file that GiD uses is a standard ASCII file.

Every line of the file is a point on the graph with X and Y coordinates separated by a space. 

Comment lines are also allowed and should begin with a '#'. 

The title of the graph and the labels for the X and Y axes can also be configured.

If a comment line contains the Keyword 'Graph:' the string between quotes that follows this keyword will 

be used as the title of the graph. The string between quotes that follows the keywords 'X:' and 'Y:' will be 

used as labels for the X- and Y-axes respectively. The same is true for the Y axis, but with the Keyword 

'Y:'.

Example:

# Graph: "Nodes 26, 27, 28, ... 52 Graph." 

# 

# X: "Szz-Nodal_Streess" Y: "Sxz-Nodal_Stress" 

-3055.444 1672.365 

-2837.013 5892.115 

-2371.195 666.9543 

-2030.643 3390.457 

-1588.883 -4042.649 

-1011.5 1236.958 

# End

15.11.4 View graphs window

From this window diferents kinds of graphs can be created. The colour, line style, names of these 

graphs can be also changed from this windows. A grid can be drawn as reference, and several other 

options can be personalized.
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Graphs window: the Create panel

From this panel, following options are present: 

Point evolution: a graph of the evolution of the selected result along all the steps, of the default 

analysis, is created after pressing the 'Apply' button and selecting some nodes or points. 

Point graph: a graph of one result against another of the selected results is created after pressing 

the 'Apply' button and selecting some nodes or points. The option 'all steps' shows the cross-result 

evolution along all steps inside the default analysis.

Border graph: displays a graph of the results on the selected border, using the x, y, z or line distance 

as abscissa.

Line graph:  also called 'section graph' displays a graph defined by the line conectig two selected 

nodes of surfaces or volumes, or any arbitrary points on any projectable surface and in any position.

No graphs: deletes all the created graphs.
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Graphs window: the General Options panel

Several options regarding the view of the displayed graphs can be personalized

Graphs window: the Graph Management panel

Several options related to individual graphs can be personalized, and deleted.

15.12 Result surface

This option uses a result component, or a scalar value, and draws a 3D surface above the mesh 

following the normals of this mesh. It can be seen as an extrusion of the mesh along its normals with the 

result as factor, like the beam diagrams but with surfaces.

Result surface is supported for results defined over nodes.
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With the Show elevations option inside the menu Options -> Result Surface, you can choose how the 

elevations (lines or faces that connect the result surface with the underlying mesh) are drawn:

None: The mesh and its result surface are drawn separately, without interconnecting lines or faces.

Extruded nodes:  Lines are drawn between the original nodes of the mesh and the extruded ones, 

i.e. the nodes of the result surface.

Extruded edges: Faces are drawn between the original edges (of the elements) of the mesh and the 

extruded ones, i.e. the edges of the result surface.

Contour fill:  Switches On or Off the contour fill representation of the result used to create the 3D 

surface.

15.13 Deform Mesh

Volumes, surfaces and cuts can be deformed according to a nodal vector and a factor. When doing this 

all the results are drawn on the deformed volumes, surfaces and cuts. In GiD this is called Main 

Geometry. Thus, when the Main Geometry is deformed, results are also drawn distorted; and when 

Main geometry is in its original state, results also drawn in their original state.

Deformation is supported for results defined over nodes.

The View results window allows you to do this.

Menu: Window->View results...

Reference mesh panel

The Main Mesh panel allows the user to deform the mesh, thus all the results visualization will be drawn 

on this deformed mesh.

The Reference mesh panel creates a fixed copy of the actual mesh representation just for comparison 

purposes. Although this copy can also be deformed, and with a different result than the one used for the 

Main Mesh, the results will not be drawn on this mesh.
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In the upper part of this window, you choose between the Original state of the Main Geometry and the 

Deformed state, for which a nodal vectorial result, and an analysis and step, must be selected and a 

factor entered.

There is also a Reference Geometry option. This lets you visualize volumes, surfaces or cuts like Main 

Geometry does, but NO results can be displayed over these volumes, surfaces or cuts. It is merely 

provided as a reference, to contrast several deformations or changes in the original geometry. 

Remember that the current Mesh Display Style will be used for the Reference Geometry and it can only 

be changed when redoing the mesh.

In the lower part of the window, the Reference Geometry can be configured. You can choose between:

Off, so this reference visualization is not displayed;

Original, if Main Geometry is deformed and you wish to compare it to its original state without losing 

a results representation;

Deformation, where after providing an analysis, step, result and factor, you can use it to contrast two 

deformation states, or a deformed state and an original geometry; or

Color, where the colour of the reference meshes can be specified as the same as, or different from, 

the original meshes.

There are two more interesting options:

Position vector:  normally the deformation result is relative to the original coordinates of the mesh, 

but if the result is a new absolute position for the nodes of the mesh, then the user should check this 

option.

fixed deformation: if this option is checked, the deformation will use the same fixed factor, instead of 

using the GiD suggested one, which varies acording to the magnitude of the deformation.

15.14 Line diagrams

Menu:  View results->Line diagrams 

This result visualization option is only active when line elements are used in the mesh, and will only be 

represented over these line elements. When using this result visualization option, graph-style lines will 

be drawn over the line elements.

When drawing a Scalar Diagram , the graph-style lines are drawn on a plane parallel to the screen 

(with its normal vector pointing out of the screen) when this result view is selected. The positive 'axis' will 

be the vector resulting from the cross product between this normal vector and the one that the line 

defines. 

When drawing a Vector Diagram , the graph-style lines are drawn on a plane that includes the result 

vector and the vector that the line defines. The graph-style lines represent the module of this vector. The 

positive 'axis' is also defined by the result vector. As modules are positive, to allow negative values, the 

input format for vector results allows the introduction of a fourth component: the signed vector module 

(see Postprocess results format: ProjectName.post.res ). 

There is a Show Elevations option only accessible through the Right buttons  menu under Results -> 

LineDiagram -> Options. Elevations are lines that connect the nodes and the gauss points of the line 
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element and the graph-style line that represents the result. The options are: 

None:  to switch the elevations off; 

Nodes only:  to draw the elevation lines only on the nodes; 

Whole line:  to draw the elevation lines along the whole line, using nodes and gauss points; 

Filled line:  to draw orange filled elevations; 

Contour filled line:   the colors used to draw the filled elevations will be the same as a contour fill 

done along the line. 

15.15 Integrate

With this option the user is able to:

This step: get the integral value of a scalar or vectorial result over a set of elements.

All step: get a graph of the integral values across all the analysis steps, of a scalar or vectorial result 

over a set of elements.

15.16 Animation

Menu:  Windows->Animate... 

With this window a little bit of automatization has been done to create animations inside GiD. Nowadays, 

almost all results visualizations are animated. Only stream-lines are not automatized along all the steps 

of the current analysis.

Animate window

Some animations can be done with combined results visualization, or separate analisis, for instance an 

isosurface animation from OLS result of ODDLS analysis with a contour fill of Pressure of the RANSOL 

analysis can also be done with this window. the only constraint is that the same number of steps and the 

same value of the steps should be present in both analysis.

This window lets you create an animation of the current Results View, where the limits can be fixed 
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along the animation with Automatic Limits, and/or an animation of the Deformation of the meshes. To 

the right of the Step: label, the step value is shown. On the slide bar, the step number is shown.

The four buttons under the slide bar are self-explanatory: they 'Rewind', 'Stop', 'Play' and 'Step' the 

animation. Clicking on the slide bar will rewind or advance the animation. The green LED, which 

indicates that an animation is ready, will change to red while the animation is being saved to a file. This 

LED will change back to green when the animation is finished, or the 'Stop' button is pressed.

Options are:

Automatic Limits:  GiD searches for the minimum and maximum values of the results along all the 

steps of the analysis and uses them to draw the results view through all the steps. Previously, it 

needs to visualize some resutls. 

Deformation:  Permits to record animation with a specific deformation. 

Endless:  The animation continues indefinately. 

Total time:  specfies the duration of the clip. 

Delay:  Specify a delay time between steps in milliseconds. 

Use step values as seconds:  the number of step will be used to the duration of the clip. 

From step I to step K:  allows the user to do an animation between step number I  and setp number 

J , both included. This is also useful to skip the first step of an animation of a deformed mesh with a 

result visualization, which is the original state of the mesh, without deformation and without the result 

visualization. 

Save TIFF/JPEG/GIFs on:   Save snapshots, in TIFF, JPEG or GIF format, of each step when the 

'Play' button is pushed. Here the filename given will be used as a prefix to create the 

TIFF/JPEG/GIFs; for instance, if you write MyAnimation, TIFF/JPEG/GIF files will be created with 

names MyAnimation-01.tif/MyAnimation-01.gif, MyAnimation-02.tif/MyAnimation-02.gif, and so on. 

Save MPEG/Avi mjpeg/AVI MS Video 1/AVI raw True Color/AVI raw 15 bpp (VD) /AVI raw 16 bpp 

(MS)/GIF on:   Entering a filename here, a MPEG/AVI/GIF file will be created when 'Play' button is 

pushed. 

Note:  To avoid problems when trying to view an MPEG  format animation in Microsoft Windows , it is 

strongly recommended that you use the Default   menu to select a 'standard' size and press the 

Resize   button. The graphical window will change to this 'standard' size. After finishing the animation, 

simply select Default  on the menu and press the Resize  button, and the previous size will be restored. 

Note:  AVI MS Video 1 uses a simple video compression algorithm, commonly supported by all video 

players. it is the recommended. 

Note:  If you want to recompress the animation with another codec, like xvid, the AVI raw True Color is 

recommended, as it saves each frame without compression. 

Create a stereoscopic animation:  permits to create a stereoscopic animation which for each frame 

the left eye view and the right view are saved, i.e. efectively doubling the width of the frames. Special 

software video players, and hardware, are needed to view this animation correctly. Only AVI format is 

supported at the time. 

Static analysis animation profile:   If the project has only one step, it is possible to simulate an 

animation by generating intermediate steps. Use this option to automatically generate several frames, 

following a lineal, cosine, triangular or sinusoidal interpolation between the normal state and the 

deformed state. 
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Default:  This comobobox permits to choose the resolution of the clip. 

profile factor for pseudo-animation

15.17 Several results

Menu: Window->Several results...

With this window, which appears under Windows -> Several Results, you can select whether to view the 

results one by one, as usual, or to view some results visualization types at once, e.g. a contour fill of 

pressure and velocity vectors at the same time. From this window you can also delete the undesired 

results visualizations. After selecting the desired behaviour, press the Apply button.

Several Result window
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Example showing contour fill, vectors and the minimum and maximum visualization types

15.18 Legends

Menu: Options->Legends

Legends appear when contour visualization, isosurfaces or color vector visualization is used:

Show: Legends can be switched On or Off.

Opaque: Legends can be transparent, showing the result visualization behind them, or opaque.

Show title: With this option the result name of the current visualization appears at the top of the 

legend.

Draw user limits: if enabled, the maximum and minimum value of the legend will be surrounded with 

a box it these where fixed by the user.

Border: if enabled, draws a box arround the legend and comments

Change title: allows the user to change the title of the legend.

Outside: Activating this option, the legend is shown in a separate window, thus leaving more space in 

GiD's windows.

Automatic comments: If this option is activated, information about the type of analysis, the actual 

step and the kind of result, is added at the bottom of the screen (see Automatic comments -pag. 193-

).

15.19 Automatic comments

Menu:  Utilities->Tools->Comments... 

While displaying results, comments can be automatically generated by switching On   the Automatic 

checkbox in the Comments window, which appears by selecting Utilities -> Graphical -> Comments. 
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Comments customization window

If this option is selected and the comment lines are empty, the program will create its own automatic 

comments, like these ones:

Load Analysis , step 3

Display Vectors  of Displacements , |Displacements|  factor 68095.4

Deformation  ( x127.348 ): Displacements  of Load Analysis 2 , step 8

where the fields which will change when the visualization changes are marked in bold.

You can also create your own automatic comments, just by filling in the comment lines. To tell the 

program where the result name, analysis name, etc. should be placed, the following fields can be used:

%an: for the analysis name of the current visualized result

%sv: for the step value of the current visualized result

%vt: for the result visualization type of the current visualized result

%vf: for the vectors factor used in the current visualized result (if any)

%rn: for the result name of the current visualized result

%cn: for the component name of the current visualized result

%da: for the analysis name of the current deformation (if any)

%ds: for the step value of the current deformation (if any)

%dr: for the result name of the current deformation (if any)

%df: for the factor of the current deformation (if any)

GiD will substitute the fields for the values of the current visualization. Fields which cannot be filled will 

be empty.

15.20 Create Results

There are two options to create results:

Menu: Window -> Create result...
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Create result window

With this window, at the moment, only results of the same type can be operated between them using 

one of these operators: '+', '-', '*' and '/'.

 The macro 'Converts a scalar to a vector':

Nodal scalar to vector window

In the figure above it can be seen highlighted the icon of the macro 'Convert a scalar to a vector'.

With this macro the user can create a vector from a scalar result using the entered vector, by multiplying 

the vector with the scalar value. This operation can be applied to all the steps of the analysis with the 'all 

steps' option.
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contour lines 176

contour method 31

contour ranges 176

convert cuts to sets 163

convert to cuts 179

Convert to NURBS line/surface 74

Coon's surface 67

Coordinates 16

Coordinates window 98

Copy 106

Correct sizes 125

cover mesh 168

Create 4-sided surface 67

Create 4-sided surface automatically 67

Create arc 60

Create contact surface 64

Create contact volume 65

Create entities 57

Create line 57

Create line (straight) 57

Create NURBS line 58

Create NURBS surface 61

Create planar surface 68

Create point 57

Create polyline 60

Create volume 64

CreateBoundaries 144

Customizing Problem type registration 154

cylinder 66

Cylindrical coordinates 17

D

Data 115

data report 35

Debugger 119

deform mesh 186

Delete entities 68

Delete nodes/elements 143

display style 166

display vectors 177

Distance 114

distance 114

Divide 69

Draw 139

Draw again 56

Draw assigned sizes 139

Draw condition 120

Draw Element Type 140

Draw material 122

Draw Mesh / No mesh 140

Draw RjumpSkip 141

Draw Sizes 139

Draw Structured Type 140

DXF read 26

DXF write 35

Dynamic box 19

Dynamic pan 44

E

Edit entities 69

Edit mesh 142

Edit NURBS line/surface 71

Element type 135

Elements (structured) 132

End session 38
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Entering cylindrical coordinates 17

Entering global coordinates 16

Entering local coordinates 16

Entering points 15

Entering points by coordinates 16

Entering spherical coordinates 17

Entities informations 111

Entities labels 51

Entities selection 19

Entities share 106

Entities visualization 52

Erase elements 143

Erase entities 68

Erase mesh 142

Escape 21

Exchange material 122

Export 34

Export ACIS 35

Export ASCII project 35

Export calculation file 36

export data report 35

Export DXF 35

export GiD mesh 35

Export IGES 34

Extents (zoom) 41

Extrude 106

F

FEMAP 158

Files 21

Filter 19

filter window 102

Find entities 113

Force mesh 137

Force no mesh 137

Four-sided surface automatic creation 67

Four-sided surface creation 67

Frame 41

G

Gauss points in contour fill 174

Gauss points in smooth contour fill 176

General data 123

Generate mesh 141

Geometry 56

Geometry view 57

GiD basics 2

GIF sequence 188

Graph Lines 181

Graph Lines file format 182

Graph Lines options 182

Graphical displacement 44

Graphs 181

Grid 19

H

Hardcopy 37

Help 150

hidden boundaries 166

Hidden lines 166

Hide drawing regions 48

Hole NURBS surface 74

Hole volume 64

I

Icons 7

Id 113

Identity 113

IGES read 24

IGES write 34

Illumination 44

Image to clipboard 55

Import 24

Import 3DStudio mesh 28
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import ACIS 26

Import CGNS mesh 28

import DXF 26

Import GiD mesh 29

import IGES 24

import NASTRAN 27

import Parasolid 26

import Rhino 27

import Shapefile 27

Import STL mesh 28

import VDA 26

Import VRML mesh 28

Info entities 111

Info problem 111

Initial view (rotation) 44

Insert geometry 34

Insert GiD model 34

Internet Retrieve 118

Intersection 75

Intersection multiple lines 75

Intersection Multiple surfaces 76

Intersection surface lines 76

intersection volume volume 76

Interval data 122

Intervals 123

Invoking GiD 4

Iso line 179

Iso Surface 179

iso surfaces colours 179

iso surfaces with results 179

Isoline 179

Isosurface 179

K

Keyboard shortcut 101

L

Label 51

Label lists (holes) 112

Layers 93

Layers ON save 35

Leaving commands 21

legends 191

Line (straight) creation 57

line diagrams 187

line options 165

Lines 166

Lines intersection (Multiple) 75

Lines normals 52

Lines operations 70

Lines sense swap 52

Lines-surface intersection 76

List 111

Load 118

Local axes 124

Local/global coordinates 16

M

Macros 101

marching cube 31

Material (new) 122

Materials 121

Mcopy 106

Mesh 124

Mesh cancel 142

Mesh criteria 137

Mesh edit 142

Mesh generation 141

Mesh quality 144

Mesh read 29

Mesh write 35

Meshing 124

Meshing data reset 139
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Mirror 106

Mode 56

Mouse 13

Move 110

Move node 142

Move point 69

Move screen objects 98

MPEG files 188

Multiple lines intersection 75

multiple meshes 158

Multiple surfaces intersection 76

Multiple views 55

Multiple windows 55

N

NASTRAN 158

NASTRAN read 27

New 23

New material 122

Normal in surface option 18

Normal projection 47

Normals 52

Notes 105

NURBS line conversion 74

NURBS line creation 58

NURBS line edition 71

NURBS surface creation 61

NURBS surface hole 74

O

Object axes rotation 42

Offset 106

Online Help 150

open multiple files 158

Open project 23

open several files 158

Option Arc center 19

Option base in points 18

Option normal in surface 18

Option point in line 18

Option point in surface 18

Option tangent in line 18

P

Page/image setup 37

Pan (graphical) 44

Parallel lines. NURBS surface 61

Parametric line 59

Parametric surface 63

Parasolid read 26

particle tracing 179

Perspective 47

Perspective projection 47

Planar surface creation 68

Plane XY (Original) 43

Plane XZ 43

Plane YZ 43

Point (show) 113

Point creation 57

Point definition 15

Point enter window 98

Point in line option 18

Point in surface option 18

point options 165

Points 15

Points rotation 43

polygon 66

Polyline 71

Polyline creation 60

Post-processing change light vector 166

Post-processing culling 166

Post-processing cut planes 163

Post-processing cuts 163
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Post-processing divide 163

Post-processing Do Cuts 163

Post-processing Fast-rotation 166

Post-processing Make a cut 163

Post-processing opaque 166

Post-processing render 166

Post-processing select meshes/sets/cuts 166

Post-processing transparent 166

Postprocess introduction 155

postprocess utilities 160

Postprocessing no results 170

Postprocessing results 170

Preferences 79

Preprocess/Postprocess 36

Print 38

Print to file 37

prism 66

Problem data 123

Problem information 111

Problem type 117

Problemtype 118

Q

Quality of the mesh 144

Quit 38

R

radius 114

Read 3DStudio mesh 28

Read ACIS 26

Read batch window 99

Read CGNS mesh 28

Read DXF 26

Read IGES 24

read multiple files 158

Read NASTRAN 27

Read Parasolid 26

Read project 23

Read Rhino 27

Read saved project 21

read several files 158

Read Shapefile 27

Read STL mesh 28

Read surface mesh 31

Read VDA 26

Read View 53

Read VRML mesh 28

reading post-process files 158

Recent files 38

Redraw (graphical) 44

Register GiD 152

Register Problem type 152

remeshing 158

Remove elements/nodes 143

Render 44

Renumber 112

Repair model 115

Report 105

Reset mesh data 139

Result surface 185

results over isosurfaces 179

results visualization 170

Rhino read 27

Rotate (graphical) 41

Rotate angle 44

Rotate center 43

Rotate object axes 42

Rotate points 43

Rotate screen axes 42

Rotate trackball 42

Rotation 106

S
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Save 21

Save as 24

Save ASCII project 35

Save ON layers 35

Save project 23

Save View 53

Save window configuration 97

saving binary results 158

saving boundaries 158

saving cuts 158

saving graphs 158

saving in binary format 158

saving post-process files 158

scalar diagram 187

Scale 106

Screen axes rotation 42

Script file 32

Search entities 113

Search volume 64

select meshes/sets/cuts 166

Selecting points 19

selection filter 102

selection window 102

Semi-Structured 132

Sequence of commands 101

setting contour fill colors 174

Settings 79

several meshes 158

several results 190

Shadows 49

Shapefile read 27

Shortcut, keyboard 101

Show errors 144

show min max 177

ShowIsolines 179

Signal entities 113

Simplify NURBS line/surface 74

Size of mesh 125

smooth contour fill 176

Smooth elements 143

Solver 147

Spacing 125

sphere 66

Spherical coordinates 17

Split elements 142

Status 110

Stereoscopic animation 188

Stereoscopic movies 188

stereoscopic vision 49

STL 158

STL export 158

STL mesh read 28

Straight line creation 57

stream lines 179

Structured 128

structured concentrate 132

Surface (4-sided) 67

Surface (planar) 68

Surface boolean operations 76

surface intersection 76

Surface mesh 64

Surface mesh read 31

Surface-lines intersection 76

SurfMesh 71

SurfMesh edition 71

Swap arc 71

Swap normals 113

T

Tangent in line option 18

Tcl/Tk 119
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TECPLOT 158

text data report 35

texture 168

textures 168

Three-sided surface creation 67

TIFF sequence 188

Toolbars 97

Toolkit icons 7

Trackball rotation 42

Transform problem type 117

Translation 106

Trimmed NURBS surface 61

Type of element 135

U

Unassign condition 121

Unassign material 122

Uncollapse 75

Undo 79

Units 123

Unload 118

Unstructured 125

Up menus 21

Update problem type 118

User basics 13

User interface 7

Using this manual 1

Utilities 77

V

Variables 79

VDA read 26

vector colours 177

vector diagram 187

Vector filtering 177

vectors detail level 177

vectors options 177

View 39

View entities 52

View geometry 57

View higher entities 52

View process info 149

View Results window 170

Views, several 55

Visit GiD web 154

Visualization 39

visualization troubles 4

Volume boolean operations 76

Volume creation 64

volume intersection 76

VRML mesh 28

W

Window Configuration file 97

Windows 7

windows state 97

Word oriented 13

Write ACIS 35

Write calculation file 36

Write DXF 35

Write IGES 34

Write using template file 36

Z

Zoom 41
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